summaryrefslogtreecommitdiff
path: root/dev-perl/Const-Fast/Const-Fast-0.14.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Const-Fast/Const-Fast-0.14.0-r1.ebuild')
-rw-r--r--dev-perl/Const-Fast/Const-Fast-0.14.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Const-Fast/Const-Fast-0.14.0-r1.ebuild b/dev-perl/Const-Fast/Const-Fast-0.14.0-r1.ebuild
new file mode 100644
index 000000000000..a7a12a5bd500
--- /dev/null
+++ b/dev-perl/Const-Fast/Const-Fast-0.14.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=LEONT
+MODULE_VERSION=0.014
+inherit perl-module
+
+DESCRIPTION="Facility for creating read-only scalars, arrays, and hashes"
+
+SLOT="0"
+KEYWORDS="amd64 arm ppc x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Storable
+ >=dev-perl/Sub-Exporter-Progressive-0.1.7
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.21.0
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+SRC_TEST=do
+mytargets="install"