summaryrefslogtreecommitdiff
path: root/dev-ml/tiny_httpd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-12 07:32:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-12 07:32:04 +0100
commitbd3c6f11646b7601637fa3245cf8a363e9fa0034 (patch)
tree432586d5bca19cc90648717891333e8ae473427b /dev-ml/tiny_httpd
parent3ad0a4619950efcdb234f117cb58611443537534 (diff)
gentoo auto-resync : 12:07:2022 - 07:32:03
Diffstat (limited to 'dev-ml/tiny_httpd')
-rw-r--r--dev-ml/tiny_httpd/Manifest3
-rw-r--r--dev-ml/tiny_httpd/metadata.xml20
-rw-r--r--dev-ml/tiny_httpd/tiny_httpd-0.12.ebuild49
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-ml/tiny_httpd/Manifest b/dev-ml/tiny_httpd/Manifest
new file mode 100644
index 000000000000..ea508c2aa94f
--- /dev/null
+++ b/dev-ml/tiny_httpd/Manifest
@@ -0,0 +1,3 @@
+DIST tiny_httpd-0.12.tar.gz 49124 BLAKE2B c3f407a605dabad1c710a696a3fca5dce04a75deb61e25e9ce572432e0d96cd3029628ea24d17d55a051d1d0f78aa1fd80797e7ff9c0bb7fc9d190e461784cd3 SHA512 99b4d01d4f4d138b122c689b8b3bc5043fc386d6686675311f625bf5fec72c6e1a7513712b00889fe17cd392b8c475440d4f89ee46392aff32ac6ccc39cefe09
+EBUILD tiny_httpd-0.12.ebuild 971 BLAKE2B fe9e0ef9dafc3fd1fd840aa4e507287b84d75f44774f0cc86464d9f5e8c5116c545405799a42bbd242b411143f7c9e9e000b9ce6b68b6aacd21d121cadf78fd5 SHA512 6c3b371cec555aa91d6e02d52ce17706771f03f762fb6aa6cf1fe719c0fac39896d3688fcc4fe1c4df0f9115869a3a68dbcacf496b3d45ef567fca386bdebc7d
+MISC metadata.xml 644 BLAKE2B c4601135ee132599458bf7d9427f1470dc653c1e73ac0b8808cf4211ff3708682394ceb4a55f1a7ab4cf4ee35a5e824e844a110d6761585a8a31b3ae7537bef3 SHA512 1782b868f5a99dba55ec2fe7014242fad166e09b1e03523106557e8fff200bc2e32619cd4da14e55910e3749f6e4b4c6aa4fb39b6616bb30e34f5d21b7d4c50a
diff --git a/dev-ml/tiny_httpd/metadata.xml b/dev-ml/tiny_httpd/metadata.xml
new file mode 100644
index 000000000000..44aded2c1fd1
--- /dev/null
+++ b/dev-ml/tiny_httpd/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <use>
+ <flag name="camlzip">Interface to camlzip for tiny_httpd</flag>
+ </use>
+ <upstream>
+ <doc>https://c-cube.github.io/tiny_httpd/</doc>
+ <bugs-to>https://github.com/c-cube/tiny_httpd/issues</bugs-to>
+ <remote-id type="github">c-cube/tiny_httpd</remote-id>
+ <maintainer>
+ <name>Simon Cruanes</name>
+ <email>simon.cruanes.2007@m4x.org</email>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/tiny_httpd/tiny_httpd-0.12.ebuild b/dev-ml/tiny_httpd/tiny_httpd-0.12.ebuild
new file mode 100644
index 000000000000..890d8831cf38
--- /dev/null
+++ b/dev-ml/tiny_httpd/tiny_httpd-0.12.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Minimal HTTP server with a small request router"
+HOMEPAGE="
+ https://github.com/c-cube/tiny_httpd
+ https://opam.ocaml.org/packages/tiny_httpd
+"
+SRC_URI="https://github.com/c-cube/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="camlzip ocamlopt test"
+
+RDEPEND="
+ dev-ml/result:=
+ dev-ml/seq:=
+
+ camlzip? ( >=dev-ml/camlzip-1.06:= )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-ml/qtest
+ dev-ml/ounit2
+ dev-ml/ptime
+ dev-ml/qcheck
+ net-misc/curl
+ )
+"
+
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( camlzip )"
+
+src_compile() {
+ local pkgs="tiny_httpd"
+ use camlzip && pkgs="${pkgs},tiny_httpd_camlzip"
+ dune build -p "${pkgs}" -j $(makeopts_jobs) || die
+}
+
+src_install() {
+ dune_src_install tiny_httpd
+ use camlzip && dune_src_install "tiny_httpd_camlzip"
+}