summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-12 07:32:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-12 07:32:04 +0100
commitbd3c6f11646b7601637fa3245cf8a363e9fa0034 (patch)
tree432586d5bca19cc90648717891333e8ae473427b /dev-ml
parent3ad0a4619950efcdb234f117cb58611443537534 (diff)
gentoo auto-resync : 12:07:2022 - 07:32:03
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/Manifest.gzbin34500 -> 34823 bytes
-rw-r--r--dev-ml/ptime/Manifest3
-rw-r--r--dev-ml/ptime/metadata.xml35
-rw-r--r--dev-ml/ptime/ptime-1.0.0.ebuild32
-rw-r--r--dev-ml/tiny_httpd/Manifest3
-rw-r--r--dev-ml/tiny_httpd/metadata.xml20
-rw-r--r--dev-ml/tiny_httpd/tiny_httpd-0.12.ebuild49
7 files changed, 142 insertions, 0 deletions
diff --git a/dev-ml/Manifest.gz b/dev-ml/Manifest.gz
index f6f3a9ce6e91..1918c4503a91 100644
--- a/dev-ml/Manifest.gz
+++ b/dev-ml/Manifest.gz
Binary files differ
diff --git a/dev-ml/ptime/Manifest b/dev-ml/ptime/Manifest
new file mode 100644
index 000000000000..0383bed310a9
--- /dev/null
+++ b/dev-ml/ptime/Manifest
@@ -0,0 +1,3 @@
+DIST ptime-1.0.0.tbz 33749 BLAKE2B 6765924f624a92c69495883accd47c66294f49e2d2841fafc66444369b97b9dceaecac0c00a14cba2e8e710bf85c6d5759f419e83d4d0a7bee56c197d06bb000 SHA512 df2410d9cc25a33083fe968a584b8fb4d68ad5c077f3356da0a20427e6cd8756a5b946b921e5cf8ed4097f2c506e93345d9dca63b113be644d5a7cc0753d1534
+EBUILD ptime-1.0.0.ebuild 558 BLAKE2B ad8ce46853545c04f65e32d3c4a278ac395a2aa1b58737235faf11176704c6644435eca4ff23563ddac9a58c6ab3d2c33602ef9db5340dcc8a92d1e94930591c SHA512 6d6647456a98f8651a3573e0321e6833c744de5c6629a8026e37de1be2975d247a0085147cc932e91456d5b31b1787acf4b4a3fd8bd056e47b9c4cc742082d40
+MISC metadata.xml 1340 BLAKE2B 5658303c39bee6aa4a5629c99c9bf73d6e55eede8b996b41afe3a702454db99149afd968045e494d65d38e9d08bf8bb2a57e75ccf88a68eca80ec102e2891c6a SHA512 121cc3ffc375fd72c8d28fc26c9fb99753cd0a6507e661a3806a78fb3b162c1cb73511587357ae3344fcbcb7155a20b7387d57dcd06bb593c8a18aa9136e4079
diff --git a/dev-ml/ptime/metadata.xml b/dev-ml/ptime/metadata.xml
new file mode 100644
index 000000000000..13860735d090
--- /dev/null
+++ b/dev-ml/ptime/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription lang="en">Ptime has platform independent POSIX time support in pure OCaml. It
+provides a type to represent a well-defined range of POSIX timestamps
+with picosecond precision, conversion with date-time values,
+conversion with [RFC 3339 timestamps][rfc3339] and pretty printing to
+a human-readable, locale-independent representation.
+
+The additional Ptime_clock library provides access to a system POSIX
+clock and to the system's current time zone offset.
+
+Ptime is not a calendar library.
+
+Ptime has no dependency. Ptime_clock depends on your system library or
+JavaScript runtime system. Ptime and its libraries are distributed
+under the ISC license.
+
+[rfc3339]: http://tools.ietf.org/html/rfc3339
+
+Home page: http://erratique.ch/software/ptime</longdescription>
+ <upstream>
+ <doc>https://erratique.ch/software/ptime/doc/</doc>
+ <bugs-to>https://github.com/dbuenzli/ptime/issues</bugs-to>
+ <remote-id type="github">dbuenzli/ptime</remote-id>
+ <maintainer>
+ <name>Daniel Bünzli</name>
+ <email>daniel.buenzli@erratique.ch</email>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ptime/ptime-1.0.0.ebuild b/dev-ml/ptime/ptime-1.0.0.ebuild
new file mode 100644
index 000000000000..49d8a2f7ff44
--- /dev/null
+++ b/dev-ml/ptime/ptime-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam findlib
+
+DESCRIPTION="POSIX time for OCaml"
+HOMEPAGE="
+ https://erratique.ch/software/ptime
+ https://github.com/dbuenzli/ptime
+ https://opam.ocaml.org/packages/ptime/
+"
+SRC_URI="https://erratique.ch/software/ptime/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+ dev-ml/topkg
+"
+BDEPEND="dev-ml/ocamlbuild"
+
+OPAM_FILE=opam
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}
diff --git a/dev-ml/tiny_httpd/Manifest b/dev-ml/tiny_httpd/Manifest
new file mode 100644
index 000000000000..ea508c2aa94f
--- /dev/null
+++ b/dev-ml/tiny_httpd/Manifest
@@ -0,0 +1,3 @@
+DIST tiny_httpd-0.12.tar.gz 49124 BLAKE2B c3f407a605dabad1c710a696a3fca5dce04a75deb61e25e9ce572432e0d96cd3029628ea24d17d55a051d1d0f78aa1fd80797e7ff9c0bb7fc9d190e461784cd3 SHA512 99b4d01d4f4d138b122c689b8b3bc5043fc386d6686675311f625bf5fec72c6e1a7513712b00889fe17cd392b8c475440d4f89ee46392aff32ac6ccc39cefe09
+EBUILD tiny_httpd-0.12.ebuild 971 BLAKE2B fe9e0ef9dafc3fd1fd840aa4e507287b84d75f44774f0cc86464d9f5e8c5116c545405799a42bbd242b411143f7c9e9e000b9ce6b68b6aacd21d121cadf78fd5 SHA512 6c3b371cec555aa91d6e02d52ce17706771f03f762fb6aa6cf1fe719c0fac39896d3688fcc4fe1c4df0f9115869a3a68dbcacf496b3d45ef567fca386bdebc7d
+MISC metadata.xml 644 BLAKE2B c4601135ee132599458bf7d9427f1470dc653c1e73ac0b8808cf4211ff3708682394ceb4a55f1a7ab4cf4ee35a5e824e844a110d6761585a8a31b3ae7537bef3 SHA512 1782b868f5a99dba55ec2fe7014242fad166e09b1e03523106557e8fff200bc2e32619cd4da14e55910e3749f6e4b4c6aa4fb39b6616bb30e34f5d21b7d4c50a
diff --git a/dev-ml/tiny_httpd/metadata.xml b/dev-ml/tiny_httpd/metadata.xml
new file mode 100644
index 000000000000..44aded2c1fd1
--- /dev/null
+++ b/dev-ml/tiny_httpd/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <use>
+ <flag name="camlzip">Interface to camlzip for tiny_httpd</flag>
+ </use>
+ <upstream>
+ <doc>https://c-cube.github.io/tiny_httpd/</doc>
+ <bugs-to>https://github.com/c-cube/tiny_httpd/issues</bugs-to>
+ <remote-id type="github">c-cube/tiny_httpd</remote-id>
+ <maintainer>
+ <name>Simon Cruanes</name>
+ <email>simon.cruanes.2007@m4x.org</email>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/tiny_httpd/tiny_httpd-0.12.ebuild b/dev-ml/tiny_httpd/tiny_httpd-0.12.ebuild
new file mode 100644
index 000000000000..890d8831cf38
--- /dev/null
+++ b/dev-ml/tiny_httpd/tiny_httpd-0.12.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Minimal HTTP server with a small request router"
+HOMEPAGE="
+ https://github.com/c-cube/tiny_httpd
+ https://opam.ocaml.org/packages/tiny_httpd
+"
+SRC_URI="https://github.com/c-cube/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="camlzip ocamlopt test"
+
+RDEPEND="
+ dev-ml/result:=
+ dev-ml/seq:=
+
+ camlzip? ( >=dev-ml/camlzip-1.06:= )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-ml/qtest
+ dev-ml/ounit2
+ dev-ml/ptime
+ dev-ml/qcheck
+ net-misc/curl
+ )
+"
+
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( camlzip )"
+
+src_compile() {
+ local pkgs="tiny_httpd"
+ use camlzip && pkgs="${pkgs},tiny_httpd_camlzip"
+ dune build -p "${pkgs}" -j $(makeopts_jobs) || die
+}
+
+src_install() {
+ dune_src_install tiny_httpd
+ use camlzip && dune_src_install "tiny_httpd_camlzip"
+}