summaryrefslogtreecommitdiff
path: root/dev-ml/sedlex/sedlex-2.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-ml/sedlex/sedlex-2.5.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-ml/sedlex/sedlex-2.5.ebuild')
-rw-r--r--dev-ml/sedlex/sedlex-2.5.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-ml/sedlex/sedlex-2.5.ebuild b/dev-ml/sedlex/sedlex-2.5.ebuild
index 70cb278e79a8..cc4748a81f3b 100644
--- a/dev-ml/sedlex/sedlex-2.5.ebuild
+++ b/dev-ml/sedlex/sedlex-2.5.ebuild
@@ -10,12 +10,6 @@ HOMEPAGE="https://github.com/ocaml-community/sedlex"
SRC_URI="https://github.com/ocaml-community/${PN}/archive/v${PV}.tar.gz
-> ${P}.tar.gz"
-FILES=( DerivedCoreProperties extracted/DerivedGeneralCategory PropList )
-for file in ${FILES[@]} ; do
- SRC_URI+=" https://www.unicode.org/Public/12.1.0/ucd/${file}.txt
- -> ${P}-${file##*/}.txt"
-done
-
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
@@ -34,3 +28,10 @@ src_compile() {
--ignore-promoted-rules
eend $? || die
}
+
+dune_src_test() {
+ ebegin "Testing"
+ dune runtest --display short --profile release \
+ --ignore-promoted-rules
+ eend $? || die
+}