summaryrefslogtreecommitdiff
path: root/dev-ml/sedlex/sedlex-2.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-ml/sedlex/sedlex-2.5.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-ml/sedlex/sedlex-2.5.ebuild')
-rw-r--r--dev-ml/sedlex/sedlex-2.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/sedlex/sedlex-2.5.ebuild b/dev-ml/sedlex/sedlex-2.5.ebuild
new file mode 100644
index 000000000000..70cb278e79a8
--- /dev/null
+++ b/dev-ml/sedlex/sedlex-2.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="An OCaml lexer generator for Unicode"
+HOMEPAGE="https://github.com/ocaml-community/sedlex"
+SRC_URI="https://github.com/ocaml-community/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+FILES=( DerivedCoreProperties extracted/DerivedGeneralCategory PropList )
+for file in ${FILES[@]} ; do
+ SRC_URI+=" https://www.unicode.org/Public/12.1.0/ucd/${file}.txt
+ -> ${P}-${file##*/}.txt"
+done
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/gen:=
+ dev-ml/ppxlib:=
+ dev-ml/uchar:=
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ebegin "Building"
+ dune build @install --display short --profile release \
+ --ignore-promoted-rules
+ eend $? || die
+}