summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-uri/ocaml-uri-1.9.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocaml-uri/ocaml-uri-1.9.4.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-uri/ocaml-uri-1.9.4.ebuild')
-rw-r--r--dev-ml/ocaml-uri/ocaml-uri-1.9.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ocaml-uri/ocaml-uri-1.9.4.ebuild b/dev-ml/ocaml-uri/ocaml-uri-1.9.4.ebuild
new file mode 100644
index 000000000000..53b7fbd0612d
--- /dev/null
+++ b/dev-ml/ocaml-uri/ocaml-uri-1.9.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib opam
+
+DESCRIPTION="RFC3986 URI parsing library for OCaml"
+HOMEPAGE="https://github.com/mirage/ocaml-uri https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-ml/ocaml-re:=
+ dev-ml/sexplib:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_type_conv:=
+ dev-ml/stringext:=
+ dev-ml/type-conv:=
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.0.2 )
+ dev-ml/jbuilder
+"
+
+src_install() {
+ opam_src_install uri
+}