summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-uri
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocaml-uri
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-uri')
-rw-r--r--dev-ml/ocaml-uri/Manifest3
-rw-r--r--dev-ml/ocaml-uri/metadata.xml11
-rw-r--r--dev-ml/ocaml-uri/ocaml-uri-1.9.4.ebuild33
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-ml/ocaml-uri/Manifest b/dev-ml/ocaml-uri/Manifest
new file mode 100644
index 000000000000..56dda47612d4
--- /dev/null
+++ b/dev-ml/ocaml-uri/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-uri-1.9.4.tar.gz 213917 BLAKE2B 3b76ae2f39a7a97e581791e32e7ec302faacaf883ae82bb635497f205a7bb12b331f2ef34f834c4b22b56433fef75b6ba2c60db6b66f13997290e108f6f0f38b SHA512 c2314c55d1d89bb7824e6bd2aad57fa2bdc4889d5e6c0b4ce75f4ca33660d510d7ab125ff0f340f4688930f3ddac13193d34762f912cc70c4ce30aa206f32ddc
+EBUILD ocaml-uri-1.9.4.ebuild 662 BLAKE2B cfcb89038e02acf1459996271e66c20427ea627f78b16fe35e8301ee461a5ccd5fac2b9c5209890fed528cf5663d00c11e4465399c9a5306ee4c5f2550d032df SHA512 cb4a2fe73b6fd7f9148e38ee3ae62cfada521ccea926f7217e5b8e49718dab8bd22fbae4adb7f0b0470e468d4bc32c1397c4bebe6b54908388d295d04eb200b5
+MISC metadata.xml 357 BLAKE2B 3977236c1143a41d3f8893b1b15484578dacb36306bcb415ee1e5484204ad00ae9ba1f79ad130e3be45f1b2b061b0669191c686c20c810fc1397229e74e6c73c SHA512 6dee6f70da15edb4559f0e3c82e1b46e3e72ce98666bf122fc5e61d905e72629716d724f8d77d03025c7952bfcc13fdebca4b1e0e96da3806548286bf7df3edd
diff --git a/dev-ml/ocaml-uri/metadata.xml b/dev-ml/ocaml-uri/metadata.xml
new file mode 100644
index 000000000000..b6a6ada36e6c
--- /dev/null
+++ b/dev-ml/ocaml-uri/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mirage/ocaml-uri</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-uri/ocaml-uri-1.9.4.ebuild b/dev-ml/ocaml-uri/ocaml-uri-1.9.4.ebuild
new file mode 100644
index 000000000000..53b7fbd0612d
--- /dev/null
+++ b/dev-ml/ocaml-uri/ocaml-uri-1.9.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib opam
+
+DESCRIPTION="RFC3986 URI parsing library for OCaml"
+HOMEPAGE="https://github.com/mirage/ocaml-uri https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-ml/ocaml-re:=
+ dev-ml/sexplib:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_type_conv:=
+ dev-ml/stringext:=
+ dev-ml/type-conv:=
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.0.2 )
+ dev-ml/jbuilder
+"
+
+src_install() {
+ opam_src_install uri
+}