summaryrefslogtreecommitdiff
path: root/dev-ml/fmt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-ml/fmt
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-ml/fmt')
-rw-r--r--dev-ml/fmt/Manifest2
-rw-r--r--dev-ml/fmt/fmt-0.9.0.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/fmt/Manifest b/dev-ml/fmt/Manifest
index 43a16bb90a4c..1ae379484904 100644
--- a/dev-ml/fmt/Manifest
+++ b/dev-ml/fmt/Manifest
@@ -1,3 +1,5 @@
DIST fmt-0.8.9.tbz 21469 BLAKE2B 4cddf626118c9bdea435f9db4e6a3c0b92b49b2c07d1b0f708ae7b82963453be666ad49df196d98b466236509d3fa5a519e191da6b2385a308d1019f1583f0b5 SHA512 19b97caf5d2dbe86cd75bec478707b8f4e4b899b2a11ce04790dc5acb5c9ed6ea98047de52ee50c6480231a16307af2541eabaa94d18d7d008f7a67496f5f626
+DIST fmt-0.9.0.tbz 22699 BLAKE2B 6c251b7c32093a5860b8e5c18f6a92573e664e8a20eb4b85dc6e601a04045d9c55c1e4a4f5cb879ccc92046c15c5ff97d1877ab78ecfaa2a4aa83a9f49fd409e SHA512 66cf4b8bb92232a091dfda5e94d1c178486a358cdc34b1eec516d48ea5acb6209c0dfcb416f0c516c50ddbddb3c94549a45e4a6d5c5fd1c81d3374dec823a83b
EBUILD fmt-0.8.9-r1.ebuild 834 BLAKE2B 190d96c89021110250dcec8a7fcf6afcffc25fff399bc8b44a312efcda447d2444bd9b4194e245843f189746dfd94970dbda218a6727248ef6d2ff94e657d728 SHA512 7908d43f5cb907314c301a0524750fc2e2a97c7a027e118ce235d959863f2ca0bc1f154365518bfecedbac9e458ffbea5cf8989199eaee666c4f6545726a574a
+EBUILD fmt-0.9.0.ebuild 871 BLAKE2B ffaff296b0a6e5988cf0896584727e19f5f2176bfc118021fcd64999a9a02769cc0a1bb661565a10abad603a7d094d7508a8327f0fe52db01c84509ccc55f2b5 SHA512 2632ac52a642ccc8f5fedf774664fedb37369805b91029816a3c8bd771386abbf7bb56b94fa9ef9e3718eca03833ffa64c7bbf4b41033b6da049e77a509d607f
MISC metadata.xml 245 BLAKE2B fc55e865a04721eb22b544bbdad9960ab2fd5957dc7332f8a3c1b2d162fb6f33ef2d7fe263f1cb80525372b5469b4bd1bde4af0a34c5b2533f1ed540540bd720 SHA512 65b3bea831b7ea0a1bd555c8d768f8733feb52378bc68b92e1156fac09e6bba370c07d9318525c848a23c0f019cb1bbfa9638e4a6ce4f2e6f2487fb90025de63
diff --git a/dev-ml/fmt/fmt-0.9.0.ebuild b/dev-ml/fmt/fmt-0.9.0.ebuild
new file mode 100644
index 000000000000..2c981562f8e6
--- /dev/null
+++ b/dev-ml/fmt/fmt-0.9.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib opam
+
+DESCRIPTION="Combinators to devise OCaml Format pretty-printing functions"
+HOMEPAGE="https://erratique.ch/software/fmt https://github.com/dbuenzli/fmt"
+SRC_URI="https://erratique.ch/software/fmt/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/cmdliner:=[ocamlopt]
+ >=dev-lang/ocaml-4.08:=[ocamlopt]
+ dev-ml/result:=[ocamlopt]
+ dev-ml/stdlib-shims:=[ocamlopt]
+ dev-ml/uchar:=[ocamlopt]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-ml/topkg-0.9
+ dev-ml/ocamlbuild
+ dev-ml/findlib
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --tests $(usex test 'true' 'false') || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test _build/test/test.native || die
+}