summaryrefslogtreecommitdiff
path: root/dev-ml/fmt/fmt-0.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/fmt/fmt-0.9.0.ebuild')
-rw-r--r--dev-ml/fmt/fmt-0.9.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/fmt/fmt-0.9.0.ebuild b/dev-ml/fmt/fmt-0.9.0.ebuild
new file mode 100644
index 000000000000..2c981562f8e6
--- /dev/null
+++ b/dev-ml/fmt/fmt-0.9.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib opam
+
+DESCRIPTION="Combinators to devise OCaml Format pretty-printing functions"
+HOMEPAGE="https://erratique.ch/software/fmt https://github.com/dbuenzli/fmt"
+SRC_URI="https://erratique.ch/software/fmt/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/cmdliner:=[ocamlopt]
+ >=dev-lang/ocaml-4.08:=[ocamlopt]
+ dev-ml/result:=[ocamlopt]
+ dev-ml/stdlib-shims:=[ocamlopt]
+ dev-ml/uchar:=[ocamlopt]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-ml/topkg-0.9
+ dev-ml/ocamlbuild
+ dev-ml/findlib
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --tests $(usex test 'true' 'false') || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test _build/test/test.native || die
+}