summaryrefslogtreecommitdiff
path: root/dev-ml/camlzip/camlzip-1.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /dev-ml/camlzip/camlzip-1.10.ebuild
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'dev-ml/camlzip/camlzip-1.10.ebuild')
-rw-r--r--dev-ml/camlzip/camlzip-1.10.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/camlzip/camlzip-1.10.ebuild b/dev-ml/camlzip/camlzip-1.10.ebuild
new file mode 100644
index 000000000000..3c6a128e841c
--- /dev/null
+++ b/dev-ml/camlzip/camlzip-1.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
+HOMEPAGE="https://github.com/xavierleroy/camlzip"
+SRC_URI="https://github.com/xavierleroy/camlzip/archive/rel$(ver_rs 1- '').tar.gz -> ${P}.tar.gz"
+
+SLOT="1/${PV}"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+RDEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]
+ >=sys-libs/zlib-1.1.3"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-rel$(ver_rs 1- '')"
+
+src_compile() {
+ emake all
+ if use ocamlopt; then
+ emake allopt
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ emake DESTDIR="${D}" install-findlib
+ dosym zip/libcamlzip.a /usr/$(get_libdir)/ocaml/libcamlzip.a
+
+ dodoc README Changes
+}