summaryrefslogtreecommitdiff
path: root/dev-ml/camlzip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /dev-ml/camlzip
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'dev-ml/camlzip')
-rw-r--r--dev-ml/camlzip/Manifest4
-rw-r--r--dev-ml/camlzip/camlzip-1.10.ebuild37
-rw-r--r--dev-ml/camlzip/metadata.xml5
3 files changed, 44 insertions, 2 deletions
diff --git a/dev-ml/camlzip/Manifest b/dev-ml/camlzip/Manifest
index 9c45cd5a2ec5..e6a3543e3202 100644
--- a/dev-ml/camlzip/Manifest
+++ b/dev-ml/camlzip/Manifest
@@ -1,5 +1,7 @@
DIST camlzip-1.06.tar.gz 26499 BLAKE2B a7a1dbe157c0dcb9847bcd6324bbb7cbaf39342d0fdbaed51d2c004ae7b03f8d655fb15da50dae6190b976675e405e28fa2d4fa35a2f4372c50519564d58f981 SHA512 5ef0172927106589620678897f12f054533503a5cf13df71bf4deda43f223d0cd6acce118977e87bce53afe289f367b851f192a8e693274c2bd13549121019dd
DIST camlzip-1.07.tar.gz 26652 BLAKE2B f373ac0427faa9b6a846e9db8f3e48c00ec6885b8a11cc09fae96b5a7656908f172fda73dbea8ddd1b3dbfd98bcfa3e2e67ce9faf2942d1e260fc0a804813a05 SHA512 b92e9db002b9b398fd132c6ecd8098fac4cc7ddb3f770cc412990dcdf4bd62ba358c762d31fb0b5cd6b32f20d3bf4b3410ca6e86c511a438b92ece940f9831bd
+DIST camlzip-1.10.tar.gz 27335 BLAKE2B bbf24953634278589395dd9fcedf1e3becce8dad1f380393dc3ac59589143e1685dc14085ef566e12fb751c6f1a333dd368795a5083b94a43b71e058e86489f3 SHA512 5c42e0d808230e3820b2e7ef34b544ca51a7bf0a484ce4e1c8b1e4966133196bb3ff7c3ca85b9c50050aca389316eb52f0335f6e2ad60c000594a33171b9a9a9
EBUILD camlzip-1.06.ebuild 678 BLAKE2B 1cf4d95499422bce82abc437c7548137cddfe93c96144c943d958b65695a358733f0018e2f60df0726947e09d462ef76ef2889e314461ecc601727bfaf30dc69 SHA512 f33b4b3cb0d158f0514482d67592c357ecda300bcfa5637018fa335b537e05016e4b908f9e3112c6c9c3aa94e829b2ef03d8f071e8931d295354a171bc0c62c1
EBUILD camlzip-1.07.ebuild 809 BLAKE2B 774b993515003a89142706a1c3580bff6e2b1508cccd67b986ef0a521aeb45a9f25a13043db071d0224a5c758a9bf9f2b250421d422eafce943ac14830f1c689 SHA512 1ced2107bda8135e57ed6ef58313332461cc1b001e049ffecbee1e066b7bce1c02e3dcb868a8126445b41c60d867bb381e553e380f55e750ce46ddd215ceac66
-MISC metadata.xml 251 BLAKE2B 5a2cab12190752f3347eda1469de0eedd0e62247a59b4735e891b210368a76615c226b3fda09670f5649e5d886dcb66c2b3da9d9a5c4b002bc8bba68c1216f6f SHA512 9bcbc95bd38801f6d837a4a49932336c8af43fafa8a795c12706b41684878ff966b4a4fd9f922046f2dc00bda806aa3597237c055f8f1693cba6a99d6d84b8ad
+EBUILD camlzip-1.10.ebuild 805 BLAKE2B a4177543efa93743e5d4bc70fc46a4a7af981a20ea72562df8e22774bd31184da4de1922c88a8d10cddc16748e62fa27928c8a33b1f799e376812f76aa4630bb SHA512 f0e9a6a31980cf67cf6bc002152b188b5aa528f6999bbec1c1f5961d2300203452ef6595f826371eb8901c94c5ebdb93ab658fea16c1087b977615643fd27412
+MISC metadata.xml 331 BLAKE2B 0d8f433e2cede398f8cfcf629db7a0f6440766bf9d822e65529135ff915632c578ee0fda0ced5fcec0259aa568b391bda7f2ae070f4c351051b7e68113e17363 SHA512 93244e380436e9779580d7e6a9d8175f00bdac042935ffb0312d6a794af01c88fb4c4f6da42650c121bd7912adb1da0ea6fdf9fa02c367f82c9a8b8ad221f35e
diff --git a/dev-ml/camlzip/camlzip-1.10.ebuild b/dev-ml/camlzip/camlzip-1.10.ebuild
new file mode 100644
index 000000000000..3c6a128e841c
--- /dev/null
+++ b/dev-ml/camlzip/camlzip-1.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
+HOMEPAGE="https://github.com/xavierleroy/camlzip"
+SRC_URI="https://github.com/xavierleroy/camlzip/archive/rel$(ver_rs 1- '').tar.gz -> ${P}.tar.gz"
+
+SLOT="1/${PV}"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+RDEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]
+ >=sys-libs/zlib-1.1.3"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-rel$(ver_rs 1- '')"
+
+src_compile() {
+ emake all
+ if use ocamlopt; then
+ emake allopt
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ emake DESTDIR="${D}" install-findlib
+ dosym zip/libcamlzip.a /usr/$(get_libdir)/ocaml/libcamlzip.a
+
+ dodoc README Changes
+}
diff --git a/dev-ml/camlzip/metadata.xml b/dev-ml/camlzip/metadata.xml
index 57e9234a0ba8..e9aafd4d0149 100644
--- a/dev-ml/camlzip/metadata.xml
+++ b/dev-ml/camlzip/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
<upstream>
<remote-id type="github">xavierleroy/camlzip</remote-id>
</upstream>