summaryrefslogtreecommitdiff
path: root/dev-libs/raft/raft-0.9.25.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-libs/raft/raft-0.9.25.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-libs/raft/raft-0.9.25.ebuild')
-rw-r--r--dev-libs/raft/raft-0.9.25.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/raft/raft-0.9.25.ebuild b/dev-libs/raft/raft-0.9.25.ebuild
new file mode 100644
index 000000000000..fc81de79a010
--- /dev/null
+++ b/dev-libs/raft/raft-0.9.25.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="C implementation of the Raft consensus protocol"
+HOMEPAGE="https://github.com/canonical/raft"
+SRC_URI="https://github.com/canonical/raft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/libuv"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ # ACCESS DENIED issue, #723208
+ sed -i 's#zfs version 2>/dev/null | cut -f 2 -d - | head -1#< /sys/module/zfs/version cut -f 1#' configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-uv
+
+ --disable-benchmark
+ --disable-debug
+ --disable-example
+ --disable-sanitize
+ --disable-static
+
+ $(use_enable test fixture)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}