summaryrefslogtreecommitdiff
path: root/dev-libs/raft
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-libs/raft
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-libs/raft')
-rw-r--r--dev-libs/raft/Manifest3
-rw-r--r--dev-libs/raft/metadata.xml19
-rw-r--r--dev-libs/raft/raft-0.9.25.ebuild49
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-libs/raft/Manifest b/dev-libs/raft/Manifest
new file mode 100644
index 000000000000..6b60b7b8fab6
--- /dev/null
+++ b/dev-libs/raft/Manifest
@@ -0,0 +1,3 @@
+DIST raft-0.9.25.tar.gz 313444 BLAKE2B a2a15287cef28b03b012ea372d83e7d0b70bc561f5996eb36fb5ef898261188ee8dfef1aa1619333ada2c8f20a37aa1af3f68a1d97c11919d521544c89629e55 SHA512 8709a909c527b7062072165356dcc012cf7af6cf85e3a3be515220ea4a863637dd06e7c4376af4284006bce65034002d1639ca52ac1ce108be2efa0725a82b70
+EBUILD raft-0.9.25.ebuild 955 BLAKE2B d526b496e487c1261c14a8fa36bf05ff4794c215229e067d4dfeb6af63bfd721fe8d3d4ebdd09d3d50294ede3474ca934f567c1ab845f20dcc9c9af8d47a7037 SHA512 dfc500d69652d498e9aee9c582200e6e66bdbd9616688c25da3084f39800c54eca90928e00a32b7141a209f8ce8b961b40abd5f897b998acfde8e3191decd9fb
+MISC metadata.xml 755 BLAKE2B df2f0d028fa7b8e27b29facf058e32cfcd3352415ed4a682499a8a9bfccab115b174d30750a66d9a811da90fe5deb68ab9c2344f7c691d158d48c36d76da9db4 SHA512 95093f3a838955c8a109dfea975d73698bc5aade34bd54fc5dbbe9ec6e5ec9f092cdb939c4f91290babacdd6ae5ef72027201bd731955f8337ec21e49713a3c7
diff --git a/dev-libs/raft/metadata.xml b/dev-libs/raft/metadata.xml
new file mode 100644
index 000000000000..c96395f90242
--- /dev/null
+++ b/dev-libs/raft/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>juippis@gentoo.org</email>
+ <name>Joonas Niilola</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>virtualization@gentoo.org</email>
+ <name>Gentoo Virtualization Project</name>
+ </maintainer>
+ <longdescription>
+ The library has modular design: its core part implements only the core
+ Raft algorithm logic, in a fully platform independent way. On top of that,
+ a pluggable interface defines the I/O implementation for networking
+ (send/receive RPC messages) and disk persistence (store log entries and
+ snapshots).
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-libs/raft/raft-0.9.25.ebuild b/dev-libs/raft/raft-0.9.25.ebuild
new file mode 100644
index 000000000000..fc81de79a010
--- /dev/null
+++ b/dev-libs/raft/raft-0.9.25.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="C implementation of the Raft consensus protocol"
+HOMEPAGE="https://github.com/canonical/raft"
+SRC_URI="https://github.com/canonical/raft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/libuv"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ # ACCESS DENIED issue, #723208
+ sed -i 's#zfs version 2>/dev/null | cut -f 2 -d - | head -1#< /sys/module/zfs/version cut -f 1#' configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-uv
+
+ --disable-benchmark
+ --disable-debug
+ --disable-example
+ --disable-sanitize
+ --disable-static
+
+ $(use_enable test fixture)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}