summaryrefslogtreecommitdiff
path: root/dev-libs/papi/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-03 08:59:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-03 08:59:05 +0000
commite6ba529df30e3fc9dfdf55ec5797f2f764df6e54 (patch)
tree6b38c918c796f792ef4b18b57437c05a1fd46ae8 /dev-libs/papi/files
parentfbe7acf59ebf6dc3f04a6ef108ff3887fa5d7972 (diff)
gentoo auto-resync : 03:12:2022 - 08:59:05
Diffstat (limited to 'dev-libs/papi/files')
-rw-r--r--dev-libs/papi/files/papi-6.0.0.1-configure-clang16.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/papi/files/papi-6.0.0.1-configure-clang16.patch b/dev-libs/papi/files/papi-6.0.0.1-configure-clang16.patch
new file mode 100644
index 000000000000..a56213cdb6d5
--- /dev/null
+++ b/dev-libs/papi/files/papi-6.0.0.1-configure-clang16.patch
@@ -0,0 +1,53 @@
+https://bitbucket.org/icl/papi/pull-requests/406
+
+From 3d09c90d892c845473ba92bb1e9ff0ead4f3eb84 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Mon, 28 Nov 2022 08:44:38 +0100
+Subject: [PATCH] configure: Avoid implicit ints and implicit function
+ declarations
+
+Implicit ints and implicit function declarations were removed from
+the C language in 1999. Relying on them can cause spurious autoconf
+check failures with compilers that do not support them in the default
+language mode.
+--- a/configure.in
++++ b/configure.in
+@@ -577,14 +577,16 @@ fi
+
+ AC_MSG_CHECKING(for working gettid)
+ AC_LINK_IFELSE([AC_LANG_SOURCE([#include <sys/types.h>
+- main() { pid_t a = gettid(); }])],
++ #include <unistd.h>
++ int main() { pid_t a = gettid(); }])],
+ [AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_GETTID, 1, [Full gettid function])],
+ [AC_MSG_RESULT(no)
+ AC_MSG_CHECKING(for working syscall(SYS_gettid))
+ AC_LINK_IFELSE([AC_LANG_SOURCE([#include <sys/types.h>
+ #include <sys/syscall.h>
+- main() { pid_t a = syscall(SYS_gettid); }])],
++ #include <unistd.h>
++ int main() { pid_t a = syscall(SYS_gettid); }])],
+ [AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_SYSCALL_GETTID, 1, [gettid syscall function])],
+ [AC_MSG_RESULT(no)]) ])
+@@ -625,7 +627,7 @@ AC_ARG_WITH(walltimer,
+ #include <stdio.h>
+ #include <time.h>
+ #include <syscall.h>
+- main() {
++ int main() {
+ struct timespec t1, t2;
+ double seconds;
+ if (syscall(__NR_clock_gettime,CLOCK_REALTIME_HR,&t1) == -1) exit(1);
+@@ -646,7 +648,7 @@ AC_ARG_WITH(walltimer,
+ #include <stdio.h>
+ #include <time.h>
+ #include <syscall.h>
+- main() {
++ int main() {
+ struct timespec t1, t2;
+ double seconds;
+ if (syscall(__NR_clock_gettime,CLOCK_REALTIME,&t1) == -1) exit(1);
+--
+2.38.1