summaryrefslogtreecommitdiff
path: root/dev-libs/papi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-03 08:59:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-03 08:59:05 +0000
commite6ba529df30e3fc9dfdf55ec5797f2f764df6e54 (patch)
tree6b38c918c796f792ef4b18b57437c05a1fd46ae8 /dev-libs/papi
parentfbe7acf59ebf6dc3f04a6ef108ff3887fa5d7972 (diff)
gentoo auto-resync : 03:12:2022 - 08:59:05
Diffstat (limited to 'dev-libs/papi')
-rw-r--r--dev-libs/papi/Manifest3
-rw-r--r--dev-libs/papi/files/papi-6.0.0.1-configure-clang16.patch53
-rw-r--r--dev-libs/papi/papi-6.0.0.1-r1.ebuild (renamed from dev-libs/papi/papi-6.0.0.1.ebuild)6
3 files changed, 60 insertions, 2 deletions
diff --git a/dev-libs/papi/Manifest b/dev-libs/papi/Manifest
index a242915b8819..145f42b89f11 100644
--- a/dev-libs/papi/Manifest
+++ b/dev-libs/papi/Manifest
@@ -1,3 +1,4 @@
+AUX papi-6.0.0.1-configure-clang16.patch 2755 BLAKE2B ee43146e4c585004ea4dcee08c4026f07a0b8ed0b8fde54c69998ba2a9b460d27e9f7877a60dfa6cbad332c79c546f861ffbd9be88f829aa7eba360aa4cfa850 SHA512 af3d671efc552342f7af78185154bfb2c48dfd8fed3677851d79b0166b875fd6a0afb6d19536517500f34ba0aa89fb2362189de753b00b2b16a3186e7bd7b5b1
DIST papi-6.0.0.1.tar.gz 4665285 BLAKE2B 5b6b2de8c16510a05a57159ceba591625c78f2a6d4ea62979fea4dd3e72bce73138e36480d82e13713c9ff2298e00330619fa57fdc7f81d75e1ce519b6f600ae SHA512 54c37b49858e921bd1357d8b0bba12c27e40e89b1354d89e5a85672ef3e6d3a4784212079098004256369a172d744580fb283741e7b4ac2d6fa5642bc42ea2ad
-EBUILD papi-6.0.0.1.ebuild 1118 BLAKE2B 841bc96e9e64018da26bc1ee9698d0e202d77fee3dd24dd364018c1bf013fd637d85f035807200acceb91a2ec3d01f1794f69b32e2d5c1613c05b7fc0ce6cbb3 SHA512 9fa6411201f4142169e477ae4f18039fa6076f7b5d58c4f449f6ad6ad14c60ed91d338fef15245c07b1878647a0351d022bb9e716c988ff06b20c77453ee0d9e
+EBUILD papi-6.0.0.1-r1.ebuild 1184 BLAKE2B 3477e6162beb6b7ec6728e365f70e940e856eac72a22370ad981da40ae13a84d40196ba262d0a27c1c9c31658a0f7d71a3a3aef022519942ac71cb4e16a3f0a4 SHA512 95f66df5320f6114cb08dc5154ec9c336ea1a6e64e090555d02c5f809dd8657db0bf2700c3d0c0b6152f253237a5507ea5e6c8e918e1ac135476bec2ee29f44c
MISC metadata.xml 169 BLAKE2B 25149b73446be31f3ea3dd3a6394230987e7d4c601d1605fd3827b37bd99b3301c2e0edb95d0f59a4577ed27919f43c2cc02b1edf62c4012b935a82e709e0c05 SHA512 55c53f74b001bae56ba8c54581a4168335b6b3a28dac23a2102b76795d5fd41de33b8b3e1ec03f9acc6e7a3a77e93b1a6ff3e3967c3156dcbf22b5b5a6245ef5
diff --git a/dev-libs/papi/files/papi-6.0.0.1-configure-clang16.patch b/dev-libs/papi/files/papi-6.0.0.1-configure-clang16.patch
new file mode 100644
index 000000000000..a56213cdb6d5
--- /dev/null
+++ b/dev-libs/papi/files/papi-6.0.0.1-configure-clang16.patch
@@ -0,0 +1,53 @@
+https://bitbucket.org/icl/papi/pull-requests/406
+
+From 3d09c90d892c845473ba92bb1e9ff0ead4f3eb84 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Mon, 28 Nov 2022 08:44:38 +0100
+Subject: [PATCH] configure: Avoid implicit ints and implicit function
+ declarations
+
+Implicit ints and implicit function declarations were removed from
+the C language in 1999. Relying on them can cause spurious autoconf
+check failures with compilers that do not support them in the default
+language mode.
+--- a/configure.in
++++ b/configure.in
+@@ -577,14 +577,16 @@ fi
+
+ AC_MSG_CHECKING(for working gettid)
+ AC_LINK_IFELSE([AC_LANG_SOURCE([#include <sys/types.h>
+- main() { pid_t a = gettid(); }])],
++ #include <unistd.h>
++ int main() { pid_t a = gettid(); }])],
+ [AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_GETTID, 1, [Full gettid function])],
+ [AC_MSG_RESULT(no)
+ AC_MSG_CHECKING(for working syscall(SYS_gettid))
+ AC_LINK_IFELSE([AC_LANG_SOURCE([#include <sys/types.h>
+ #include <sys/syscall.h>
+- main() { pid_t a = syscall(SYS_gettid); }])],
++ #include <unistd.h>
++ int main() { pid_t a = syscall(SYS_gettid); }])],
+ [AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_SYSCALL_GETTID, 1, [gettid syscall function])],
+ [AC_MSG_RESULT(no)]) ])
+@@ -625,7 +627,7 @@ AC_ARG_WITH(walltimer,
+ #include <stdio.h>
+ #include <time.h>
+ #include <syscall.h>
+- main() {
++ int main() {
+ struct timespec t1, t2;
+ double seconds;
+ if (syscall(__NR_clock_gettime,CLOCK_REALTIME_HR,&t1) == -1) exit(1);
+@@ -646,7 +648,7 @@ AC_ARG_WITH(walltimer,
+ #include <stdio.h>
+ #include <time.h>
+ #include <syscall.h>
+- main() {
++ int main() {
+ struct timespec t1, t2;
+ double seconds;
+ if (syscall(__NR_clock_gettime,CLOCK_REALTIME,&t1) == -1) exit(1);
+--
+2.38.1
diff --git a/dev-libs/papi/papi-6.0.0.1.ebuild b/dev-libs/papi/papi-6.0.0.1-r1.ebuild
index f63cab71642c..a42b0ca09acf 100644
--- a/dev-libs/papi/papi-6.0.0.1.ebuild
+++ b/dev-libs/papi/papi-6.0.0.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,6 +20,10 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.0.0.1-configure-clang16.patch
+)
+
src_prepare() {
default