summaryrefslogtreecommitdiff
path: root/dev-lang/python-exec/python-exec-2.4.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /dev-lang/python-exec/python-exec-2.4.6-r1.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'dev-lang/python-exec/python-exec-2.4.6-r1.ebuild')
-rw-r--r--dev-lang/python-exec/python-exec-2.4.6-r1.ebuild26
1 files changed, 4 insertions, 22 deletions
diff --git a/dev-lang/python-exec/python-exec-2.4.6-r1.ebuild b/dev-lang/python-exec/python-exec-2.4.6-r1.ebuild
index d18086c2f138..18343cded128 100644
--- a/dev-lang/python-exec/python-exec-2.4.6-r1.ebuild
+++ b/dev-lang/python-exec/python-exec-2.4.6-r1.ebuild
@@ -27,10 +27,8 @@ RDEPEND="
src_configure() {
local pyimpls=() i EPYTHON
for i in "${_PYTHON_ALL_IMPLS[@]}"; do
- if use "python_targets_${i}"; then
- python_export "${i}" EPYTHON
- pyimpls+=( "${EPYTHON}" )
- fi
+ python_export "${i}" EPYTHON
+ pyimpls+=( "${EPYTHON}" )
done
local myconf=(
@@ -49,29 +47,13 @@ src_install() {
newins - python-exec.conf \
< <(sed -n -e '/^#/p' config/python-exec.conf.example)
- local programs=( python )
- local scripts=( python-config 2to3 idle pydoc pyvenv )
- local i
- for i in "${_PYTHON_ALL_IMPLS[@]}"; do
- if use "python_targets_${i}"; then
- # NB: duplicate entries are harmless
- if python_is_python3 "${i}"; then
- programs+=( python3 )
- scripts+=( python3-config )
- else
- programs+=( python2 )
- scripts+=( python2-config )
- fi
- fi
- done
-
local f
- for f in "${programs[@]}"; do
+ for f in python{,2,3}; do
# symlink the C wrapper for python to avoid shebang recursion
# bug #568974
dosym python-exec2c /usr/bin/"${f}"
done
- for f in "${scripts[@]}"; do
+ for f in python{,2,3}-config 2to3 idle pydoc pyvenv; do
# those are python scripts (except for new python-configs)
# so symlink them via the python wrapper
dosym ../lib/python-exec/python-exec2 /usr/bin/"${f}"