summaryrefslogtreecommitdiff
path: root/dev-lang/python-exec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /dev-lang/python-exec
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'dev-lang/python-exec')
-rw-r--r--dev-lang/python-exec/Manifest4
-rw-r--r--dev-lang/python-exec/python-exec-2.4.6-r1.ebuild26
-rw-r--r--dev-lang/python-exec/python-exec-9999.ebuild26
3 files changed, 10 insertions, 46 deletions
diff --git a/dev-lang/python-exec/Manifest b/dev-lang/python-exec/Manifest
index 299b0c372cd7..10cfd491b50f 100644
--- a/dev-lang/python-exec/Manifest
+++ b/dev-lang/python-exec/Manifest
@@ -1,4 +1,4 @@
DIST python-exec-2.4.6.tar.bz2 87634 BLAKE2B 7b6de8ad0e0603fafd3284e6e3c5247ad83f145ab4db6728914318ae8e6f5aaa3c0247f4e01238fca11519ef72fb1b11436aea7e2b8c988b8717b3f6a2a43c37 SHA512 e05eaf01b83de196a10933636ab6b1a5489a421592df49b8b58eabd0e732de970f902744cd3a06b5ab530a6d69fe6dfa8f270fbb09b9fe3df4ae04d516828050
-EBUILD python-exec-2.4.6-r1.ebuild 4715 BLAKE2B 616fc3530ef6941a016a3b8dd270e4010627f7f6bf6c70eac168080d0fc4199a79d885633859fa3be4fa01e970247003c7bfc42c0dfb7e2fee704a16a425ef9b SHA512 bde8d8c34527ab4aacd164d9b31eb92acc886fc21f11f3c9bbddce6aef453f73dc892b5b65fa964f448e58900d2787d5c328372aa354dceb1d1062b3a78d4507
-EBUILD python-exec-9999.ebuild 4510 BLAKE2B 85c32e0ddd596272424d0c511dfeff5656badff0a0bbcbb596c0d38dc08c63bffed41d7237403d8bc19c204e500ce2b6ce102bdcd588ca08593436898a5a6011 SHA512 aeff34fe79ee3f082a8743cd4ecc6ed0f7abc3f63bc1009f66228e4f146b54449d94aa92404e5bb075f9d5eea042e5a5958c20378107fffd7ee14a01a010bc39
+EBUILD python-exec-2.4.6-r1.ebuild 4306 BLAKE2B 59fd3edded4bd678980e12e658996dda7bb74a140040a1902d07cfeb226bf1a2088fccc5b1f725d23d936d57404adad67e175e63b5ad7c8ca0a929142ca37230 SHA512 91017a7b1a1c10d8536d4587e0d7d27caa74cfa63d1823a354abbf47bb8e2e48022401addb3b8e7cd111a1e2ae7bbc21ae88650c795b3f573c996d220f50b596
+EBUILD python-exec-9999.ebuild 4101 BLAKE2B c9a38a540fb5548d34bb239d3f23bfd3ce3e8f8eea9e01f9d64a92218bced4e15212e25f12a28ff165a80412d7a62dad08f86f8183704da67dcff6238d6c239f SHA512 a57aa9bd6a88ea62e1f8d6b01a3c25491d4b405eda4de05f64a03575f737493700d73581ee2de2d79f3b3a681532f04433c33748a90dd615010340d44a316277
MISC metadata.xml 589 BLAKE2B 7f9fa9750915db8b546b52a560a7fd8d9a63c4f310e423ebdc0508fe9b14363001b30f3c3db26f6d05eec8a44176d62a9335153dff2d55a41a31d3b428cc9ca6 SHA512 2ac0223af0a2cf95d2b18ef415eadb325af0094e4ec361a414b0d68b203dc1c937d3d680af96bdad1e8a48cb5786683bdbbd451f47a0f3a777c075e1690ccf7a
diff --git a/dev-lang/python-exec/python-exec-2.4.6-r1.ebuild b/dev-lang/python-exec/python-exec-2.4.6-r1.ebuild
index d18086c2f138..18343cded128 100644
--- a/dev-lang/python-exec/python-exec-2.4.6-r1.ebuild
+++ b/dev-lang/python-exec/python-exec-2.4.6-r1.ebuild
@@ -27,10 +27,8 @@ RDEPEND="
src_configure() {
local pyimpls=() i EPYTHON
for i in "${_PYTHON_ALL_IMPLS[@]}"; do
- if use "python_targets_${i}"; then
- python_export "${i}" EPYTHON
- pyimpls+=( "${EPYTHON}" )
- fi
+ python_export "${i}" EPYTHON
+ pyimpls+=( "${EPYTHON}" )
done
local myconf=(
@@ -49,29 +47,13 @@ src_install() {
newins - python-exec.conf \
< <(sed -n -e '/^#/p' config/python-exec.conf.example)
- local programs=( python )
- local scripts=( python-config 2to3 idle pydoc pyvenv )
- local i
- for i in "${_PYTHON_ALL_IMPLS[@]}"; do
- if use "python_targets_${i}"; then
- # NB: duplicate entries are harmless
- if python_is_python3 "${i}"; then
- programs+=( python3 )
- scripts+=( python3-config )
- else
- programs+=( python2 )
- scripts+=( python2-config )
- fi
- fi
- done
-
local f
- for f in "${programs[@]}"; do
+ for f in python{,2,3}; do
# symlink the C wrapper for python to avoid shebang recursion
# bug #568974
dosym python-exec2c /usr/bin/"${f}"
done
- for f in "${scripts[@]}"; do
+ for f in python{,2,3}-config 2to3 idle pydoc pyvenv; do
# those are python scripts (except for new python-configs)
# so symlink them via the python wrapper
dosym ../lib/python-exec/python-exec2 /usr/bin/"${f}"
diff --git a/dev-lang/python-exec/python-exec-9999.ebuild b/dev-lang/python-exec/python-exec-9999.ebuild
index b37d3e0c3b6f..f5c7a17a180b 100644
--- a/dev-lang/python-exec/python-exec-9999.ebuild
+++ b/dev-lang/python-exec/python-exec-9999.ebuild
@@ -33,10 +33,8 @@ src_prepare() {
src_configure() {
local pyimpls=() i EPYTHON
for i in "${_PYTHON_ALL_IMPLS[@]}"; do
- if use "python_targets_${i}"; then
- python_export "${i}" EPYTHON
- pyimpls+=( "${EPYTHON}" )
- fi
+ python_export "${i}" EPYTHON
+ pyimpls+=( "${EPYTHON}" )
done
local myconf=(
@@ -55,29 +53,13 @@ src_install() {
newins - python-exec.conf \
< <(sed -n -e '/^#/p' config/python-exec.conf.example)
- local programs=( python )
- local scripts=( python-config 2to3 idle pydoc pyvenv )
- local i
- for i in "${_PYTHON_ALL_IMPLS[@]}"; do
- if use "python_targets_${i}"; then
- # NB: duplicate entries are harmless
- if python_is_python3 "${i}"; then
- programs+=( python3 )
- scripts+=( python3-config )
- else
- programs+=( python2 )
- scripts+=( python2-config )
- fi
- fi
- done
-
local f
- for f in "${programs[@]}"; do
+ for f in python{,2,3}; do
# symlink the C wrapper for python to avoid shebang recursion
# bug #568974
dosym python-exec2c /usr/bin/"${f}"
done
- for f in "${scripts[@]}"; do
+ for f in python{,2,3}-config 2to3 idle pydoc pyvenv; do
# those are python scripts (except for new python-configs)
# so symlink them via the python wrapper
dosym ../lib/python-exec/python-exec2 /usr/bin/"${f}"