summaryrefslogtreecommitdiff
path: root/dev-lang/julia/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
commitc3bc61051d7f12b4c682efa7a5460bbc8815649e (patch)
treeb6d19e96ba3c397fb8278eeb9b68170db92630ba /dev-lang/julia/files
parent3517852e3b8a68d1e997770fc0650c5053bafc6c (diff)
gentoo resync : 07.01.2022
Diffstat (limited to 'dev-lang/julia/files')
-rw-r--r--dev-lang/julia/files/julia-1.1.0-fix_build_system.patch53
-rw-r--r--dev-lang/julia/files/julia-1.6.0-fix-system-csl.patch271
-rw-r--r--dev-lang/julia/files/julia-1.6.5-libgit-1.2.patch (renamed from dev-lang/julia/files/julia-1.7.0-libgit-1.2.patch)0
-rw-r--r--dev-lang/julia/files/julia-1.6.5-llvm_13_compat_part_1.patch (renamed from dev-lang/julia/files/julia-1.7.0-llvm_13_compat_part_1.patch)0
-rw-r--r--dev-lang/julia/files/julia-1.6.5-llvm_13_compat_part_2.patch (renamed from dev-lang/julia/files/julia-1.7.0-llvm_13_compat_part_2.patch)0
-rw-r--r--dev-lang/julia/files/julia-1.6.5-llvm_13_compat_part_3.patch (renamed from dev-lang/julia/files/julia-1.7.0-llvm_13_compat_part_3.patch)0
-rw-r--r--dev-lang/julia/files/julia-1.6.5-make-install-no-build.patch (renamed from dev-lang/julia/files/julia-1.7.0-make-install-no-build.patch)0
-rw-r--r--dev-lang/julia/files/julia-1.7.0-do_not_set_rpath.patch29
-rw-r--r--dev-lang/julia/files/julia-1.7.1-do_not_set_rpath.patch11
-rw-r--r--dev-lang/julia/files/julia-1.7.1-hardcoded-libs.patch (renamed from dev-lang/julia/files/julia-1.7.0-hardcoded-libs.patch)0
10 files changed, 11 insertions, 353 deletions
diff --git a/dev-lang/julia/files/julia-1.1.0-fix_build_system.patch b/dev-lang/julia/files/julia-1.1.0-fix_build_system.patch
deleted file mode 100644
index 394f5900a90e..000000000000
--- a/dev-lang/julia/files/julia-1.1.0-fix_build_system.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff --git a/Make.inc b/Make.inc
-index 81ff923..79e47f1 100644
---- a/Make.inc
-+++ b/Make.inc
-@@ -185,7 +185,7 @@ USE_GPL_LIBS ?= 1
- # Directories where said libraries get installed to
- prefix ?= $(BUILDROOT)/julia-$(JULIA_COMMIT)
- bindir := $(prefix)/bin
--libdir := $(prefix)/lib
-+libdir := $(prefix)/GENTOOLIBDIR
- libexecdir := $(prefix)/libexec
- datarootdir := $(prefix)/share
- docdir := $(datarootdir)/doc/julia
-@@ -417,7 +417,7 @@ ifneq ($(OS), WINNT)
- JCXXFLAGS += -pedantic
- endif
- DEBUGFLAGS := -O0 -ggdb2 -DJL_DEBUG_BUILD -fstack-protector-all
--SHIPFLAGS := -O3 -ggdb2 -falign-functions
-+SHIPFLAGS := GENTOOCFLAGS
- endif
-
- ifeq ($(USECLANG),1)
-@@ -428,7 +428,7 @@ JCFLAGS := -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
- JCPPFLAGS := -fasynchronous-unwind-tables
- JCXXFLAGS := -pipe $(fPIC) -fno-rtti -pedantic
- DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
--SHIPFLAGS := -O3 -g
-+SHIPFLAGS := GENTOOCFLAGS
- ifeq ($(OS), Darwin)
- ifeq ($(USE_LIBCPP), 1)
- MACOSX_VERSION_MIN := 10.8
-@@ -457,7 +457,7 @@ JCFLAGS := -std=gnu11 -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
- JCPPFLAGS :=
- JCXXFLAGS := -pipe $(fPIC) -fno-rtti
- DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
--SHIPFLAGS := -O3 -g -falign-functions
-+SHIPFLAGS := GENTOOCFLAGS
- endif
-
- ifeq ($(USECCACHE), 1)
-diff --git a/doc/Makefile b/doc/Makefile
-index 99e60ee..2027fb5 100644
---- a/doc/Makefile
-+++ b/doc/Makefile
-@@ -30,7 +30,7 @@ deps: UnicodeData.txt
- $(JLCHECKSUM) UnicodeData.txt
-
- clean:
-- -rm -rf _build/* deps/* docbuild.log UnicodeData.txt
-+ @echo "Do not clean doc/_build/html. Just use it..."
-
- cleanall: clean
-
diff --git a/dev-lang/julia/files/julia-1.6.0-fix-system-csl.patch b/dev-lang/julia/files/julia-1.6.0-fix-system-csl.patch
deleted file mode 100644
index 90a097197bff..000000000000
--- a/dev-lang/julia/files/julia-1.6.0-fix-system-csl.patch
+++ /dev/null
@@ -1,271 +0,0 @@
-From 71d7a8a8c12b72bfa362ae955d2ce4dfbdf5b8ba Mon Sep 17 00:00:00 2001
-From: Elliot Saba <staticfloat@gmail.com>
-Date: Fri, 26 Mar 2021 18:40:07 +0000
-Subject: [PATCH 1/2] [build] Add `symlink_system_library` calls for CSL
-
-We differentiate between a `USE_BINARYBUILDER_CSL=0` configuration
-(where we copy the CSL libraries into the Julia build tree) versus a
-`USE_SYSTEM_CSL=1` configuration (where we symlink them in a manner
-similar to other system libararies)
----
- Make.inc | 23 +++++++++++++-
- base/Makefile | 88 ++++++++++++++++++++++++++++++---------------------
- deps/csl.mk | 40 ++++++++---------------
- 3 files changed, 87 insertions(+), 64 deletions(-)
-
-diff --git a/Make.inc b/Make.inc
-index 519720a861ed7..7cba05806e684 100644
---- a/Make.inc
-+++ b/Make.inc
-@@ -596,6 +596,21 @@ else
- SHLIB_EXT := so
- endif
-
-+ifeq ($(OS),WINNT)
-+define versioned_libname
-+$$(if $(2),$(1)-$(2).$(SHLIB_EXT),$(1).$(SHLIB_EXT))
-+endef
-+else ifeq ($(OS),Darwin)
-+define versioned_libname
-+$$(if $(2),$(1).$(2).$(SHLIB_EXT),$(1).$(SHLIB_EXT))
-+endef
-+else
-+define versioned_libname
-+$$(if $(2),$(1).$(SHLIB_EXT).$(2),$(1).$(SHLIB_EXT))
-+endef
-+endif
-+
-+
- ifeq ($(SHLIB_EXT), so)
- define SONAME_FLAGS
- -Wl,-soname=$1
-@@ -1147,6 +1162,8 @@ BB_TRIPLET_LIBGFORTRAN := $(subst $(SPACE),-,$(filter-out cxx%,$(subst -,$(SPACE
- BB_TRIPLET_CXXABI := $(subst $(SPACE),-,$(filter-out libgfortran%,$(subst -,$(SPACE),$(BB_TRIPLET_LIBGFORTRAN_CXXABI))))
- BB_TRIPLET := $(subst $(SPACE),-,$(filter-out cxx%,$(filter-out libgfortran%,$(subst -,$(SPACE),$(BB_TRIPLET_LIBGFORTRAN_CXXABI)))))
-
-+LIBGFORTRAN_VERSION := $(subst libgfortran,,$(filter libgfortran%,$(subst -,$(SPACE),$(BB_TRIPLET_LIBGFORTRAN))))
-+
- # This is the set of projects that BinaryBuilder dependencies are hooked up for.
- BB_PROJECTS := BLASTRAMPOLINE OPENBLAS LLVM SUITESPARSE OPENLIBM GMP MBEDTLS LIBSSH2 NGHTTP2 MPFR CURL LIBGIT2 PCRE LIBUV LIBUNWIND DSFMT OBJCONV ZLIB P7ZIP CSL
- define SET_BB_DEFAULT
-@@ -1479,8 +1496,12 @@ ifneq ($(findstring $(OS),Linux FreeBSD),)
- LIBGCC_NAME := libgcc_s.$(SHLIB_EXT).1
- endif
-
--
-+# USE_SYSTEM_CSL causes it to get symlinked into build_private_shlibdir
-+ifeq ($(USE_SYSTEM_CSL),1)
-+LIBGCC_BUILD_DEPLIB := $(call dep_lib_path,$(build_libdir),$(build_private_shlibdir)/$(LIBGCC_NAME))
-+else
- LIBGCC_BUILD_DEPLIB := $(call dep_lib_path,$(build_libdir),$(build_shlibdir)/$(LIBGCC_NAME))
-+endif
- LIBGCC_INSTALL_DEPLIB := $(call dep_lib_path,$(libdir),$(private_shlibdir)/$(LIBGCC_NAME))
-
- # USE_SYSTEM_LIBM and USE_SYSTEM_OPENLIBM causes it to get symlinked into build_private_shlibdir
-diff --git a/base/Makefile b/base/Makefile
-index e024e546f94d3..2bef6aab7f1f4 100644
---- a/base/Makefile
-+++ b/base/Makefile
-@@ -169,53 +169,69 @@ endif
- # echo "$$P"
-
- define symlink_system_library
--symlink_$1: $$(build_private_libdir)/$1.$$(SHLIB_EXT)
--$$(build_private_libdir)/$1.$$(SHLIB_EXT):
-- REALPATH=`$$(call spawn,$$(build_depsbindir)/libwhich) -p $$(notdir $$@)` && \
-- $$(call resolve_path,REALPATH) && \
-- [ -e "$$$$REALPATH" ] && \
-- ([ ! -e "$$@" ] || rm "$$@") && \
-- echo ln -sf "$$$$REALPATH" "$$@" && \
-- ln -sf "$$$$REALPATH" "$$@"
--ifneq ($2,)
--ifneq ($$(USE_SYSTEM_$2),0)
--SYMLINK_SYSTEM_LIBRARIES += symlink_$1
--endif
-+libname_$2 := $$(notdir $(call versioned_libname,$2,$3))
-+libpath_$2 := $$(shell $$(call spawn,$$(build_depsbindir)/libwhich) -p $$(libname_$2) 2>/dev/null)
-+symlink_$2: $$(build_private_libdir)/$$(libname_$2)
-+$$(build_private_libdir)/$$(libname_$2):
-+ @if [ -e "$$(libpath_$2)" ]; then \
-+ REALPATH=$$(libpath_$2); \
-+ $$(call resolve_path,REALPATH) && \
-+ [ -e "$$$$REALPATH" ] && \
-+ ([ ! -e "$$@" ] || rm "$$@") && \
-+ echo ln -sf "$$$$REALPATH" "$$@" && \
-+ ln -sf "$$$$REALPATH" "$$@"; \
-+ else \
-+ if [ "$4" != "ALLOW_FAILURE" ]; then \
-+ echo "System library symlink failure: Unable to locate $$(libname_$2) on your system!" >&2; \
-+ false; \
-+ fi; \
-+ fi
-+ifneq ($$(USE_SYSTEM_$1),0)
-+SYMLINK_SYSTEM_LIBRARIES += symlink_$2
- endif
- endef
-
- # the following excludes: libuv.a, libutf8proc.a
-
--$(eval $(call symlink_system_library,$(LIBMNAME)))
- ifneq ($(USE_SYSTEM_LIBM),0)
--SYMLINK_SYSTEM_LIBRARIES += symlink_$(LIBMNAME)
-+$(eval $(call symlink_system_library,LIBM,$(LIBMNAME)))
- else ifneq ($(USE_SYSTEM_OPENLIBM),0)
--SYMLINK_SYSTEM_LIBRARIES += symlink_$(LIBMNAME)
-+$(eval $(call symlink_system_library,OPENLIBM,$(LIBMNAME)))
- endif
-
--$(eval $(call symlink_system_library,libpcre2-8,PCRE))
--$(eval $(call symlink_system_library,libdSFMT,DSFMT))
--$(eval $(call symlink_system_library,$(LIBBLASNAME),BLAS))
-+$(eval $(call symlink_system_library,CSL,libgcc_s,1))
-+ifneq (,$(LIBGFORTRAN_VERSION))
-+$(eval $(call symlink_system_library,CSL,libgfortran,$(LIBGFORTRAN_VERSION)))
-+endif
-+$(eval $(call symlink_system_library,CSL,libquadmath,0))
-+$(eval $(call symlink_system_library,CSL,libstdc++,6))
-+# We allow libssp, libatomic and libgomp to fail as they are not available on all systems
-+$(eval $(call symlink_system_library,CSL,libssp,0,ALLOW_FAILURE))
-+$(eval $(call symlink_system_library,CSL,libatomic,1,ALLOW_FAILURE))
-+$(eval $(call symlink_system_library,CSL,libgomp,1,ALLOW_FAILURE))
-+$(eval $(call symlink_system_library,PCRE,libpcre2-8))
-+$(eval $(call symlink_system_library,DSFMT,libdSFMT))
-+$(eval $(call symlink_system_library,BLAS,$(LIBBLASNAME)))
- ifneq ($(LIBLAPACKNAME),$(LIBBLASNAME))
--$(eval $(call symlink_system_library,$(LIBLAPACKNAME),LAPACK))
-+$(eval $(call symlink_system_library,LAPACK,$(LIBLAPACKNAME)))
- endif
--$(eval $(call symlink_system_library,libgmp,GMP))
--$(eval $(call symlink_system_library,libmpfr,MPFR))
--$(eval $(call symlink_system_library,libmbedtls,MBEDTLS))
--$(eval $(call symlink_system_library,libmbedcrypto,MBEDTLS))
--$(eval $(call symlink_system_library,libmbedx509,MBEDTLS))
--$(eval $(call symlink_system_library,libssh2,LIBSSH2))
--$(eval $(call symlink_system_library,libnghttp2,NGHTTP2))
--$(eval $(call symlink_system_library,libcurl,CURL))
--$(eval $(call symlink_system_library,libgit2,LIBGIT2))
--$(eval $(call symlink_system_library,libamd,SUITESPARSE))
--$(eval $(call symlink_system_library,libcamd,SUITESPARSE))
--$(eval $(call symlink_system_library,libccolamd,SUITESPARSE))
--$(eval $(call symlink_system_library,libcholmod,SUITESPARSE))
--$(eval $(call symlink_system_library,libcolamd,SUITESPARSE))
--$(eval $(call symlink_system_library,libumfpack,SUITESPARSE))
--$(eval $(call symlink_system_library,libspqr,SUITESPARSE))
--$(eval $(call symlink_system_library,libsuitesparseconfig,SUITESPARSE))
-+$(eval $(call symlink_system_library,GMP,libgmp))
-+$(eval $(call symlink_system_library,MPFR,libmpfr))
-+$(eval $(call symlink_system_library,MBEDTLS,libmbedtls))
-+$(eval $(call symlink_system_library,MBEDTLS,libmbedcrypto))
-+$(eval $(call symlink_system_library,MBEDTLS,libmbedx509))
-+$(eval $(call symlink_system_library,LIBSSH2,libssh2))
-+$(eval $(call symlink_system_library,NGHTTP2,libnghttp2))
-+$(eval $(call symlink_system_library,CURL,libcurl))
-+$(eval $(call symlink_system_library,LIBGIT2,libgit2))
-+$(eval $(call symlink_system_library,SUITESPARSE,libamd))
-+$(eval $(call symlink_system_library,SUITESPARSE,libcamd))
-+$(eval $(call symlink_system_library,SUITESPARSE,libccolamd))
-+$(eval $(call symlink_system_library,SUITESPARSE,libcholmod))
-+$(eval $(call symlink_system_library,SUITESPARSE,libcolamd))
-+$(eval $(call symlink_system_library,SUITESPARSE,libumfpack))
-+$(eval $(call symlink_system_library,SUITESPARSE,libspqr))
-+$(eval $(call symlink_system_library,SUITESPARSE,libsuitesparseconfig))
- # EXCLUDED LIBRARIES (installed/used, but not vendored for use with dlopen):
- # libunwind
- endif # WINNT
-diff --git a/deps/csl.mk b/deps/csl.mk
-index 095d4ceec4a1e..423201cbb5a0c 100644
---- a/deps/csl.mk
-+++ b/deps/csl.mk
-@@ -19,48 +19,34 @@ $$(build_shlibdir)/$(1): | $$(build_shlibdir)
- [ -n "$$$${SRC_LIB}" ] && cp $$$${SRC_LIB} $$(build_shlibdir)
- endef
-
--ifeq ($(OS),WINNT)
--define gen_libname
--$$(if $(2),lib$(1)-$(2).$(SHLIB_EXT),lib$(1).$(SHLIB_EXT))
--endef
--else ifeq ($(OS),Darwin)
--define gen_libname
--$$(if $(2),lib$(1).$(2).$(SHLIB_EXT),lib$(1).$(SHLIB_EXT))
--endef
--else
--define gen_libname
--$$(if $(2),lib$(1).$(SHLIB_EXT).$(2),lib$(1).$(SHLIB_EXT))
--endef
--endif
--
- # libgfortran has multiple names; we're just going to copy any version we can find
- # Since we're only looking in the location given by `$(FC)` this should only succeed for one.
--$(eval $(call copy_csl,$(call gen_libname,gfortran,3)))
--$(eval $(call copy_csl,$(call gen_libname,gfortran,4)))
--$(eval $(call copy_csl,$(call gen_libname,gfortran,5)))
-+$(eval $(call copy_csl,$(call versioned_libname,libgfortran,3)))
-+$(eval $(call copy_csl,$(call versioned_libname,libgfortran,4)))
-+$(eval $(call copy_csl,$(call versioned_libname,libgfortran,5)))
-
- # These are all libraries that we should always have
--$(eval $(call copy_csl,$(call gen_libname,quadmath,0)))
--$(eval $(call copy_csl,$(call gen_libname,stdc++,6)))
--$(eval $(call copy_csl,$(call gen_libname,ssp,0)))
--$(eval $(call copy_csl,$(call gen_libname,atomic,1)))
--$(eval $(call copy_csl,$(call gen_libname,gomp,1)))
-+$(eval $(call copy_csl,$(call versioned_libname,libquadmath,0)))
-+$(eval $(call copy_csl,$(call versioned_libname,libstdc++,6)))
-+$(eval $(call copy_csl,$(call versioned_libname,libssp,0)))
-+$(eval $(call copy_csl,$(call versioned_libname,libatomic,1)))
-+$(eval $(call copy_csl,$(call versioned_libname,libgomp,1)))
-
- ifeq ($(OS),WINNT)
- # Windwos has special gcc_s names
- ifeq ($(ARCH),i686)
--$(eval $(call copy_csl,$(call gen_libname,gcc_s_sjlj,1)))
-+$(eval $(call copy_csl,$(call versioned_libname,libgcc_s_sjlj,1)))
- else
--$(eval $(call copy_csl,$(call gen_libname,gcc_s_seh,1)))
-+$(eval $(call copy_csl,$(call versioned_libname,libgcc_s_seh,1)))
- endif
- else
--$(eval $(call copy_csl,$(call gen_libname,gcc_s,1)))
-+$(eval $(call copy_csl,$(call versioned_libname,libgcc_s,1)))
- endif
- # winpthread is only Windows, pthread is only others
- ifeq ($(OS),WINNT)
--$(eval $(call copy_csl,$(call gen_libname,winpthread,1)))
-+$(eval $(call copy_csl,$(call versioned_libname,libwinpthread,1)))
- else
--$(eval $(call copy_csl,$(call gen_libname,pthread,0)))
-+$(eval $(call copy_csl,$(call versioned_libname,libpthread,0)))
- endif
-
- get-csl:
-
-From 6536b8519b25db844f2a1866d056879cb87d1c66 Mon Sep 17 00:00:00 2001
-From: Elliot Saba <staticfloat@gmail.com>
-Date: Fri, 26 Mar 2021 22:32:04 +0000
-Subject: [PATCH 2/2] Expand `JL_PRIVATE_LIBS-1` for versioned library names as
- well
-
-Without this, we fail to install things like `libgcc_s.so.1` when
-installed into the private libdir by `symlink_system_libraries`.
----
- Makefile | 7 +++++--
- 1 file changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 823ff3b86339d..e08f0e959e1b3 100644
---- a/Makefile
-+++ b/Makefile
-@@ -290,8 +290,11 @@ endif
- done \
- done
- for suffix in $(JL_PRIVATE_LIBS-1) ; do \
-- lib=$(build_private_libdir)/$${suffix}.$(SHLIB_EXT); \
-- $(INSTALL_M) $$lib $(DESTDIR)$(private_libdir) ; \
-+ for lib in $(build_private_libdir)/$${suffix}.$(SHLIB_EXT)*; do \
-+ if [ "$${lib##*.}" != "dSYM" ]; then \
-+ $(INSTALL_M) $$lib $(DESTDIR)$(private_libdir) ; \
-+ fi \
-+ done \
- done
- endif
- # Install `7z` into libexec/
diff --git a/dev-lang/julia/files/julia-1.7.0-libgit-1.2.patch b/dev-lang/julia/files/julia-1.6.5-libgit-1.2.patch
index f0abc7b8f60d..f0abc7b8f60d 100644
--- a/dev-lang/julia/files/julia-1.7.0-libgit-1.2.patch
+++ b/dev-lang/julia/files/julia-1.6.5-libgit-1.2.patch
diff --git a/dev-lang/julia/files/julia-1.7.0-llvm_13_compat_part_1.patch b/dev-lang/julia/files/julia-1.6.5-llvm_13_compat_part_1.patch
index 1398be7ec873..1398be7ec873 100644
--- a/dev-lang/julia/files/julia-1.7.0-llvm_13_compat_part_1.patch
+++ b/dev-lang/julia/files/julia-1.6.5-llvm_13_compat_part_1.patch
diff --git a/dev-lang/julia/files/julia-1.7.0-llvm_13_compat_part_2.patch b/dev-lang/julia/files/julia-1.6.5-llvm_13_compat_part_2.patch
index 5a8c2cde93d5..5a8c2cde93d5 100644
--- a/dev-lang/julia/files/julia-1.7.0-llvm_13_compat_part_2.patch
+++ b/dev-lang/julia/files/julia-1.6.5-llvm_13_compat_part_2.patch
diff --git a/dev-lang/julia/files/julia-1.7.0-llvm_13_compat_part_3.patch b/dev-lang/julia/files/julia-1.6.5-llvm_13_compat_part_3.patch
index 43b7925a9ce7..43b7925a9ce7 100644
--- a/dev-lang/julia/files/julia-1.7.0-llvm_13_compat_part_3.patch
+++ b/dev-lang/julia/files/julia-1.6.5-llvm_13_compat_part_3.patch
diff --git a/dev-lang/julia/files/julia-1.7.0-make-install-no-build.patch b/dev-lang/julia/files/julia-1.6.5-make-install-no-build.patch
index 0632a6e726f7..0632a6e726f7 100644
--- a/dev-lang/julia/files/julia-1.7.0-make-install-no-build.patch
+++ b/dev-lang/julia/files/julia-1.6.5-make-install-no-build.patch
diff --git a/dev-lang/julia/files/julia-1.7.0-do_not_set_rpath.patch b/dev-lang/julia/files/julia-1.7.0-do_not_set_rpath.patch
deleted file mode 100644
index 24f12d261053..000000000000
--- a/dev-lang/julia/files/julia-1.7.0-do_not_set_rpath.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/Makefile 2021-12-21 09:38:26.782829864 +0100
-+++ b/Makefile 2021-12-21 10:52:40.760565902 +0100
-@@ -336,7 +336,7 @@
- install_name_tool -add_rpath @executable_path/$(build_libdir_rel) @executable_path/$(libdir_rel) $(DESTDIR)$(bindir)/$$j; \
- done
- endif
--else ifneq (,$(findstring $(OS),Linux FreeBSD))
-+else ifneq (,$(findstring $(OS),FreeBSD))
- for j in $(JL_TARGETS) ; do \
- $(PATCHELF) --set-rpath '$$ORIGIN/$(private_libdir_rel):$$ORIGIN/$(libdir_rel)' $(DESTDIR)$(bindir)/$$j; \
- done
-@@ -357,7 +357,7 @@
- endif
-
- # Set rpath for libjulia-internal, which is moving from `../lib` to `../lib/julia`. We only need to do this for Linux/FreeBSD
--ifneq (,$(findstring $(OS),Linux FreeBSD))
-+ifneq (,$(findstring $(OS),FreeBSD))
- $(PATCHELF) --set-rpath '$$ORIGIN:$$ORIGIN/$(reverse_private_libdir_rel)' $(DESTDIR)$(private_libdir)/libjulia-internal.$(SHLIB_EXT)
- ifeq ($(BUNDLE_DEBUG_LIBS),1)
- $(PATCHELF) --set-rpath '$$ORIGIN:$$ORIGIN/$(reverse_private_libdir_rel)' $(DESTDIR)$(private_libdir)/libjulia-internal-debug.$(SHLIB_EXT)
-@@ -365,7 +365,7 @@
- endif
-
- # Set rpath for LLVM.so which is `$ORIGIN/../lib` moving from `../lib` to `../lib/julia`. We only need to do this for Linux/FreeBSD
--ifneq (,$(findstring $(OS),Linux FreeBSD))
-+ifneq (,$(findstring $(OS),FreeBSD))
- $(PATCHELF) --set-rpath '$$ORIGIN:$$ORIGIN/$(reverse_private_libdir_rel)' $(DESTDIR)$(private_libdir)/libLLVM.$(SHLIB_EXT)
- endif
-
diff --git a/dev-lang/julia/files/julia-1.7.1-do_not_set_rpath.patch b/dev-lang/julia/files/julia-1.7.1-do_not_set_rpath.patch
new file mode 100644
index 000000000000..7b8c3c7ba51b
--- /dev/null
+++ b/dev-lang/julia/files/julia-1.7.1-do_not_set_rpath.patch
@@ -0,0 +1,11 @@
+--- a/Makefile 2021-12-21 09:38:26.782829864 +0100
++++ b/Makefile 2021-12-21 10:52:40.760565902 +0100
+@@ -365,7 +365,7 @@
+ endif
+
+ # Set rpath for LLVM.so which is `$ORIGIN/../lib` moving from `../lib` to `../lib/julia`. We only need to do this for Linux/FreeBSD
+-ifneq (,$(findstring $(OS),Linux FreeBSD))
++ifneq (,$(findstring $(OS),FreeBSD))
+ $(PATCHELF) --set-rpath '$$ORIGIN:$$ORIGIN/$(reverse_private_libdir_rel)' $(DESTDIR)$(private_libdir)/libLLVM.$(SHLIB_EXT)
+ endif
+
diff --git a/dev-lang/julia/files/julia-1.7.0-hardcoded-libs.patch b/dev-lang/julia/files/julia-1.7.1-hardcoded-libs.patch
index be7d20368f6d..be7d20368f6d 100644
--- a/dev-lang/julia/files/julia-1.7.0-hardcoded-libs.patch
+++ b/dev-lang/julia/files/julia-1.7.1-hardcoded-libs.patch