summaryrefslogtreecommitdiff
path: root/dev-lang/julia/files/julia-1.7.1-do_not_set_rpath.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/julia/files/julia-1.7.1-do_not_set_rpath.patch')
-rw-r--r--dev-lang/julia/files/julia-1.7.1-do_not_set_rpath.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/dev-lang/julia/files/julia-1.7.1-do_not_set_rpath.patch b/dev-lang/julia/files/julia-1.7.1-do_not_set_rpath.patch
new file mode 100644
index 000000000000..7b8c3c7ba51b
--- /dev/null
+++ b/dev-lang/julia/files/julia-1.7.1-do_not_set_rpath.patch
@@ -0,0 +1,11 @@
+--- a/Makefile 2021-12-21 09:38:26.782829864 +0100
++++ b/Makefile 2021-12-21 10:52:40.760565902 +0100
+@@ -365,7 +365,7 @@
+ endif
+
+ # Set rpath for LLVM.so which is `$ORIGIN/../lib` moving from `../lib` to `../lib/julia`. We only need to do this for Linux/FreeBSD
+-ifneq (,$(findstring $(OS),Linux FreeBSD))
++ifneq (,$(findstring $(OS),FreeBSD))
+ $(PATCHELF) --set-rpath '$$ORIGIN:$$ORIGIN/$(reverse_private_libdir_rel)' $(DESTDIR)$(private_libdir)/libLLVM.$(SHLIB_EXT)
+ endif
+