summaryrefslogtreecommitdiff
path: root/dev-haskell/http-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
commitfd70f5e3ed54d5e013c11a3f3e632e80838171d0 (patch)
treec6bf0dac8239e644ccc09b184e4eb9cca9701dcf /dev-haskell/http-client
parent5deadca7219297a3c1f90eca00544a00e33efdbc (diff)
gentoo auto-resync : 23:07:2022 - 02:48:51
Diffstat (limited to 'dev-haskell/http-client')
-rw-r--r--dev-haskell/http-client/Manifest3
-rw-r--r--dev-haskell/http-client/files/http-client-0.7.10-disable-net-tests.patch16
-rw-r--r--dev-haskell/http-client/http-client-0.7.11.ebuild48
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-haskell/http-client/Manifest b/dev-haskell/http-client/Manifest
index 0cc3a54aeb34..a1b5b70f4138 100644
--- a/dev-haskell/http-client/Manifest
+++ b/dev-haskell/http-client/Manifest
@@ -1,3 +1,6 @@
+AUX http-client-0.7.10-disable-net-tests.patch 558 BLAKE2B cda700e04ad2627cdf4b8f3da5f7fadac5a116766783a7f5d850c3d5f0388986acefc1f25b460b482061e3bb93f8b908882fd104e3e3f5b1ee49a1643fc92b9e SHA512 142ceae88189ffccdeff8ecd77d04d0383af3350970a9a55571844c09dca72a11c989fe9abf5f6adf75cbf98b3e9ee81250d925293e27480bcfa92a61579a124
DIST http-client-0.6.4.1.tar.gz 89702 BLAKE2B 845488745e7429b833c92521be7abb6e03ae90fa81f819995d9fead467fce1f3c43ece8c4f5da1f8242d79086556b0f86eeea3da931a0a613eb49966ca9cd60d SHA512 b9595ebf3cb48c5ed288934976b78270a3092a35ae083853684c848301ee88a18e0e41534180033df071ab87dc9f9cbab99da37cbc74d538472409c13dcfce7d
+DIST http-client-0.7.11.tar.gz 94548 BLAKE2B 5e630b5ec1861301a8a503238c111091b9b099d181b17a1d9c5fd22dac1dc60952faa7ec1da597dd909fe5f23408d728964461d77314a30a747e5edaa1757889 SHA512 0c01961e66c71636ff2628851151a788aaf941155d50a9f20b01a2e065ca7a8218ab4867b24e7cfb434aaa9b9178f727d950017870540e0bce91fffdcc374852
EBUILD http-client-0.6.4.1.ebuild 1604 BLAKE2B 47a4b3503232150aafe3fb35566ce5c6a76349bd58aec53c2ba594fe919f290b817bcb99b0288f592ad10b410f3daa1e75600e51b9b03bab39da3b0daaa5c297 SHA512 fd0979e106b669b260ed9b76bfa82aaa39f03a883287e76804211f03dab039161088de6a824ff196e76e5bf2b64b11bbde1c864834edc9a8c5d75b42494e7595
+EBUILD http-client-0.7.11.ebuild 1398 BLAKE2B dbd744f7767355d01386f3432f396065c5ab8b982e5710ca87e4c05c12cd0520d2ae59cd7250927ed256351b0a16cd30077d446356134cdef5d7cd8c0de2d129 SHA512 8e0f68440bc3ee7498006d78202a77cbd07c4f251f689cb27697144b0d5c8d11b6c0a58c9810c93329e652d50182af54023a5e79122aacf70b0e24d1829228f1
MISC metadata.xml 430 BLAKE2B 098802e1dac0b41ca8041832ed91082890146c367919d4d63bb1b8691f4ce752a6e8319fd66098a80df4bdb3d26e541d8aea9e1e30f47260646bfa38cd59885e SHA512 edf1972b0395980415935a3bb83309845f04ec4ce57d5a309aa0f277400a61f10adc7732ad7ca235dc628e614b409cc262496ae90c3b82cf00e65a0a6a4cb9bf
diff --git a/dev-haskell/http-client/files/http-client-0.7.10-disable-net-tests.patch b/dev-haskell/http-client/files/http-client-0.7.10-disable-net-tests.patch
new file mode 100644
index 000000000000..0cc6e4f40dc2
--- /dev/null
+++ b/dev-haskell/http-client/files/http-client-0.7.10-disable-net-tests.patch
@@ -0,0 +1,16 @@
+From: hololeap <hololeap@protonmail.com>
+Signed-off-by: hololeap <hololeap@protonmail.com>
+
+Disable tests that depend on network access
+
+diff -urN http-client-0.7.10/http-client.cabal http-client-0.7.10-r1/http-client.cabal
+--- http-client-0.7.10/http-client.cabal 2022-01-20 19:39:19.388814780 -0700
++++ http-client-0.7.10-r1/http-client.cabal 2022-01-20 19:39:58.298814799 -0700
+@@ -104,6 +104,7 @@
+ , zlib
+ , async
+ , streaming-commons >= 0.1.1
++ buildable: False
+
+
+ test-suite spec-nonet
diff --git a/dev-haskell/http-client/http-client-0.7.11.ebuild b/dev-haskell/http-client/http-client-0.7.11.ebuild
new file mode 100644
index 000000000000..5a8e0421d4a2
--- /dev/null
+++ b/dev-haskell/http-client/http-client-0.7.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: +network-uri
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An HTTP client engine"
+HOMEPAGE="https://github.com/snoyberg/http-client"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="dev-haskell/async:=[profile?]
+ >=dev-haskell/base64-bytestring-1.0:=[profile?]
+ >=dev-haskell/blaze-builder-0.3:=[profile?]
+ >=dev-haskell/case-insensitive-1.0:=[profile?]
+ dev-haskell/cookie:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?]
+ >=dev-haskell/iproute-1.7.5:=[profile?]
+ dev-haskell/mime-types:=[profile?]
+ >=dev-haskell/network-2.6:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-haskell/stm-2.3:=[profile?]
+ >=dev-haskell/streaming-commons-0.1.0.2:=[profile?] <dev-haskell/streaming-commons-0.3:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ test? ( dev-haskell/hspec
+ dev-haskell/monad-control
+ >=dev-haskell/streaming-commons-0.1.1
+ dev-haskell/zlib )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.7.10-disable-net-tests.patch" )
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=network-uri
+}