summaryrefslogtreecommitdiff
path: root/dev-haskell/http-client/http-client-0.7.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/http-client/http-client-0.7.11.ebuild')
-rw-r--r--dev-haskell/http-client/http-client-0.7.11.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/http-client/http-client-0.7.11.ebuild b/dev-haskell/http-client/http-client-0.7.11.ebuild
new file mode 100644
index 000000000000..5a8e0421d4a2
--- /dev/null
+++ b/dev-haskell/http-client/http-client-0.7.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: +network-uri
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An HTTP client engine"
+HOMEPAGE="https://github.com/snoyberg/http-client"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="dev-haskell/async:=[profile?]
+ >=dev-haskell/base64-bytestring-1.0:=[profile?]
+ >=dev-haskell/blaze-builder-0.3:=[profile?]
+ >=dev-haskell/case-insensitive-1.0:=[profile?]
+ dev-haskell/cookie:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?]
+ >=dev-haskell/iproute-1.7.5:=[profile?]
+ dev-haskell/mime-types:=[profile?]
+ >=dev-haskell/network-2.6:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-haskell/stm-2.3:=[profile?]
+ >=dev-haskell/streaming-commons-0.1.0.2:=[profile?] <dev-haskell/streaming-commons-0.3:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ test? ( dev-haskell/hspec
+ dev-haskell/monad-control
+ >=dev-haskell/streaming-commons-0.1.1
+ dev-haskell/zlib )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.7.10-disable-net-tests.patch" )
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=network-uri
+}