summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-01 03:24:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-01 03:24:53 +0100
commit51f111b675c30c05f05128be7836616634098bae (patch)
treeb7f220c25531de5f5c9de03553548b7d3bf3178f /dev-go
parent6e479260831a77b38f58e3f572ead93d8327cf18 (diff)
gentoo auto-resync : 01:06:2023 - 03:24:53
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/Manifest.gzbin4717 -> 4887 bytes
-rw-r--r--dev-go/protobuf-go/Manifest4
-rw-r--r--dev-go/protobuf-go/metadata.xml11
-rw-r--r--dev-go/protobuf-go/protobuf-go-1.30.0.ebuild24
4 files changed, 39 insertions, 0 deletions
diff --git a/dev-go/Manifest.gz b/dev-go/Manifest.gz
index eaccbcdfc38d..b31a1c099502 100644
--- a/dev-go/Manifest.gz
+++ b/dev-go/Manifest.gz
Binary files differ
diff --git a/dev-go/protobuf-go/Manifest b/dev-go/protobuf-go/Manifest
new file mode 100644
index 000000000000..9e9e93170cb9
--- /dev/null
+++ b/dev-go/protobuf-go/Manifest
@@ -0,0 +1,4 @@
+DIST protobuf-go-1.30.0-deps.tar.xz 565680 BLAKE2B 711bdcd31c7986dd63a47db946d84081087c9a815b41c7239e8da312ca20faa7fbb8e4b03c59819c7403ff99e2eb691c436a3c03c7065c5ff99f513c90fc5d34 SHA512 73fffe68233c25b19edd0f22c0b1fb3e769a72a74ce00dcf5c1614ae2ec1f450e41283709791bbf0b31d08c462dc51ac08c07fece957aaec7850de66833c3648
+DIST protobuf-go-1.30.0.tar.gz 1298988 BLAKE2B 8ab6a105e691eacc60b6dc8ab872298469fcd38aad2fe7f5373761b2fa8e6208499db1b7eaccc40e5159dfcc2d1e4c9b5b5cbd81cb85787f88bcf93f355aa263 SHA512 379860dda3ccff3d6687520d92320a7543562cea104634a17abe5733c2d028116d2740434b33e39e7b263b9468806da7fe15af40c8e23c490c67fd9f9db8b770
+EBUILD protobuf-go-1.30.0.ebuild 533 BLAKE2B ff5246a55063e24cd30a23e7b3bf0eeba4318c001f7fadaf25ff0aeffbbc94a9f8b5bcac65734a09440dfe263ba547b3bef98cf4d35c4962890426dc847b1021 SHA512 e68e8032f2b4dd166dcdadca160ee6050e2929077d8fa16b4af2ec48d3c6044b8ab89fc784c6552be9954da56e9edebb481cf542ef24f4c650dafcc87dd728d2
+MISC metadata.xml 341 BLAKE2B cbce3f7b339e6f5d24a30ac3bf860e5b28b5fcac17ce55df6f23c9b859714a6e906ec7b01e226cc55fbb75ca54d01c7414767e6c4ef9aa121fdfbb24e3071645 SHA512 884e795309eacf33b0e11bcc1090130b6680d62e5dae8554665d31824fea4a1684b725fa7827084c0bea31940d621a0a11f6f7a50f3314575f8c6102ed135181
diff --git a/dev-go/protobuf-go/metadata.xml b/dev-go/protobuf-go/metadata.xml
new file mode 100644
index 000000000000..7da7f208bd96
--- /dev/null
+++ b/dev-go/protobuf-go/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">protocolbuffers/protobuf-go</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-go/protobuf-go/protobuf-go-1.30.0.ebuild b/dev-go/protobuf-go/protobuf-go-1.30.0.ebuild
new file mode 100644
index 000000000000..614b5698d2ee
--- /dev/null
+++ b/dev-go/protobuf-go/protobuf-go-1.30.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Go support for Google's protocol buffers"
+HOMEPAGE="http://protobuf.dev"
+SRC_URI="https://github.com/protocolbuffers/protobuf-go/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-libs/protobuf"
+
+src_compile() {
+ ego build ./cmd/protoc-gen-go
+}
+
+src_install() {
+dobin protoc-gen-go
+}