summaryrefslogtreecommitdiff
path: root/dev-go/protobuf-go/protobuf-go-1.30.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/protobuf-go/protobuf-go-1.30.0.ebuild')
-rw-r--r--dev-go/protobuf-go/protobuf-go-1.30.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-go/protobuf-go/protobuf-go-1.30.0.ebuild b/dev-go/protobuf-go/protobuf-go-1.30.0.ebuild
new file mode 100644
index 000000000000..614b5698d2ee
--- /dev/null
+++ b/dev-go/protobuf-go/protobuf-go-1.30.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Go support for Google's protocol buffers"
+HOMEPAGE="http://protobuf.dev"
+SRC_URI="https://github.com/protocolbuffers/protobuf-go/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-libs/protobuf"
+
+src_compile() {
+ ego build ./cmd/protoc-gen-go
+}
+
+src_install() {
+dobin protoc-gen-go
+}