summaryrefslogtreecommitdiff
path: root/dev-games/mercator/mercator-0.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-games/mercator/mercator-0.3.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-games/mercator/mercator-0.3.3.ebuild')
-rw-r--r--dev-games/mercator/mercator-0.3.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-games/mercator/mercator-0.3.3.ebuild b/dev-games/mercator/mercator-0.3.3.ebuild
new file mode 100644
index 000000000000..92cdc48b0a23
--- /dev/null
+++ b/dev-games/mercator/mercator-0.3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="WorldForge library primarily aimed at terrain"
+HOMEPAGE="https://www.worldforge.org/index.php/components/mercator/"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+SLOT="0"
+
+RDEPEND=">=dev-games/wfmath-1"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+src_compile() {
+ default
+ use doc && emake docs
+}
+
+src_install() {
+ default
+ use doc && dohtml -r doc/html/*
+ prune_libtool_files
+}