summaryrefslogtreecommitdiff
path: root/dev-games/mercator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-games/mercator
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-games/mercator')
-rw-r--r--dev-games/mercator/Manifest3
-rw-r--r--dev-games/mercator/mercator-0.3.3.ebuild30
-rw-r--r--dev-games/mercator/metadata.xml28
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-games/mercator/Manifest b/dev-games/mercator/Manifest
new file mode 100644
index 000000000000..6dc8f651a4aa
--- /dev/null
+++ b/dev-games/mercator/Manifest
@@ -0,0 +1,3 @@
+DIST mercator-0.3.3.tar.gz 436499 BLAKE2B da807a954e83da39c52b88cfec4ee9c61cff98e6cf71b9c0d0f18540e07811b5d6512ed8b48441c7512f6f6f5c223fa030efe7fb4fca65a750beb0ab3b950e6b SHA512 d8f0bcec904c77ceaadd11474a4a83ec4d5e5086f0c878b147b00f3fb3ef2ae6596553d2d4548f943aa280672dde938d34f4d231782b10149190f5d8029e039a
+EBUILD mercator-0.3.3.ebuild 602 BLAKE2B e6fd18a4d1d79547110893ae36f95178f70e90bb85d449ee7a890b4a9022327a0ebe8f0ade724ad4d02aa283d2e3e63c435b8fcc238bf705578b5e6bbd685ecc SHA512 379570b5258244732f5fabd10601cbf6d9413002df078ed7c2ba45ffd486d911df92826578de103dfa4d74e6fb23a0d950af7ed4637e4714d758a3a8d8b8d15a
+MISC metadata.xml 1299 BLAKE2B e94d86dabd63c3b9588e1f8f380389485a6ba3e0124933a1b18acb48f39ccec50d99a58dc0bda0891258182ec3e2848286da89e77b95fc813222bff70f729b3e SHA512 5c9db3c98c40f56c1859ce211e9a485a70a60dcc05065c7ad7af1bd16cf95b654da6660fafa0e617f99d7159dfe64629ab53d8529015a50b02872c35d698dc60
diff --git a/dev-games/mercator/mercator-0.3.3.ebuild b/dev-games/mercator/mercator-0.3.3.ebuild
new file mode 100644
index 000000000000..92cdc48b0a23
--- /dev/null
+++ b/dev-games/mercator/mercator-0.3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="WorldForge library primarily aimed at terrain"
+HOMEPAGE="https://www.worldforge.org/index.php/components/mercator/"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+SLOT="0"
+
+RDEPEND=">=dev-games/wfmath-1"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+src_compile() {
+ default
+ use doc && emake docs
+}
+
+src_install() {
+ default
+ use doc && dohtml -r doc/html/*
+ prune_libtool_files
+}
diff --git a/dev-games/mercator/metadata.xml b/dev-games/mercator/metadata.xml
new file mode 100644
index 000000000000..4b1795998d19
--- /dev/null
+++ b/dev-games/mercator/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+Mercator is primarily aimed at terrain for multiplayer online games and forms
+one of the WorldForge core libraries. It is intended to be used as a terrain
+library on the client, while a subset of features are useful on the server.
+
+Mercator is designed in such a way that individual tiles can be generated
+on-the-fly from a very small source data set. Each tile uses a fast
+deterministic random number generation to ensure that identical results are
+produced "anytime, anywhere". This enables transmission of terrain across low
+bandwidth links as part of the standard data stream, or server side collision
+detection with the same terrain that the player sees.
+
+The use of tiles means that there is inherently a large degree of gross control
+of the shape of the terrain. Finer control is implemented by allowing geometric
+modifications - for example, a polygonal area might be flattened, or a crater
+could be applied.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">worldforge</remote-id>
+ </upstream>
+</pkgmetadata>