summaryrefslogtreecommitdiff
path: root/dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild')
-rw-r--r--dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild23
1 files changed, 14 insertions, 9 deletions
diff --git a/dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild b/dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild
index 13da6435290b..6a6b23ad072d 100644
--- a/dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild
+++ b/dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit multilib toolchain-funcs
+EAPI=7
+
+inherit autotools toolchain-funcs
MY_PN="${PN/-libftdi/}"
MY_P="${MY_PN}-${PV}"
@@ -13,23 +14,27 @@ TABFILEDIR="libftdi/lib_table"
DESCRIPTION="Library which includes a table of VIDs and PIDs of Ever UPS devices"
HOMEPAGE="http://www.ever.com.pl"
SRC_URI="http://www.ever.com.pl/pl/pliki/${MY_P}-x86.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.1.8-LDFLAGS.patch"
+)
-S="${WORKDIR}/${MY_P}"
+src_prepare() {
+ default
+ eautoreconf
+}
src_compile() {
- cd "${TABFILEDIR}"
+ cd "${TABFILEDIR}" || die
# Wipe out precompiled binary
emake clean
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
}
src_install() {