summaryrefslogtreecommitdiff
path: root/dev-embedded/powersoftplus-libftdi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-embedded/powersoftplus-libftdi
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-embedded/powersoftplus-libftdi')
-rw-r--r--dev-embedded/powersoftplus-libftdi/Manifest3
-rw-r--r--dev-embedded/powersoftplus-libftdi/files/powersoftplus-libftdi-0.1.8-LDFLAGS.patch23
-rw-r--r--dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild23
3 files changed, 39 insertions, 10 deletions
diff --git a/dev-embedded/powersoftplus-libftdi/Manifest b/dev-embedded/powersoftplus-libftdi/Manifest
index 268187abd6fa..58ec1fd0b6a8 100644
--- a/dev-embedded/powersoftplus-libftdi/Manifest
+++ b/dev-embedded/powersoftplus-libftdi/Manifest
@@ -1,3 +1,4 @@
+AUX powersoftplus-libftdi-0.1.8-LDFLAGS.patch 572 BLAKE2B 3e896d2da3dbba62fe94290bbcea220271e010e4397cc9f7f737c9f8614af8cdc614695362bcb312895acd0f305faf3236a08e53c0db6d1c6ab4203295415a03 SHA512 8e44cf8124e75923b100b95293fadf62e0356bcf749bf0ad7c30f54103085925ed3a6a1567a12a72f42e62d78b0d4ab7468a105933f7544fe023b5dd0a93ae52
DIST powersoftplus-0.1.8-x86.tar.gz 4746235 BLAKE2B 3ae26bbb1dc924bf88ef9cf65953ce16ee3db1d4b4e4c15ec7c352dfedd37485402a201f0e6bea8909344f1f87a8aca728d8d62827ce2578c8b158157acd7c72 SHA512 13d499bcad3044ec50502026f5d61b11693c9ff5996978ff3101a705b71569749961f82855b9179d9da89a8e51c745ca5cf308ae6dbbd21242dd1d480323ba0b
-EBUILD powersoftplus-libftdi-0.1.8-r1.ebuild 749 BLAKE2B e5291443abd4e26e2238286151702124caa47d9a26ced05f62b05b45389c8c6f5700b9ee895a9e44dff4c00870181b9b881a4a79493e32efe34944a631253834 SHA512 c243682187eed94fa541cc2cebcc2b42d10cbc8d0fbc405f604a3435ab778c84d14af69b6c47e44c3cc14a72dba3de40bfa37c76ea12e74ac04a82c64a85a99d
+EBUILD powersoftplus-libftdi-0.1.8-r1.ebuild 831 BLAKE2B 7f4533d781dedc6c63cd8d60ebc983e3f33b9b5ad85bf8705843c21b6daaf36c30fc930c792a0cfa56619b19d9ccaa85665e109e17d1d8f797091971e2447d3c SHA512 793cfb76501f9d1786db9dbabd75acc2a37b3b880f99a55b5fc52e32104f5b2e986811268d0cfa44dbe0c166208a29e1144cc6a0768cc8b74d393938bfcc26b9
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/dev-embedded/powersoftplus-libftdi/files/powersoftplus-libftdi-0.1.8-LDFLAGS.patch b/dev-embedded/powersoftplus-libftdi/files/powersoftplus-libftdi-0.1.8-LDFLAGS.patch
new file mode 100644
index 000000000000..642209ea0ea1
--- /dev/null
+++ b/dev-embedded/powersoftplus-libftdi/files/powersoftplus-libftdi-0.1.8-LDFLAGS.patch
@@ -0,0 +1,23 @@
+diff --git a/libftdi/lib_table/Makefile b/libftdi/lib_table/Makefile
+index cf4316b..dd393b8 100644
+--- a/libftdi/lib_table/Makefile
++++ b/libftdi/lib_table/Makefile
+@@ -1,15 +1,15 @@
+ # which compiler
+-CC = gcc
++CC ?= gcc
+
+ VERSION = _RELEASE
+
+ LIBNAME = libd2xx_table.so
+
+-CFLAGS = -DLINUX -D$(VERSION)
++CFLAGS += -DLINUX -D$(VERSION)
+
+ $(LIBNAME): ftdi_table.o
+
+- $(CC) -Wall -shared -fPIC -o $(LIBNAME) ftdi_table.o
++ $(CC) -Wall -shared -fPIC ${LDFLAGS} -o $(LIBNAME) ftdi_table.o
+
+ ftdi_table.o: ftdi_table.c
+ $(CC) -I. $(CFLAGS) -c -fPIC ftdi_table.c
diff --git a/dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild b/dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild
index 13da6435290b..6a6b23ad072d 100644
--- a/dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild
+++ b/dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit multilib toolchain-funcs
+EAPI=7
+
+inherit autotools toolchain-funcs
MY_PN="${PN/-libftdi/}"
MY_P="${MY_PN}-${PV}"
@@ -13,23 +14,27 @@ TABFILEDIR="libftdi/lib_table"
DESCRIPTION="Library which includes a table of VIDs and PIDs of Ever UPS devices"
HOMEPAGE="http://www.ever.com.pl"
SRC_URI="http://www.ever.com.pl/pl/pliki/${MY_P}-x86.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.1.8-LDFLAGS.patch"
+)
-S="${WORKDIR}/${MY_P}"
+src_prepare() {
+ default
+ eautoreconf
+}
src_compile() {
- cd "${TABFILEDIR}"
+ cd "${TABFILEDIR}" || die
# Wipe out precompiled binary
emake clean
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
}
src_install() {