summaryrefslogtreecommitdiff
path: root/dev-dotnet/pe-format/pe-format-2.1.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-dotnet/pe-format/pe-format-2.1.2-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-dotnet/pe-format/pe-format-2.1.2-r1.ebuild')
-rw-r--r--dev-dotnet/pe-format/pe-format-2.1.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-dotnet/pe-format/pe-format-2.1.2-r1.ebuild b/dev-dotnet/pe-format/pe-format-2.1.2-r1.ebuild
new file mode 100644
index 000000000000..d75726d5aa38
--- /dev/null
+++ b/dev-dotnet/pe-format/pe-format-2.1.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd xdg-utils
+
+DESCRIPTION="Intelligent PE executable wrapper for binfmt_misc"
+HOMEPAGE="https://bitbucket.org/mgorny/pe-format2/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}2/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-util/desktop-file-utils"
+RDEPEND="!<sys-apps/openrc-0.9.4"
+
+src_configure() {
+ local myconf=(
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ keepdir /var/lib
+}
+
+pkg_postinst() {
+ ebegin "Calling pe-format2-setup to update handler setup"
+ pe-format2-setup
+ eend ${?}
+
+ xdg_desktop_database_update
+}