summaryrefslogtreecommitdiff
path: root/dev-dotnet/pe-format
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-dotnet/pe-format
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-dotnet/pe-format')
-rw-r--r--dev-dotnet/pe-format/Manifest4
-rw-r--r--dev-dotnet/pe-format/metadata.xml20
-rw-r--r--dev-dotnet/pe-format/pe-format-2.1.2-r1.ebuild38
-rw-r--r--dev-dotnet/pe-format/pe-format-9999.ebuild54
4 files changed, 116 insertions, 0 deletions
diff --git a/dev-dotnet/pe-format/Manifest b/dev-dotnet/pe-format/Manifest
new file mode 100644
index 000000000000..208eedb2a419
--- /dev/null
+++ b/dev-dotnet/pe-format/Manifest
@@ -0,0 +1,4 @@
+DIST pe-format-2.1.2.tar.bz2 79023 BLAKE2B 83877431f12ccf6e344f435a9a5ca993adca286558efd96734b0b5b5a29b160ccaa1d219d899d12e368db861ec04d4fa365e69f97f66c79deb161e57747395e4 SHA512 c946384fdb95593f8b9390f77c7ccc2fc5ae2588412e37e868785523ca91f0d9d98e41928ec61c4cd1f47ba7d1b167cd7b6671f6662ac247d1d83a37b1c32b0f
+EBUILD pe-format-2.1.2-r1.ebuild 770 BLAKE2B 45230d1123cec6430cc69181d27e5b756a801c4572772f9faee3d4a9904761756b225836a7b3db3b9c74978780f4b13bf8fb24438347fb687d0aa1c1236069ac SHA512 216320e5cd9e99c5ac69998cd6ff304a829995f2271fba653acd8b527f8022cfc785434751749ad785d92428b59899af05d029c6a159e5c6ba59e490287b118a
+EBUILD pe-format-9999.ebuild 949 BLAKE2B 1e19028f40c9ed682aa1978381ac6901b69cc65e77779344c3a907eb6d95f54f9584dae2a3c559bcd06c72723d14323ab65230aaf17ea9eb5474aae10b561f8b SHA512 13e44ad4df2b11edeffda77a772922a1111abbb8a3bb1f7f7a326018c61890c30725ab2ce237f44f2730851e703f20140f6011c5a8d3e8a851ceadbf74c48efb
+MISC metadata.xml 659 BLAKE2B a8a98f5b67ad105de4824cd384b26577006cefd176e02a2777f73de7c3a6aa88be6612b49233a554b6ddc673fb4049d207e3c5ceb25132ba336e80090923c9d7 SHA512 c13fe4fcb55825347d3d894af8f34f0978d3c6aa413f0d460c1f5d9b5321491d30537c1045ecb5a921419c5cb07a2a1d53e9f48d015b20a34f880a171926bb3d
diff --git a/dev-dotnet/pe-format/metadata.xml b/dev-dotnet/pe-format/metadata.xml
new file mode 100644
index 000000000000..2af76e28dbce
--- /dev/null
+++ b/dev-dotnet/pe-format/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://bitbucket.org/mgorny/pe-format2/issues/</bugs-to>
+ <remote-id type="bitbucket">mgorny/pe-format2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-dotnet/pe-format/pe-format-2.1.2-r1.ebuild b/dev-dotnet/pe-format/pe-format-2.1.2-r1.ebuild
new file mode 100644
index 000000000000..d75726d5aa38
--- /dev/null
+++ b/dev-dotnet/pe-format/pe-format-2.1.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd xdg-utils
+
+DESCRIPTION="Intelligent PE executable wrapper for binfmt_misc"
+HOMEPAGE="https://bitbucket.org/mgorny/pe-format2/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}2/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-util/desktop-file-utils"
+RDEPEND="!<sys-apps/openrc-0.9.4"
+
+src_configure() {
+ local myconf=(
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ keepdir /var/lib
+}
+
+pkg_postinst() {
+ ebegin "Calling pe-format2-setup to update handler setup"
+ pe-format2-setup
+ eend ${?}
+
+ xdg_desktop_database_update
+}
diff --git a/dev-dotnet/pe-format/pe-format-9999.ebuild b/dev-dotnet/pe-format/pe-format-9999.ebuild
new file mode 100644
index 000000000000..e9f8305fd6ce
--- /dev/null
+++ b/dev-dotnet/pe-format/pe-format-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+#if LIVE
+EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}2.git"
+
+inherit autotools git-r3
+#endif
+
+inherit systemd xdg-utils
+
+DESCRIPTION="Intelligent PE executable wrapper for binfmt_misc"
+HOMEPAGE="https://bitbucket.org/mgorny/pe-format2/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}2/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-util/desktop-file-utils"
+RDEPEND="!<sys-apps/openrc-0.9.4"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+
+src_prepare() {
+ default
+ eautoreconf
+}
+#endif
+
+src_configure() {
+ local myconf=(
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ keepdir /var/lib
+}
+
+pkg_postinst() {
+ ebegin "Calling pe-format2-setup to update handler setup"
+ pe-format2-setup
+ eend ${?}
+
+ xdg_desktop_database_update
+}