summaryrefslogtreecommitdiff
path: root/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild')
-rw-r--r--dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild b/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
new file mode 100644
index 000000000000..a14d50d57957
--- /dev/null
+++ b/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit mono eutils multilib
+
+S="${WORKDIR}/MonoCalendar"
+
+DESCRIPTION="iCal clone for .NET"
+HOMEPAGE="http://www.monocalendar.com/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+DEPEND=">=dev-lang/mono-1.2.1"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ cd "${S}"/bin/Release/
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)/${PN}
+ insinto /usr/$(get_libdir)/${PN}
+
+ doins bin/Release/*dll
+ doins bin/Release/*.exe
+
+ make_wrapper monocalendar "mono /usr/$(get_libdir)/${PN}/MonoCalendar.exe"
+}