summaryrefslogtreecommitdiff
path: root/dev-dotnet/monocalendar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-dotnet/monocalendar
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-dotnet/monocalendar')
-rw-r--r--dev-dotnet/monocalendar/Manifest3
-rw-r--r--dev-dotnet/monocalendar/metadata.xml11
-rw-r--r--dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild36
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-dotnet/monocalendar/Manifest b/dev-dotnet/monocalendar/Manifest
new file mode 100644
index 000000000000..f8972ad77794
--- /dev/null
+++ b/dev-dotnet/monocalendar/Manifest
@@ -0,0 +1,3 @@
+DIST monocalendar-source-0.7.2.tar.gz 178249 BLAKE2B ed1a38419b1c1528838800431d6935b152d8131fa6eea36c6344dcaa40e785e1d53170df96b8e2053497d4f8c45791e63c935fa0ff572678483415663bc95b98 SHA512 8793f4a56d5626485a2e8378121b8b2f2435a5c7f26be12fad1bf4647e464686f670becbf1b0a35add60080f1bdf06ba993f9ecbc4d30ca3fad5ecceebcd0c12
+EBUILD monocalendar-0.7.2.ebuild 705 BLAKE2B 221b142d87722bf7598d7544cd665fde21fe3ecaf68f36ad0ef7397addf04bfb5c983912a27fd2be0df3604032972581bb67c98e1952df03126cc4d697ff70c6 SHA512 5c7a50212d105b99b985acbc21e0d35f8c1a23653d68b082b45180df753d6553389d75bb89437bd28c70c09e47e39de51bd7cc0cf538fa3b5ce7d96627a6db0f
+MISC metadata.xml 337 BLAKE2B 09e6f061750009accdf54c43086e365df5726f2b6d8166f1e558315c7459d2c371f051e75e8fa2a94026c063a37b0191ca6366d8db5d99235fa711b3c88433a7 SHA512 41d0cf40ec994d68f82d74518da2d7cb68d1b399f1de56e785fc2df0155a414629df5782aff4ac0a7f365a4ed3a0e0622ed68ba01cb032db140e17f67163ea11
diff --git a/dev-dotnet/monocalendar/metadata.xml b/dev-dotnet/monocalendar/metadata.xml
new file mode 100644
index 000000000000..1b209872a2ed
--- /dev/null
+++ b/dev-dotnet/monocalendar/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">monocalendar</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild b/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
new file mode 100644
index 000000000000..a14d50d57957
--- /dev/null
+++ b/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit mono eutils multilib
+
+S="${WORKDIR}/MonoCalendar"
+
+DESCRIPTION="iCal clone for .NET"
+HOMEPAGE="http://www.monocalendar.com/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+DEPEND=">=dev-lang/mono-1.2.1"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ cd "${S}"/bin/Release/
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)/${PN}
+ insinto /usr/$(get_libdir)/${PN}
+
+ doins bin/Release/*dll
+ doins bin/Release/*.exe
+
+ make_wrapper monocalendar "mono /usr/$(get_libdir)/${PN}/MonoCalendar.exe"
+}