summaryrefslogtreecommitdiff
path: root/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild')
-rw-r--r--dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild23
1 files changed, 9 insertions, 14 deletions
diff --git a/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild b/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
index a14d50d57957..4837debd2b9f 100644
--- a/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
+++ b/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
@@ -1,17 +1,16 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit mono eutils multilib
-
-S="${WORKDIR}/MonoCalendar"
+inherit eutils mono
DESCRIPTION="iCal clone for .NET"
HOMEPAGE="http://www.monocalendar.com/"
SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"
+S="${WORKDIR}/MonoCalendar"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 x86"
IUSE=""
@@ -20,17 +19,13 @@ DEPEND=">=dev-lang/mono-1.2.1"
RDEPEND="${DEPEND}"
src_compile() {
- cd "${S}"/bin/Release/
-
- emake || die "emake failed"
+ emake -C bin/Release
}
src_install() {
- dodir /usr/$(get_libdir)/${PN}
- insinto /usr/$(get_libdir)/${PN}
-
- doins bin/Release/*dll
- doins bin/Release/*.exe
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe bin/Release/*dll
+ doexe bin/Release/*.exe
make_wrapper monocalendar "mono /usr/$(get_libdir)/${PN}/MonoCalendar.exe"
}