summaryrefslogtreecommitdiff
path: root/dev-dotnet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /dev-dotnet
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/Manifest.gzbin2900 -> 2900 bytes
-rw-r--r--dev-dotnet/monocalendar/Manifest2
-rw-r--r--dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild23
3 files changed, 10 insertions, 15 deletions
diff --git a/dev-dotnet/Manifest.gz b/dev-dotnet/Manifest.gz
index edb139183f95..2cbc75ffc32e 100644
--- a/dev-dotnet/Manifest.gz
+++ b/dev-dotnet/Manifest.gz
Binary files differ
diff --git a/dev-dotnet/monocalendar/Manifest b/dev-dotnet/monocalendar/Manifest
index f8972ad77794..f2670fc1e276 100644
--- a/dev-dotnet/monocalendar/Manifest
+++ b/dev-dotnet/monocalendar/Manifest
@@ -1,3 +1,3 @@
DIST monocalendar-source-0.7.2.tar.gz 178249 BLAKE2B ed1a38419b1c1528838800431d6935b152d8131fa6eea36c6344dcaa40e785e1d53170df96b8e2053497d4f8c45791e63c935fa0ff572678483415663bc95b98 SHA512 8793f4a56d5626485a2e8378121b8b2f2435a5c7f26be12fad1bf4647e464686f670becbf1b0a35add60080f1bdf06ba993f9ecbc4d30ca3fad5ecceebcd0c12
-EBUILD monocalendar-0.7.2.ebuild 705 BLAKE2B 221b142d87722bf7598d7544cd665fde21fe3ecaf68f36ad0ef7397addf04bfb5c983912a27fd2be0df3604032972581bb67c98e1952df03126cc4d697ff70c6 SHA512 5c7a50212d105b99b985acbc21e0d35f8c1a23653d68b082b45180df753d6553389d75bb89437bd28c70c09e47e39de51bd7cc0cf538fa3b5ce7d96627a6db0f
+EBUILD monocalendar-0.7.2.ebuild 628 BLAKE2B b2197d0eeb7b99322ff42b42cf3ab5a331bb531fa17c5f11c8168a18540521fcf9abbefa1ed6a1d6e27b39d17f07a0805ac390cf320d6c1cdc17e40198fa0920 SHA512 5dfcd6f08cc17a8b856356087aeb75a0bb91028740d314baa36ffd0b944d7b2f8d9afd8657280ca05b40319d26c6ae1ef30137d7b3080c7b75f7022c51f6ab6b
MISC metadata.xml 337 BLAKE2B 09e6f061750009accdf54c43086e365df5726f2b6d8166f1e558315c7459d2c371f051e75e8fa2a94026c063a37b0191ca6366d8db5d99235fa711b3c88433a7 SHA512 41d0cf40ec994d68f82d74518da2d7cb68d1b399f1de56e785fc2df0155a414629df5782aff4ac0a7f365a4ed3a0e0622ed68ba01cb032db140e17f67163ea11
diff --git a/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild b/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
index a14d50d57957..4837debd2b9f 100644
--- a/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
+++ b/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
@@ -1,17 +1,16 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit mono eutils multilib
-
-S="${WORKDIR}/MonoCalendar"
+inherit eutils mono
DESCRIPTION="iCal clone for .NET"
HOMEPAGE="http://www.monocalendar.com/"
SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"
+S="${WORKDIR}/MonoCalendar"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 x86"
IUSE=""
@@ -20,17 +19,13 @@ DEPEND=">=dev-lang/mono-1.2.1"
RDEPEND="${DEPEND}"
src_compile() {
- cd "${S}"/bin/Release/
-
- emake || die "emake failed"
+ emake -C bin/Release
}
src_install() {
- dodir /usr/$(get_libdir)/${PN}
- insinto /usr/$(get_libdir)/${PN}
-
- doins bin/Release/*dll
- doins bin/Release/*.exe
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe bin/Release/*dll
+ doexe bin/Release/*.exe
make_wrapper monocalendar "mono /usr/$(get_libdir)/${PN}/MonoCalendar.exe"
}