summaryrefslogtreecommitdiff
path: root/dev-db/mysql-udf-http/mysql-udf-http-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-db/mysql-udf-http/mysql-udf-http-1.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-db/mysql-udf-http/mysql-udf-http-1.0.ebuild')
-rw-r--r--dev-db/mysql-udf-http/mysql-udf-http-1.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-db/mysql-udf-http/mysql-udf-http-1.0.ebuild b/dev-db/mysql-udf-http/mysql-udf-http-1.0.ebuild
new file mode 100644
index 000000000000..76152f4b2812
--- /dev/null
+++ b/dev-db/mysql-udf-http/mysql-udf-http-1.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs autotools
+
+DESCRIPTION="MySQL User-defined function (UDF) for HTTP REST"
+HOMEPAGE="https://code.google.com/p/mysql-udf-http/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/mysql-5.1
+ net-misc/curl"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
+ MYSQL_INCLUDE="$(mysql_config --include)"
+}
+
+src_prepare() {
+ # fix README
+ sed -i -e "s|${PN}\(\.so\)|${PN//-/_}\1|g" README
+
+ # fix Makefile.am
+ sed -i -e "s|${PN}\([_\.]la\)|${PN//-/_}\1|g" \
+ -e "s|\(-module\)|\1 -avoid-version|g" src/Makefile.am
+
+ epatch "${FILESDIR}/${PN}-stdlib.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-pic --disable-static --libdir="${MYSQL_PLUGINDIR}" \
+ --with-mysql="$(type -p mysql_config)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README
+
+ # remove obsolete *.la file
+ rm -f -- "${D}${MYSQL_PLUGINDIR}"/*.la
+}
+
+pkg_postinst() {
+ elog
+ elog "Please have a look at the documentation, how to"
+ elog "enable/disable the UDF functions of ${PN}."
+ elog
+ elog "The documentation is located here:"
+ elog "/usr/share/doc/${PF}"
+ elog
+}