summaryrefslogtreecommitdiff
path: root/dev-db/mysql-udf-http
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-db/mysql-udf-http
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-db/mysql-udf-http')
-rw-r--r--dev-db/mysql-udf-http/Manifest4
-rw-r--r--dev-db/mysql-udf-http/files/mysql-udf-http-stdlib.patch10
-rw-r--r--dev-db/mysql-udf-http/metadata.xml8
-rw-r--r--dev-db/mysql-udf-http/mysql-udf-http-1.0.ebuild59
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-db/mysql-udf-http/Manifest b/dev-db/mysql-udf-http/Manifest
new file mode 100644
index 000000000000..59116e9ac75a
--- /dev/null
+++ b/dev-db/mysql-udf-http/Manifest
@@ -0,0 +1,4 @@
+AUX mysql-udf-http-stdlib.patch 262 BLAKE2B 7d80e33afafc57072ffc2bff22a3ff297dfc5311e1d13ebb668b32e371e3dde4a71859ff268b567a237f640bc2f01679065f5c5ab13223501cdd5a89e85ca66a SHA512 9e914bafffa08ace217ffab6de9497cf0cbe4bcc2f5c10fb9c381e540cc700bdf356fdde8edcce539e3e0d2728083451e5ec147c24bf63c9861d35b3030a6b77
+DIST mysql-udf-http-1.0.tar.gz 322160 BLAKE2B 50097f0e58b6adb23b51f6aa760fdb58c226196d274f1a115da7824be459538feade2365cdbc15e8c5a4fbeddd5513d73fa7773f69a41e305d8687917600d4d1 SHA512 84feb7cfec052e368131bdf44937868339d9d8694128cd5257aa248ce3d1e2e660f3df1e7da99f64b3954fa66c29ed7af5a809fa5ebbd93a96c6cd2ec2ec81de
+EBUILD mysql-udf-http-1.0.ebuild 1303 BLAKE2B 7e496664c99bef30023e2bf3d1679b7d21cad9006cbb6babd9d010c932a77ac9c487b1d05cbfbef70f57b6db9ad1dc8f1f19def2ea3309c1f0ae6147606dec61 SHA512 bdbbc1ddb92411972cfd1365cf3745669006f86710a17a5d3adc6232c33e2e5868b3ca1f272a9dcd57a444cac1ced5cad38dc2a28a97a403c09302af73a64306
+MISC metadata.xml 251 BLAKE2B a8ed853b16c23d8a55dfce0a0cf8b7072a29c573b7bbac0b538173766e320222aef7ea91789c9a9a90e0a191505f2c5986c508352fb2277aae4773089b4ec773 SHA512 e1e841d7dcee0bb517f95e3e36a03deb356ff186b63674f3f4b87cf29daed5b3070ac9442eec72c84820a4c01ef0f715b8589f496495a4a8eac2c4d4be48815d
diff --git a/dev-db/mysql-udf-http/files/mysql-udf-http-stdlib.patch b/dev-db/mysql-udf-http/files/mysql-udf-http-stdlib.patch
new file mode 100644
index 000000000000..6e371fc4a835
--- /dev/null
+++ b/dev-db/mysql-udf-http/files/mysql-udf-http-stdlib.patch
@@ -0,0 +1,10 @@
+--- src/mysql-udf-http.c.orig 2010-09-06 06:00:32.000000000 +0200
++++ src/mysql-udf-http.c 2011-10-18 16:36:37.000000000 +0200
+@@ -2,6 +2,7 @@
+ #include <string.h>
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <curl/curl.h>
+ #include "mysql-udf-http.h"
+
diff --git a/dev-db/mysql-udf-http/metadata.xml b/dev-db/mysql-udf-http/metadata.xml
new file mode 100644
index 000000000000..c28680ca19b4
--- /dev/null
+++ b/dev-db/mysql-udf-http/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="google-code">mysql-udf-http</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/mysql-udf-http/mysql-udf-http-1.0.ebuild b/dev-db/mysql-udf-http/mysql-udf-http-1.0.ebuild
new file mode 100644
index 000000000000..76152f4b2812
--- /dev/null
+++ b/dev-db/mysql-udf-http/mysql-udf-http-1.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs autotools
+
+DESCRIPTION="MySQL User-defined function (UDF) for HTTP REST"
+HOMEPAGE="https://code.google.com/p/mysql-udf-http/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/mysql-5.1
+ net-misc/curl"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
+ MYSQL_INCLUDE="$(mysql_config --include)"
+}
+
+src_prepare() {
+ # fix README
+ sed -i -e "s|${PN}\(\.so\)|${PN//-/_}\1|g" README
+
+ # fix Makefile.am
+ sed -i -e "s|${PN}\([_\.]la\)|${PN//-/_}\1|g" \
+ -e "s|\(-module\)|\1 -avoid-version|g" src/Makefile.am
+
+ epatch "${FILESDIR}/${PN}-stdlib.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-pic --disable-static --libdir="${MYSQL_PLUGINDIR}" \
+ --with-mysql="$(type -p mysql_config)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README
+
+ # remove obsolete *.la file
+ rm -f -- "${D}${MYSQL_PLUGINDIR}"/*.la
+}
+
+pkg_postinst() {
+ elog
+ elog "Please have a look at the documentation, how to"
+ elog "enable/disable the UDF functions of ${PN}."
+ elog
+ elog "The documentation is located here:"
+ elog "/usr/share/doc/${PF}"
+ elog
+}