summaryrefslogtreecommitdiff
path: root/dev-cpp/sparsehash/sparsehash-2.0.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-cpp/sparsehash/sparsehash-2.0.3-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-cpp/sparsehash/sparsehash-2.0.3-r1.ebuild')
-rw-r--r--dev-cpp/sparsehash/sparsehash-2.0.3-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-cpp/sparsehash/sparsehash-2.0.3-r1.ebuild b/dev-cpp/sparsehash/sparsehash-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..b043e1800ff6
--- /dev/null
+++ b/dev-cpp/sparsehash/sparsehash-2.0.3-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="An extremely memory-efficient hash_map implementation"
+HOMEPAGE="https://github.com/sparsehash/sparsehash"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S=${WORKDIR}/${PN}-${P}
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0.3-fix-buildsystem.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}