summaryrefslogtreecommitdiff
path: root/dev-cpp/sparsehash
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-cpp/sparsehash
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-cpp/sparsehash')
-rw-r--r--dev-cpp/sparsehash/Manifest7
-rw-r--r--dev-cpp/sparsehash/files/1.10-gcc46.patch16
-rw-r--r--dev-cpp/sparsehash/files/sparsehash-2.0.3-fix-buildsystem.patch71
-rw-r--r--dev-cpp/sparsehash/metadata.xml11
-rw-r--r--dev-cpp/sparsehash/sparsehash-1.10.ebuild27
-rw-r--r--dev-cpp/sparsehash/sparsehash-2.0.3-r1.ebuild24
6 files changed, 156 insertions, 0 deletions
diff --git a/dev-cpp/sparsehash/Manifest b/dev-cpp/sparsehash/Manifest
new file mode 100644
index 000000000000..eab2ad1aef0a
--- /dev/null
+++ b/dev-cpp/sparsehash/Manifest
@@ -0,0 +1,7 @@
+AUX 1.10-gcc46.patch 344 BLAKE2B 1fc47b87541612868ec90f9460f191938660a54bfcae7ebd894140b54d979700359def84c62627e53560524c84e5ca17f809eb79d103aac91939243ad7ccbd63 SHA512 10ba18dd4d102c92c467846d46288080f712f7d82b9a786daab13e74b9cbd0dd9923075d7e12288adaac68e31b96c8eb0a7d010e5d2fe3a2d2321413f2dd51a8
+AUX sparsehash-2.0.3-fix-buildsystem.patch 2649 BLAKE2B d7a5e7d4343279af069e0b8eb00ad2b8fc33e26840ee0a9ca63c73ea37aa99548d3c741d70647078424f27906946f261b07d764be9adaf47c1d13bc4bf6d302f SHA512 6732a3197550f75ce7a83d61882938d841694f41e9daec51ef36206306fdabdd33dd46eaec106a8877826098b8227368c1ed0962d36aa220abd0336713667bd4
+DIST sparsehash-1.10.tar.gz 289819 BLAKE2B fb66d945a52862465a870931b83846619fb7034b2acae053d75d859b359d866257a779d522d9267ab729d19aeac1365fc699e4a541b446f874c323f7c8ceaa0b SHA512 ecc01e755885b8da5927f4f56c95c02ce9a43e5c0280cdc1cdfa812f787396646925c0f602a35decdf94144e8d2f3ac31b80f5ed98b70ccca607a29bb11f8a35
+DIST sparsehash-2.0.3.tar.gz 322046 BLAKE2B 3749875bfbfa0ec9b92cfe68496a318208539745ca1b76910193879cb9ac790952b390cfbd941ff6e9714bd61546844e8f2d958d9b24845efeb54743facac136 SHA512 bb00d0acb8eba65f7da8015ea4f6bebf8bba36ed6777881960ee215f22b7be17b069c59838d210551ce67a34baccfc7b2fed603677ec53c0c32714d8e76f5d6c
+EBUILD sparsehash-1.10.ebuild 532 BLAKE2B f217f5ff5252e8516fc6e6817e073de8d500df0dbe296d78b3ddc8f63c1c020f83a4294e146d2328ff0a249b24c2a3863478d671da23cf61d89e00d61317d5a9 SHA512 768f1ff2c47d97ff663774a86b9540005810826dd7bf1ff5867452ef00f7f22f11dffabddc78389b09d00cdbfd27f2b5d765f90e030c32bbead6368747405184
+EBUILD sparsehash-2.0.3-r1.ebuild 520 BLAKE2B 13fdb6d8404479aa367344b2f5c49bb12074856d164123793240577aa3133214246549485cbfcf064aaf25045f2e3085ba5a1a696976b5d8a39d68ada4ffe273 SHA512 805380e93b7ef20ed633ac1971b76c0d1dba9a27687772cb1bfb067d63a575a8c59d95ffb9658a9b550b14d04927685d66dbaec00a93426c64c18dea1ff9b284
+MISC metadata.xml 335 BLAKE2B 80cfd400c2faff1ecebd19ea1e5737f4e3f95e266fcd6870d2efbb7f6d642e07cd2115ed90d4956c6506241719038113fd926d3a66c7ddaa89bf9ccd12bb7e74 SHA512 9d718bf4d0e71b393c36a57db6e165975f61570ad41dce4ac3f5aa55f2770b6f52a8f67eb04fa725c9bb839fd30393f2a78be6d6ad3c341f083053c94e934e62
diff --git a/dev-cpp/sparsehash/files/1.10-gcc46.patch b/dev-cpp/sparsehash/files/1.10-gcc46.patch
new file mode 100644
index 000000000000..4339b487eca0
--- /dev/null
+++ b/dev-cpp/sparsehash/files/1.10-gcc46.patch
@@ -0,0 +1,16 @@
+ src/google/sparsetable | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/src/google/sparsetable b/src/google/sparsetable
+index 0eeb22e..e8580b9 100644
+--- a/src/google/sparsetable
++++ b/src/google/sparsetable
+@@ -83,6 +83,8 @@
+ #endif
+ #endif
+
++#include <cstddef>
++
+ _START_GOOGLE_NAMESPACE_
+
+ #ifndef HAVE_U_INT16_T
diff --git a/dev-cpp/sparsehash/files/sparsehash-2.0.3-fix-buildsystem.patch b/dev-cpp/sparsehash/files/sparsehash-2.0.3-fix-buildsystem.patch
new file mode 100644
index 000000000000..237719c3b9f3
--- /dev/null
+++ b/dev-cpp/sparsehash/files/sparsehash-2.0.3-fix-buildsystem.patch
@@ -0,0 +1,71 @@
+* Do not override $(docdir) as part of the GNU conventions
+* Do not install 'COPYING' and 'INSTALL'
+* Install html files using html_ prefix and not doc_ prefix
+* Do not try to link against tcmalloc, the complexity of juggling
+ the options around isn't worth it
+Bug: https://bugs.gentoo.org/show_bug.cgi?id=585968
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -9,7 +9,7 @@
+ # (for sanity checking)
+ AC_CONFIG_SRCDIR(README)
+ AM_INIT_AUTOMAKE([dist-zip])
+-AM_CONFIG_HEADER(src/config.h)
++AC_CONFIG_HEADERS([src/config.h])
+
+ # Checks for programs.
+ AC_PROG_CXX
+@@ -28,23 +28,7 @@
+ # These are 'only' needed for unittests
+ AC_CHECK_HEADERS(sys/resource.h unistd.h sys/time.h sys/utsname.h)
+
+-# If you have google-perftools installed, we can do a bit more testing.
+-# We not only want to set HAVE_MALLOC_EXTENSION_H, we also want to set
+-# a variable to let the Makefile to know to link in tcmalloc.
+ AC_LANG([C++])
+-AC_CHECK_HEADERS(google/malloc_extension.h,
+- tcmalloc_libs=-ltcmalloc,
+- tcmalloc_libs=)
+-# On some systems, when linking in tcmalloc you also need to link in
+-# pthread. That's a bug somewhere, but we'll work around it for now.
+-tcmalloc_flags=""
+-if test -n "$tcmalloc_libs"; then
+- ACX_PTHREAD
+- tcmalloc_flags="\$(PTHREAD_CFLAGS)"
+- tcmalloc_libs="$tcmalloc_libs \$(PTHREAD_LIBS)"
+-fi
+-AC_SUBST(tcmalloc_flags)
+-AC_SUBST(tcmalloc_libs)
+
+ # Figure out where hash_map lives and also hash_fun.h (or stl_hash_fun.h).
+ # This also tells us what namespace hash code lives in.
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -11,12 +11,11 @@
+ AM_CXXFLAGS = -Wall -W -Wwrite-strings -Woverloaded-virtual -Wshadow
+ endif
+
+-docdir = $(prefix)/share/doc/$(PACKAGE)-$(VERSION)
+ ## This is for HTML and other documentation you want to install.
+ ## Add your documentation files (in doc/) in addition to these boilerplate
+ ## Also add a TODO file if you have one
+-dist_doc_DATA = AUTHORS COPYING ChangeLog INSTALL NEWS README README_windows.txt \
+- TODO \
++dist_doc_DATA = AUTHORS ChangeLog NEWS README README_windows.txt TODO
++dist_html_DATA = \
+ doc/dense_hash_map.html \
+ doc/dense_hash_set.html \
+ doc/sparse_hash_map.html \
+@@ -182,11 +181,6 @@
+ $(sparsehashinclude_HEADERS)
+ nodist_time_hash_map_SOURCES = $(nodist_internalinclude_HEADERS)
+
+-# If tcmalloc is installed, use it with time_hash_map; it gives us
+-# heap-usage statistics for the hash_map routines, which is very nice
+-time_hash_map_CXXFLAGS = @tcmalloc_flags@ $(AM_CXXFLAGS)
+-time_hash_map_LDFLAGS = @tcmalloc_flags@
+-time_hash_map_LDADD = @tcmalloc_libs@
+
+ ## ^^^^ END OF RULES TO MAKE THE LIBRARIES, BINARIES, AND UNITTESTS
+
diff --git a/dev-cpp/sparsehash/metadata.xml b/dev-cpp/sparsehash/metadata.xml
new file mode 100644
index 000000000000..60498dfe4403
--- /dev/null
+++ b/dev-cpp/sparsehash/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cpp@gentoo.org</email>
+ <name>Gentoo C++ Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sparsehash/sparsehash</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/sparsehash/sparsehash-1.10.ebuild b/dev-cpp/sparsehash/sparsehash-1.10.ebuild
new file mode 100644
index 000000000000..b3855b668231
--- /dev/null
+++ b/dev-cpp/sparsehash/sparsehash-1.10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="An extremely memory-efficient hash_map implementation"
+HOMEPAGE="https://github.com/google/sparsehash"
+SRC_URI="https://google-sparsehash.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gcc46.patch
+}
+
+src_install() {
+ default
+
+ # Installs just every piece
+ rm -rf "${D}/usr/share/doc"
+ dohtml doc/*
+}
diff --git a/dev-cpp/sparsehash/sparsehash-2.0.3-r1.ebuild b/dev-cpp/sparsehash/sparsehash-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..b043e1800ff6
--- /dev/null
+++ b/dev-cpp/sparsehash/sparsehash-2.0.3-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="An extremely memory-efficient hash_map implementation"
+HOMEPAGE="https://github.com/sparsehash/sparsehash"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S=${WORKDIR}/${PN}-${P}
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0.3-fix-buildsystem.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}