summaryrefslogtreecommitdiff
path: root/dev-cpp/robin-map/robin-map-0.6.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-cpp/robin-map/robin-map-0.6.3.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-cpp/robin-map/robin-map-0.6.3.ebuild')
-rw-r--r--dev-cpp/robin-map/robin-map-0.6.3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-cpp/robin-map/robin-map-0.6.3.ebuild b/dev-cpp/robin-map/robin-map-0.6.3.ebuild
new file mode 100644
index 000000000000..78a6b31dd3fb
--- /dev/null
+++ b/dev-cpp/robin-map/robin-map-0.6.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="C++ fast hash map and hash set using robin hood hashing"
+HOMEPAGE="https://github.com/Tessil/robin-map"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Tessil/robin-map"
+else
+ SRC_URI="https://github.com/Tessil/robin-map/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"