summaryrefslogtreecommitdiff
path: root/dev-cpp/robin-map
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-cpp/robin-map
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-cpp/robin-map')
-rw-r--r--dev-cpp/robin-map/Manifest4
-rw-r--r--dev-cpp/robin-map/metadata.xml12
-rw-r--r--dev-cpp/robin-map/robin-map-0.6.3.ebuild20
-rw-r--r--dev-cpp/robin-map/robin-map-9999.ebuild20
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-cpp/robin-map/Manifest b/dev-cpp/robin-map/Manifest
new file mode 100644
index 000000000000..302b6c9bbab5
--- /dev/null
+++ b/dev-cpp/robin-map/Manifest
@@ -0,0 +1,4 @@
+DIST robin-map-0.6.3.tar.gz 64506 BLAKE2B 46a2b5b47346016695db0c49f73cfbf8530b7db0a31527030eb00f3b6f0695325ab6fe16de1e60d6b1d0793818bdd1e31e50117f2e2e4c50154f65b38ac66d84 SHA512 485557f300d33bda62bb8accdf246819ee8ffe956bc022e7ddca54ff6ad1a9fdb8db8d80690add3ef238e834d1eb8e2905920cb0a0674e7df010f6946d01297b
+EBUILD robin-map-0.6.3.ebuild 502 BLAKE2B 159600dc8f19618ce93ff5f58fc80cba234ae7700685d9e54b4b3b11b59b19a028ded4719bce1a449243af5070e01b9f7b7489cb9d930573ea9d7054a350226d SHA512 36b12444e22c878ab08f411891aa27d579fc3ef6dc09db34de2403193c907d413b0c6ef7aa447a58894fdf5332c32f0cd9c76985a7036b6b20a4518edb4ce371
+EBUILD robin-map-9999.ebuild 504 BLAKE2B fafe5db735e95537d9885600e4a2c760ed5070c769079411ea422c892bef4b06033f50456b855e662760a2d71eabdc8ee3b1f9f1e9dc5f0785893b34b1187877 SHA512 42dc895fc411aaeca3854220783c544dcb691c54590af7d5c7562fc44cde6e19a86d10c3ceb942ea2a34eef36115e513fd318867592ae0c9d8302d0ec912216a
+MISC metadata.xml 368 BLAKE2B de2351d3b1e732b8c5a5e17afdc6b0a540ed78ff6404cf3faac0e51fd44678b352b9a0df4aabf11bc49a31b00333e941525b4a873576676a6e46be87fe4b59bb SHA512 ecc9d3212da03cae0ff6b48bc78dde27d40769faaa48bc66c86a13fc88d80fd7a89bdb4137e911c0ad06bb12c40220e9427fb8460fb95eb1beae0fc8af8d2a0e
diff --git a/dev-cpp/robin-map/metadata.xml b/dev-cpp/robin-map/metadata.xml
new file mode 100644
index 000000000000..8238cc0570ce
--- /dev/null
+++ b/dev-cpp/robin-map/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-cpp/robin-map/robin-map-0.6.3.ebuild b/dev-cpp/robin-map/robin-map-0.6.3.ebuild
new file mode 100644
index 000000000000..78a6b31dd3fb
--- /dev/null
+++ b/dev-cpp/robin-map/robin-map-0.6.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="C++ fast hash map and hash set using robin hood hashing"
+HOMEPAGE="https://github.com/Tessil/robin-map"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Tessil/robin-map"
+else
+ SRC_URI="https://github.com/Tessil/robin-map/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
diff --git a/dev-cpp/robin-map/robin-map-9999.ebuild b/dev-cpp/robin-map/robin-map-9999.ebuild
new file mode 100644
index 000000000000..99255a6ea187
--- /dev/null
+++ b/dev-cpp/robin-map/robin-map-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="C++ fast hash map and hash set using robin hood hashing"
+HOMEPAGE="https://github.com/Tessil/robin-map"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Tessil/robin-map"
+else
+ SRC_URI="https://github.com/Tessil/robin-map/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"