summaryrefslogtreecommitdiff
path: root/dev-cpp/nlohmann_json/nlohmann_json-3.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-cpp/nlohmann_json/nlohmann_json-3.6.1.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-cpp/nlohmann_json/nlohmann_json-3.6.1.ebuild')
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.6.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.6.1.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.6.1.ebuild
new file mode 100644
index 000000000000..fd4f1a4593e9
--- /dev/null
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.6.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="JSON for Modern C++"
+HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
+SRC_URI="https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+DOCS=( ChangeLog.md README.md )
+
+S=${WORKDIR}/json-${PV}
+
+src_compile() {
+ meson_src_compile
+ use doc && emake -C doc
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ meson_src_install
+ use doc && dodoc -r doc/html
+}