summaryrefslogtreecommitdiff
path: root/dev-cpp/nlohmann_json
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-cpp/nlohmann_json
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-cpp/nlohmann_json')
-rw-r--r--dev-cpp/nlohmann_json/Manifest2
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.6.1.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-cpp/nlohmann_json/Manifest b/dev-cpp/nlohmann_json/Manifest
index 7b9d4e753962..a9b3bfceb050 100644
--- a/dev-cpp/nlohmann_json/Manifest
+++ b/dev-cpp/nlohmann_json/Manifest
@@ -1,3 +1,5 @@
DIST nlohmann_json-3.5.0.tar.gz 114796008 BLAKE2B 94caa0374be1d38230cb13b8cd9deb3da04e4b81d361ce6baf54c1bad231945a94df74683a31660dc98413dbf23ea7596c6ed1da9cda9e02add7d7c6568973e3 SHA512 e2874e10e12070e8e1b9c01f41ce24002a3859c4aca8bf46083ea08e68f44ed6725bdcdf8e592b1e50d69975d506836c62a8e10fc6da00f0844c149dd6676996
+DIST nlohmann_json-3.6.1.tar.gz 118862808 BLAKE2B 257508b33480741bd4438fe928869c0744a5e84806fa4e068b048bfc0e665802a45f31bc740c14f74e7a0384df18b9bba58a0e001750b1a800ea00cd1712b280 SHA512 e0565ccdee34e89a6836a97f039c04a0bac445b44f6f323918ea424b34e4577688a4f4f72d5ef1ec0b53d159bfe87e8e9c97b70ef98231ea463f59f05e16eb2a
EBUILD nlohmann_json-3.5.0.ebuild 642 BLAKE2B 6febe4e494834b7b050fcb4bfe2556b364dd2ef0d61bf2f83d837ec8a30bef517c80e67d1676e2b65957debf642fd2da5e8fdbeeaf16159149d8a96fef4fb165 SHA512 649bd0a762be3b89acfbcba0c49c683f5ac8a5ed4d07180033930ed7446d48a989781d2b2d5a2671bcaf7be02e5ff4e562d0186bd1c4d2b4c40a8b6a78993e99
+EBUILD nlohmann_json-3.6.1.ebuild 642 BLAKE2B 6febe4e494834b7b050fcb4bfe2556b364dd2ef0d61bf2f83d837ec8a30bef517c80e67d1676e2b65957debf642fd2da5e8fdbeeaf16159149d8a96fef4fb165 SHA512 649bd0a762be3b89acfbcba0c49c683f5ac8a5ed4d07180033930ed7446d48a989781d2b2d5a2671bcaf7be02e5ff4e562d0186bd1c4d2b4c40a8b6a78993e99
MISC metadata.xml 337 BLAKE2B a929f6f116c9b0bdf3415325cc710b4b2afa1bb2b6a74c8df9531ad0358d8141054cee8be2be7b380574a8c59359f1c9e9bd8b7fcb607b8da251b787d75dcf43 SHA512 d6ae8564e57c1062487634fb7d4e2c0fa4c79a38d89c06c3514d3459cfd08500634a5fc8add1e126f3181b711dae74931c906b67f6aac51d6400cd2800f293df
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.6.1.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.6.1.ebuild
new file mode 100644
index 000000000000..fd4f1a4593e9
--- /dev/null
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.6.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="JSON for Modern C++"
+HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
+SRC_URI="https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+DOCS=( ChangeLog.md README.md )
+
+S=${WORKDIR}/json-${PV}
+
+src_compile() {
+ meson_src_compile
+ use doc && emake -C doc
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ meson_src_install
+ use doc && dodoc -r doc/html
+}