summaryrefslogtreecommitdiff
path: root/dev-ada/xmlada/xmlada-2018.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /dev-ada/xmlada/xmlada-2018.ebuild
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'dev-ada/xmlada/xmlada-2018.ebuild')
-rw-r--r--dev-ada/xmlada/xmlada-2018.ebuild47
1 files changed, 17 insertions, 30 deletions
diff --git a/dev-ada/xmlada/xmlada-2018.ebuild b/dev-ada/xmlada/xmlada-2018.ebuild
index 0696bbdadb19..04866d734b83 100644
--- a/dev-ada/xmlada/xmlada-2018.ebuild
+++ b/dev-ada/xmlada/xmlada-2018.ebuild
@@ -17,11 +17,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gnat_2016 gnat_2017 +gnat_2018 +shared static-libs static-pic"
REQUIRED_USE="|| ( shared static-libs static-pic )
- ^^ ( gnat_2016 gnat_2017 gnat_2018 )"
+ !gnat_2016 ^^ ( gnat_2017 gnat_2018 )"
RDEPEND="gnat_2016? ( dev-lang/gnat-gpl:4.9.4 )
gnat_2017? ( dev-lang/gnat-gpl:6.3.0 )
- gnat_2018? ( dev-lang/gnat-gpl:7.3.0 )"
+ gnat_2018? ( dev-lang/gnat-gpl:7.3.1 )"
DEPEND="${RDEPEND}
dev-ada/gprbuild[gnat_2016=,gnat_2017=,gnat_2018=]"
@@ -56,38 +56,25 @@ src_test() {
}
src_install () {
- local includedir=/usr/include/${PN}
-
- fix_install () {
- mv "${D}"${includedir}/$1.$2/* "${D}"${includedir}/$1/ || die
- for file in "${D}"${includedir}/$1/*; do
- dosym ../$1/$(basename ${file}) \
- ${includedir}/$1.$2/$(basename ${file})
- done
+ build () {
+ gprinstall -XLIBRARY_TYPE=$1 -f -p -XBUILD=Production \
+ -XPROCESSORS=$(makeopts_jobs) --prefix="${D}"usr \
+ --install-name=xmlada --build-var=LIBRARY_TYPE \
+ --build-var=XMLADA_BUILD \
+ --build-name=$1 xmlada.gpr || die "gprinstall failed"
}
-
+ if use shared; then
+ build relocatable
+ fi
if use static-libs; then
- emake PROCESSORS=$(makeopts_jobs) install-static
+ build static
fi
- for kind in shared static-pic; do
- if use ${kind}; then
- emake PROCESSORS=$(makeopts_jobs) install-${kind}
- fi
- done
- rm "${D}"/usr/lib/libxmlada_* || die
- for dir in xmlada_{dom,input,sax,schema,unicode}; do
- dodir /usr/include/${PN}/${dir}
- if use shared; then
- fix_install ${dir} relocatable
- fi
- if use static-libs; then
- fix_install ${dir} static
- fi
- if use static-pic; then
- fix_install ${dir} static-pic
- fi
- done
+ if use static-pic; then
+ build static-pic
+ fi
+
einstalldocs
dodoc xmlada-roadmap.txt
rm "${D}"/usr/share/doc/${PN}/.buildinfo || die
+ rm -r "${D}"/usr/share/gpr/manifests || die
}