summaryrefslogtreecommitdiff
path: root/dev-ada/xmlada
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /dev-ada/xmlada
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'dev-ada/xmlada')
-rw-r--r--dev-ada/xmlada/Manifest2
-rw-r--r--dev-ada/xmlada/xmlada-2018.ebuild47
2 files changed, 18 insertions, 31 deletions
diff --git a/dev-ada/xmlada/Manifest b/dev-ada/xmlada/Manifest
index c2ea8f36d2ba..33304053e3eb 100644
--- a/dev-ada/xmlada/Manifest
+++ b/dev-ada/xmlada/Manifest
@@ -3,5 +3,5 @@ AUX xmlada-2018-gentoo.patch 1133 BLAKE2B 6b15f8225c8d4094417f20b61261fc247a4c92
DIST xmlada-gpl-2017-src.tar.gz 1578393 BLAKE2B 7b4894040b6044e86c96cbd530ebda5c0cfc4ad0e2b472d46798a93f535aca0916b03385a3aef49bd4e59d508a9665c856360e9cab0a4f67b15091228b629d81 SHA512 371f6adc01550a4bb13204ec0404dc1165438db595f4346813e5a23a155de74c857c40c55adde173919c2fe35b3b91d78b235c9718ee86bc848e62ddfd7fa2b4
DIST xmlada-gpl-2018-src.tar.gz 1582215 BLAKE2B 11012dab19f45507eeb5ce6ebec9a77ceb5dfb7749960922f0f48bb1b0409305fd43466a7af90b48ff0a0cf58612e8859274a92e0fe272b4e57a59b92a1725f1 SHA512 8970c4e68defad66625c1110554dadfc485fbbe42e832987593cf727e98f13dd87c90b84461187dbbe2b1051831e6e70f9f53d6a0cfc07451726d601b2856430
EBUILD xmlada-2017.ebuild 2120 BLAKE2B 075a4fc91c5a68063f01df6fbbadd51ba550cd4e1b6896b0ad4ab5345d920fbab354aa3dff9ad0c5609fa16a25173c7390cc03dce16cc59bf87c7c3335bcd17a SHA512 bb4e8f7623d06eec64d5677bb41ef69e2fe4dd503799c66da37a2d2a42f63ac125900a10c5f04c4ca1e9b19696c4112877ce233f009352f96b53fdb82eb4da7b
-EBUILD xmlada-2018.ebuild 2193 BLAKE2B 9b3030c7b5d8cda39aac1bbd25ad83b1d3e01a5fdcc133103505e38d3b051728f581846157d50a511e6543f0f362187f969cee733d38181b0055f8a41dde4b9f SHA512 c1c1bcc1907a7faf30616ddbaa67e9abe5ce510f83becb0c2cea817abf88a1b188617b41ef9fa19900824ee288585ab4204b6dcd741fec92399900eb1a4523ea
+EBUILD xmlada-2018.ebuild 1868 BLAKE2B e2754399074f9dd41c217781f9f774fa8cc4bebcd113959d1d716e952ecdc2a2422f5bafd256fb5be0f91ee9044f925258de54a21e55b81a953f9b1850404d5b SHA512 b760d9ac596ed331ac59bcce7c3cd2260d4f3e99cccd68980844641d153ffeb97abd2d21934b4f6314891983f8437713b3e907135815de730b0ef8aabc474e48
MISC metadata.xml 1143 BLAKE2B 7f633dfb6a079c1e981b7b7fe53f60df746919bea32c32c257002c3e13682d24b269d5bbe1b61700df930b7722d3f503bfff52c00676301f7a19523749edda81 SHA512 ce5fe7f5ca7d79bbd4b648608f1521056b62b90c70aec62b49e4be5737319df56a9248bd57b695b1469e2bb9b9b49c6c910c2321f1a690546ae1447bb0519006
diff --git a/dev-ada/xmlada/xmlada-2018.ebuild b/dev-ada/xmlada/xmlada-2018.ebuild
index 0696bbdadb19..04866d734b83 100644
--- a/dev-ada/xmlada/xmlada-2018.ebuild
+++ b/dev-ada/xmlada/xmlada-2018.ebuild
@@ -17,11 +17,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gnat_2016 gnat_2017 +gnat_2018 +shared static-libs static-pic"
REQUIRED_USE="|| ( shared static-libs static-pic )
- ^^ ( gnat_2016 gnat_2017 gnat_2018 )"
+ !gnat_2016 ^^ ( gnat_2017 gnat_2018 )"
RDEPEND="gnat_2016? ( dev-lang/gnat-gpl:4.9.4 )
gnat_2017? ( dev-lang/gnat-gpl:6.3.0 )
- gnat_2018? ( dev-lang/gnat-gpl:7.3.0 )"
+ gnat_2018? ( dev-lang/gnat-gpl:7.3.1 )"
DEPEND="${RDEPEND}
dev-ada/gprbuild[gnat_2016=,gnat_2017=,gnat_2018=]"
@@ -56,38 +56,25 @@ src_test() {
}
src_install () {
- local includedir=/usr/include/${PN}
-
- fix_install () {
- mv "${D}"${includedir}/$1.$2/* "${D}"${includedir}/$1/ || die
- for file in "${D}"${includedir}/$1/*; do
- dosym ../$1/$(basename ${file}) \
- ${includedir}/$1.$2/$(basename ${file})
- done
+ build () {
+ gprinstall -XLIBRARY_TYPE=$1 -f -p -XBUILD=Production \
+ -XPROCESSORS=$(makeopts_jobs) --prefix="${D}"usr \
+ --install-name=xmlada --build-var=LIBRARY_TYPE \
+ --build-var=XMLADA_BUILD \
+ --build-name=$1 xmlada.gpr || die "gprinstall failed"
}
-
+ if use shared; then
+ build relocatable
+ fi
if use static-libs; then
- emake PROCESSORS=$(makeopts_jobs) install-static
+ build static
fi
- for kind in shared static-pic; do
- if use ${kind}; then
- emake PROCESSORS=$(makeopts_jobs) install-${kind}
- fi
- done
- rm "${D}"/usr/lib/libxmlada_* || die
- for dir in xmlada_{dom,input,sax,schema,unicode}; do
- dodir /usr/include/${PN}/${dir}
- if use shared; then
- fix_install ${dir} relocatable
- fi
- if use static-libs; then
- fix_install ${dir} static
- fi
- if use static-pic; then
- fix_install ${dir} static-pic
- fi
- done
+ if use static-pic; then
+ build static-pic
+ fi
+
einstalldocs
dodoc xmlada-roadmap.txt
rm "${D}"/usr/share/doc/${PN}/.buildinfo || die
+ rm -r "${D}"/usr/share/gpr/manifests || die
}