summaryrefslogtreecommitdiff
path: root/app-vim/xsl-syntax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/xsl-syntax
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/xsl-syntax')
-rw-r--r--app-vim/xsl-syntax/Manifest3
-rw-r--r--app-vim/xsl-syntax/metadata.xml8
-rw-r--r--app-vim/xsl-syntax/xsl-syntax-0.3.11-r2.ebuild19
3 files changed, 30 insertions, 0 deletions
diff --git a/app-vim/xsl-syntax/Manifest b/app-vim/xsl-syntax/Manifest
new file mode 100644
index 000000000000..c2eca61b6c80
--- /dev/null
+++ b/app-vim/xsl-syntax/Manifest
@@ -0,0 +1,3 @@
+DIST xsl-syntax-0.3.11.tar.bz2 5770 BLAKE2B d7d06bf7e2537c8c6c1419f557e4c29042a1af6dd31850c28feccbd342a1beb60dded565f48b715d021ebe3279e0d4a75daa3063e7e8347a1977f97947a0a92a SHA512 e09f0f6ebe023a681560a12e919c9573abc2bf0f1a6fe1bda233ca296fa4fa81bead99aeb7eafb387f04e199f7601d8ce6593c767be1b3e94ff73135ea0f4361
+EBUILD xsl-syntax-0.3.11-r2.ebuild 565 BLAKE2B dcc903b148fe5514884f4e3d39b0b6c00f904f06ec1c11b19cfefae577c1993d7d56d2fc7718a362b3288bb03b0cd1d8ea47d9d49face56ae29841c87b2e96f9 SHA512 d214c81fb756080531fa1b8bb3c48b79cf33c9821fdd2bb0fe24de3dce20831b62d78be2ab955cec6b6e19eb1c07222160ef3defca3cc732914dec1e54f1c02d
+MISC metadata.xml 249 BLAKE2B 7ae6eac3ca23edbcbaa6aee682bb4aec155e3166f169eef8e4400e59fa56113ecc3593680d55cc57f08a4a718963dd3d0bb804bd1e8771ed60a4bebaae9db281 SHA512 4051dd059d975d2e1799125f7defbf5a62a168241d8b83d83710592efd60808800951c4fd6da1294044d7e7ec6b757b8d50593fd076696f826dec761e99645c7
diff --git a/app-vim/xsl-syntax/metadata.xml b/app-vim/xsl-syntax/metadata.xml
new file mode 100644
index 000000000000..5c000c763084
--- /dev/null
+++ b/app-vim/xsl-syntax/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/xsl-syntax/xsl-syntax-0.3.11-r2.ebuild b/app-vim/xsl-syntax/xsl-syntax-0.3.11-r2.ebuild
new file mode 100644
index 000000000000..8bc90a7472cb
--- /dev/null
+++ b/app-vim/xsl-syntax/xsl-syntax-0.3.11-r2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Syntax for XSLT (with HTML and others)"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=257"
+LICENSE="vim"
+KEYWORDS="alpha amd64 ia64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+VIM_PLUGIN_HELPURI="https://www.vim.org/scripts/script.php?script_id=257"
+
+src_prepare() {
+ default
+ # hi link is evil. See bug #101787, bug #101804.
+ sed -i -e 's,^hi link,hi def link,' syntax/xsl.vim || die "sed failed"
+}