summaryrefslogtreecommitdiff
path: root/app-vim/xsl-syntax/xsl-syntax-0.3.11-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/xsl-syntax/xsl-syntax-0.3.11-r2.ebuild')
-rw-r--r--app-vim/xsl-syntax/xsl-syntax-0.3.11-r2.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/app-vim/xsl-syntax/xsl-syntax-0.3.11-r2.ebuild b/app-vim/xsl-syntax/xsl-syntax-0.3.11-r2.ebuild
new file mode 100644
index 000000000000..8bc90a7472cb
--- /dev/null
+++ b/app-vim/xsl-syntax/xsl-syntax-0.3.11-r2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Syntax for XSLT (with HTML and others)"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=257"
+LICENSE="vim"
+KEYWORDS="alpha amd64 ia64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+VIM_PLUGIN_HELPURI="https://www.vim.org/scripts/script.php?script_id=257"
+
+src_prepare() {
+ default
+ # hi link is evil. See bug #101787, bug #101804.
+ sed -i -e 's,^hi link,hi def link,' syntax/xsl.vim || die "sed failed"
+}