summaryrefslogtreecommitdiff
path: root/app-vim/vim-latex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /app-vim/vim-latex
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'app-vim/vim-latex')
-rw-r--r--app-vim/vim-latex/Manifest1
-rw-r--r--app-vim/vim-latex/vim-latex-1.10.0-r2.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-vim/vim-latex/Manifest b/app-vim/vim-latex/Manifest
index e3904181e9be..6a7da8105632 100644
--- a/app-vim/vim-latex/Manifest
+++ b/app-vim/vim-latex/Manifest
@@ -1,3 +1,4 @@
DIST vim-latex-1.10.0.tar.gz 260820 BLAKE2B 2314ad5ded3bea51def3172e8f2b7a7483839b58804f9d8c1cc1c8f1139c1da731f91525691d47dba57d07a7db85c371e87c5ce0d3d22a004a9402df7e7cad3a SHA512 1d22b675c124e402a280dcc3a675b49a92fb9f4d42efdda0ea97be26379cd6c023589a35e165f4231524d853380e22411901bfbcc98f171c938ba800821a1213
EBUILD vim-latex-1.10.0-r1.ebuild 1569 BLAKE2B 528be5ca5ef37bad2794a1f8990bc768b6d47fd8427609fd574311d6474306c5a087d4ddfc1669f36dcbfc26434f704887f9ac7ad197585fea4023ffef906676 SHA512 33daa51732a577e0f75cdf70d591fa8008eaae823473813ea7d293a614987389333a941baf05364b18bb1d4f3440b8308e0a8c934a72e1696a07e18e940c4650
+EBUILD vim-latex-1.10.0-r2.ebuild 1577 BLAKE2B d8619c6debee550dc49df52b0db4555408aa77e07a958c6d0eeb9b13f8ac44bc07285e1f9e67a46c7d744262ab02ea59a7e00f70dcc5b5e2ad6e5e8176efd1eb SHA512 a1ac6495641601608159b9237faa3f47d478c272cbe4a275bc0d2f7807f6cece5bfa7756efb19bd84dd694086a0a897218e5d467c7c0dce75f82c884d5391812
MISC metadata.xml 328 BLAKE2B bcf4c9979e43da6c141669c218e852e7a0c062d900c35790709e393f6cabc56f646f7a84e8057d9dbafa0a73e5786135a7cfe3ef825af867500bcd502f03a61f SHA512 e14b88742b6d8143cb578ddac61dbc0ac5e84c90659e8d9b5c40882ebdf35dc001b1ffae26eb90617434b2c8a898055c838738bf7cf18a45cd2a2ce66a30bdce
diff --git a/app-vim/vim-latex/vim-latex-1.10.0-r2.ebuild b/app-vim/vim-latex/vim-latex-1.10.0-r2.ebuild
new file mode 100644
index 000000000000..ed03b0f51f16
--- /dev/null
+++ b/app-vim/vim-latex/vim-latex-1.10.0-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="A comprehensive set of tools to view, edit and compile LaTeX documents"
+HOMEPAGE="http://vim-latex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ || (
+ app-editors/vim[python,${PYTHON_SINGLE_USEDEP}]
+ app-editors/gvim[python,${PYTHON_SINGLE_USEDEP}]
+ )
+ virtual/latex-base
+ !app-vim/vimtex"
+
+VIM_PLUGIN_HELPFILES="latex-suite.txt latex-suite-quickstart.txt latexhelp.txt imaps.txt"
+
+src_compile() { :; }
+
+src_install() {
+ # remove unused metadata
+ rm vim-latex.metainfo.xml || die
+
+ # don't mess up vim's doc dir with random files
+ mv doc mydoc || die
+ mkdir doc || die
+ mv mydoc/*.txt doc/ || die
+ rm -rf mydoc || die
+
+ # don't install buggy tags scripts, use ctags instead
+ rm latextags ltags || die
+
+ vim-plugin_src_install
+
+ # use executable permissions (bug #352403)
+ fperms a+x /usr/share/vim/vimfiles/ftplugin/latex-suite/outline.py
+
+ python_fix_shebang "${ED}"
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ echo
+ elog "To use the vim-latex plugin add:"
+ elog " filetype plugin on"
+ elog ' set grepprg=grep\ -nH\ $*'
+ elog " let g:tex_flavor='latex'"
+ elog "to your ~/.vimrc-file"
+ echo
+ fi
+}