summaryrefslogtreecommitdiff
path: root/app-vim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /app-vim
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/Manifest.gzbin31721 -> 31746 bytes
-rw-r--r--app-vim/easytags/Manifest1
-rw-r--r--app-vim/easytags/easytags-3.11-r1.ebuild50
-rw-r--r--app-vim/exheres-syntax/Manifest4
-rw-r--r--app-vim/exheres-syntax/exheres-syntax-20090310.ebuild6
-rw-r--r--app-vim/exheres-syntax/exheres-syntax-99999999.ebuild4
-rw-r--r--app-vim/gitgutter/Manifest2
-rw-r--r--app-vim/gitgutter/gitgutter-99999999.ebuild5
-rw-r--r--app-vim/notes/Manifest2
-rw-r--r--app-vim/notes/notes-0.33.4-r1.ebuild (renamed from app-vim/notes/notes-0.33.4.ebuild)23
-rw-r--r--app-vim/pyclewn/Manifest2
-rw-r--r--app-vim/pyclewn/pyclewn-2.1-r2.ebuild (renamed from app-vim/pyclewn/pyclewn-2.1-r1.ebuild)26
-rw-r--r--app-vim/vim-latex/Manifest1
-rw-r--r--app-vim/vim-latex/vim-latex-1.10.0-r2.ebuild65
-rw-r--r--app-vim/vimoutliner/Manifest2
-rw-r--r--app-vim/vimoutliner/vimoutliner-0.4.0_p20180301-r2.ebuild23
16 files changed, 174 insertions, 42 deletions
diff --git a/app-vim/Manifest.gz b/app-vim/Manifest.gz
index fb09041086f9..69c784ffd199 100644
--- a/app-vim/Manifest.gz
+++ b/app-vim/Manifest.gz
Binary files differ
diff --git a/app-vim/easytags/Manifest b/app-vim/easytags/Manifest
index 049be10074f7..9f6c9c6edd1e 100644
--- a/app-vim/easytags/Manifest
+++ b/app-vim/easytags/Manifest
@@ -1,4 +1,5 @@
AUX easytags-3.11-fix-ctags-detection.patch 2964 BLAKE2B eafaddd9877d8732eeace0197ab29cedba38a89a1f7c4e1fb2192cb075bc7a4541e6a5e5448a8944a7f6a0b47fb1cd481035529d6b11d5508df35089f2e85865 SHA512 f3ef6cfce5cbbebc4d33fc5f6fe0b7df037c9ec80da6f4a2b29bccb15e00b385719e654238f6becea1372900ac5f9e5e6d6af481537dde12c03cda24ee49e674
DIST easytags-3.11.tar.gz 40572 BLAKE2B a6b228743f493bd467aff6685b6799de7e4862d384e14c81a084d7a211cf165d62cf902415a3c98a69858eded64c606bd4565f6e0c43fab7c078ba81d0ec5217 SHA512 9c1985a02b2718315d825ed29c06cbf78050e693893a9a7530a774031cbe9e6a27ee1dc91878950a1fbcaf7ea685faeb799d1e5b218b9ce25718783409f66130
+EBUILD easytags-3.11-r1.ebuild 1224 BLAKE2B d1784173bec8c978278e59586254b2bf6c9eaa9ac9ca744ff448eef65ae23f16d95476abd31d542ffdb2edbef70856142cc156bbb883bc57bfa93db6689fb370 SHA512 f1161fdfce9aa8ca733b25bb3ddcc187957e989b3b256fecdc4d314daa57e3b0979294d3ed2ad047748bbea48f573017531ba68df8270573e47cd4c2514760eb
EBUILD easytags-3.11.ebuild 996 BLAKE2B c3211f023786914dc5d9c9f76cff7295cc8c3ead593438d74cb31565aee0f5c0a7057a6d2b3581d63a1bbcc2d2e5a70add77b2e84e3e78d7b9cab5478b3942f9 SHA512 c351e922c7d4656a1d92e2aaed798b125b40bee89a7e4d758ba0ea197a204b4905d5d8f017dcf5d781ee865350c68fddc2814a856ef3f16abf404486595274a8
MISC metadata.xml 342 BLAKE2B 5e7e191544a04bc4ae28e482deef1c44c8ee11f6afe01d9ed6b138364f771411e341b5827e92bdfeae1edffdc166979c72a53034886530b0cdb55e34d9c2ce6e SHA512 0f4fbbedc023ccccc74ef8e020c3a90a0ccb0184164a52dd733699c5d4bf729d09478ea87fda093197679f7b44b3c1b64d3c64845d91d3fb92f9e3a1eab8fc78
diff --git a/app-vim/easytags/easytags-3.11-r1.ebuild b/app-vim/easytags/easytags-3.11-r1.ebuild
new file mode 100644
index 000000000000..cbd424d4f07a
--- /dev/null
+++ b/app-vim/easytags/easytags-3.11-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit python-single-r1 vim-plugin
+
+DESCRIPTION="vim plugin: automated tag file generation and syntax highlighting"
+HOMEPAGE="http://peterodding.com/code/vim/easytags/"
+SRC_URI="https://github.com/xolox/vim-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-vim/vim-misc
+ dev-util/ctags"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S="${WORKDIR}/vim-${P}"
+
+PATCHES=( "${FILESDIR}/${P}-fix-ctags-detection.patch" )
+
+src_prepare() {
+ default
+ rm addon-info.json INSTALL.md README.md || die
+}
+
+src_install() {
+ vim-plugin_src_install
+
+ fperms 755 /usr/share/vim/vimfiles/misc/easytags/{normalize-tags,why-so-slow}.py
+
+ # fix scripts
+ local f
+ for f in $(find "${ED}" -type f -name \*.py); do
+ ebegin "Fixing $(basename ${f})"
+ if [[ $f =~ highlight.py ]]; then
+ sed -e '1 i\#!/usr/bin/env python3' -i "${f}" || die "can't sed patch ${f}"
+ fi
+ 2to3 -w -n --no-diffs "${f}" >& /dev/null || die "can't convert ${f} to Python 3"
+ python_fix_shebang -q -f "${f}"
+ eend $?
+ done
+}
diff --git a/app-vim/exheres-syntax/Manifest b/app-vim/exheres-syntax/Manifest
index ee5a918b07cc..afd4c0dfd286 100644
--- a/app-vim/exheres-syntax/Manifest
+++ b/app-vim/exheres-syntax/Manifest
@@ -1,4 +1,4 @@
DIST exheres-syntax-20090310.tar.bz2 3670 BLAKE2B 27a6f075f80b7fc2e172b9586211a248f8075affd6a20ea52cafe06cda4f6d489a56a539e6a7619b3f7ce7fd29084ea990e66efbbdef7198a6857912eb9288c8 SHA512 616ef17367c68157d715321e457aaf0c65c97329f0848cb964d8974b6a85b4147f2e192b2ea3fcbfa3970e095bd9874203ce9723c73d1ef8350200732198c79f
-EBUILD exheres-syntax-20090310.ebuild 429 BLAKE2B ac967a7af33014986c90134098220abd47f0af841b35643a04b4205eead5f728bdd07fc578b9ab42075227e2f91966717119cc4921938c861b07e9eaa8e4bb3b SHA512 9da67961cc12debd0077fa9e280617ea01f6087c28ab0fae488dcc168f63efbcd76f5a323c64b50d982a356044a57b7950bf03a4ac9f1ed68b3cd8f16bf8dfa9
-EBUILD exheres-syntax-99999999.ebuild 456 BLAKE2B 1b3e21ae23744ad4695c2733ff4193899fe12cb2a59d051600082efd0458cc8930480d6edd18ce4c89aeb77989b651f3dd5b8f05853264f363437ac48006cdef SHA512 672617538cde07bafa27bad4feeea22448f579ae9069faab5687fd08579bf7d51366e9ecca63163c7bdda030fe2ccbd721b8a4580d160544774c91474271e91a
+EBUILD exheres-syntax-20090310.ebuild 428 BLAKE2B 439e309b11ea2127485ef5d2c0525da507e4479b757e2ee18a6e379d3ee7a26e483c9c452e99c0e2748ff8ae5d1c69de0a719b6628ebfe46e1bc9749969629b4 SHA512 3f179920aae04f25709b0f458b04854b64565f0f3622a89b768301106583f2e753f2c66d92417c8a6ced5a80486051e90c51541c82a665e1f2155a4022f0a3ff
+EBUILD exheres-syntax-99999999.ebuild 454 BLAKE2B f2252c222665d279c4000984f5b695b8a90bf9c7bf3c140727c4b863712affc37b79601aa78a61130d1347daab5a02aff216d833cbf64a912bf81d2f80ad7e79 SHA512 ddf73bff11158e783c466536f6f6561b57c8af34206b7b83a2307292679930bc666535fe06dea9fea487eee46be0b2a8920b91b53752c5a93e80faca922ec812
MISC metadata.xml 251 BLAKE2B 4951201e33801e19bf0cf7b2bb87164107d87f074a28da579e90da44077e2833c36b51b63f92780ec4aa611d482a80a03723b56175bc041adcbe5573b537072d SHA512 5c10f22ced866afcb94b97662e270d3d4164ca9f988621c13d6a7c4508da8d9e9bbb804798cd468a2cc84ae9fd61aff32c782a372b0b8de145c1ea71751bab34
diff --git a/app-vim/exheres-syntax/exheres-syntax-20090310.ebuild b/app-vim/exheres-syntax/exheres-syntax-20090310.ebuild
index 98ebebae3200..7a014b993ceb 100644
--- a/app-vim/exheres-syntax/exheres-syntax-20090310.ebuild
+++ b/app-vim/exheres-syntax/exheres-syntax-20090310.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,8 +6,8 @@ EAPI=6
inherit vim-plugin
DESCRIPTION="vim plugin: exheres format highlighting"
-HOMEPAGE="http://www.exherbo.org/"
-SRC_URI="http://dev.exherbo.org/~ahf/pub/software/releases/${PN}/${P}.tar.bz2"
+HOMEPAGE="https://www.exherbo.org/"
+SRC_URI="https://dev.exherbo.org/~ahf/pub/software/releases/${PN}/${P}.tar.bz2"
LICENSE="vim"
SLOT="0"
diff --git a/app-vim/exheres-syntax/exheres-syntax-99999999.ebuild b/app-vim/exheres-syntax/exheres-syntax-99999999.ebuild
index 21106c1f23b8..437d26234642 100644
--- a/app-vim/exheres-syntax/exheres-syntax-99999999.ebuild
+++ b/app-vim/exheres-syntax/exheres-syntax-99999999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,7 +6,7 @@ EAPI=6
inherit vim-plugin git-r3
DESCRIPTION="vim plugin: exheres format highlighting"
-HOMEPAGE="http://www.exherbo.org/"
+HOMEPAGE="https://www.exherbo.org/"
EGIT_REPO_URI="https://git.exherbo.org/git/exheres-syntax.git"
LICENSE="vim"
diff --git a/app-vim/gitgutter/Manifest b/app-vim/gitgutter/Manifest
index 4c0502c0a020..422ebba46a56 100644
--- a/app-vim/gitgutter/Manifest
+++ b/app-vim/gitgutter/Manifest
@@ -2,5 +2,5 @@ DIST gitgutter-20180316.tar.gz 46344 BLAKE2B f981753a0f8d066b7cb5c16c49cfdd1a1aa
DIST gitgutter-20180815.tar.gz 46741 BLAKE2B 85189390a2d8c5feaf8d2fabfd2c72bf79954fd1e9f2c3ffeca748e84caf13924f71ef5837ab62aef0ae003a01304305e73bbcb12dca27294c8164e960249fec SHA512 b6d3bd0f779d9afbd38df33888ab3ee0f1d8d10de0a6c5c6766f7f73a292cdd589a6774faa2871877075f6cedd29f14bba07c9a769d706e0e67d8817db86cfaa
EBUILD gitgutter-20180316.ebuild 789 BLAKE2B 5117f2eef5b3fac7d0edd8c84bce91362c796a28b6c75deb880741c7524da061c9060e3e175c7ffebd35bcd7b81fbfbecfad73585027c784289869ea99d1a56e SHA512 bef6a4759f414ac8d01bd7214fbbb868b5fdccbf2f68fc58aff2f1591a5e552cb912fe0e61ade6f25f287843d65760c6fcba04b091af1a726cd495e42211b253
EBUILD gitgutter-20180815.ebuild 791 BLAKE2B 43ecb9ad564614b597a3af65e92ff79e43910be3a3bb8303f26668bd26da7b5541c96284274c16f89f5708dca1d12fc3c0e2459777c46f7c1a4565442b7145dd SHA512 b032fc92d27d6c23ef0ce7a80e2778254fdd1a1d25f4f9a4f097050fcf6849afe55939575160403e784f32d46b12b0380807d5201b4db2c912794b9045868a0d
-EBUILD gitgutter-99999999.ebuild 791 BLAKE2B 1765bd9bdeb6234d90d831181bdf2ad0ef975edcfa959e7ea309c5522bdb6779163d1e5850a6715bcc8471db15c922125e80ec248d0ad822986657984475d4c8 SHA512 5b7fab9be3eabfe64a67535937883939ea3d1ba62184f55f25f18384ddf1d24416b22d1f88d6025d0b98249536984c6f8b6d0e9b7f0c467a64c14f34dfafde11
+EBUILD gitgutter-99999999.ebuild 766 BLAKE2B bc86221c26e432cbff853cc89c5486f6fab5eb9d5bfd334d1481fc2ae674a9f93a727688d541686f0722a3ca76c94b07bf7a0a211e37bdaca48930de1b2d15cc SHA512 7085549d5c06d53062f025ac634aafc1de70e290c297f5acc7edb3858f104ceae99cd3149af1479f74b2d1395a4df3689e5912b05463aa3e5cdffca9f7ef7250
MISC metadata.xml 346 BLAKE2B 89acd12a36beb7b027e42b7f094bba4e229e345ad6f0024bbd3e550784459975aff10e88f5de53de3f2150000b7349ee97348723110a43130b213404292b562a SHA512 4ada20b8f4f308445854b0e0ab229271a603e38370675691790dce0303ca4c2a7f00b247363b0f13bcebe78397fd3ebbbd157403260664171b548b8964da7a0a
diff --git a/app-vim/gitgutter/gitgutter-99999999.ebuild b/app-vim/gitgutter/gitgutter-99999999.ebuild
index 002f6583087d..472b9617df4c 100644
--- a/app-vim/gitgutter/gitgutter-99999999.ebuild
+++ b/app-vim/gitgutter/gitgutter-99999999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -25,6 +25,5 @@ src_prepare() {
default
# remove unwanted files
- rm LICENCE README* screenshot.png unplace.vim || die
- rm -r test || die
+ rm -rv LICENCE README* screenshot.png test || die
}
diff --git a/app-vim/notes/Manifest b/app-vim/notes/Manifest
index 04ee974aa4b1..9967f523bd97 100644
--- a/app-vim/notes/Manifest
+++ b/app-vim/notes/Manifest
@@ -1,3 +1,3 @@
DIST notes-0.33.4.tar.gz 239372 BLAKE2B f326c5d6adf25cce9261ac555541261750926c55f73d3a3f57885f7f03f9fae97e03f20882cb74f5fcd78b1ec06c2e0a5b1eb977aadf6a9771c679205a4a48e9 SHA512 7f2147e786582e69760c6d76d7144bc1fd0f8934ce6574184e16f463f5ca9c21e9e0fc87f88b56922b8195b26be7b0f99435cef773ccbc360077cf568b98b98a
-EBUILD notes-0.33.4.ebuild 688 BLAKE2B e222ddbabb1bc5791c7aad52f476d9cc19cf70c8cc25decce0d59e6ecf544d5593ae04ad3a732945012635f85dd00186639d8be399e1a062ca8eda0a6db24c67 SHA512 e643ca31ca9124cc94db3727999fe66189233c2ce3985d66b036fa9493e839da7e053b3deba489be3aecf42371f8825126f79463d414fb418d1cd1c0f54640bb
+EBUILD notes-0.33.4-r1.ebuild 709 BLAKE2B a042e2ba158971a026b5dbdb11721510c2963a2ca44f7fc3407e6b70f6845427f9768057809d1916f7b1a1b55b7da4711808645f08de35a7aeb8fb50fac8adf0 SHA512 1f1bb3192f9504a9255c4210f0bd55cf8f951d4ae3206552a18043889ed0bc4e5f6414d3c5e755bf42b7853aa0ea1be25e3e8c24813ccaee669a52d8a29b95d3
MISC metadata.xml 339 BLAKE2B 7d1ee9c5de677bd78ad2a5e0bca15deb9dc48bbfa56c7da216d47c0924fdab4e28c9db8878177471d2d4a7504770cf0395fd03a786d807971d07b61c31d8d7bb SHA512 ebc2c6981c7bb2ad9c8281e69d29203e5700bd5b930ee17feb16e5f1f581eb164971bcfc5584eb639404d70e2f13a3b8c51f4514759798ecc47ee8ec4776bbd1
diff --git a/app-vim/notes/notes-0.33.4.ebuild b/app-vim/notes/notes-0.33.4-r1.ebuild
index 9006ecc51f8c..d436975d1828 100644
--- a/app-vim/notes/notes-0.33.4.ebuild
+++ b/app-vim/notes/notes-0.33.4-r1.ebuild
@@ -1,30 +1,35 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="sqlite"
-inherit python-single-r1 vim-plugin
+inherit vim-plugin python-single-r1
DESCRIPTION="vim plugin: easy note taking in vim"
HOMEPAGE="http://peterodding.com/code/vim/notes/"
SRC_URI="https://github.com/xolox/vim-notes/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
+
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}
- >=app-vim/vim-misc-1.17.6"
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-vim/vim-misc"
VIM_PLUGIN_HELPFILES="${PN}.txt"
-S=${WORKDIR}/vim-${P}
+S="${WORKDIR}/vim-${P}"
src_prepare() {
+ default
+
# remove unnecessary files
rm addon-info.json INSTALL.md README.md || die
- python_fix_shebang .
+ python_fix_shebang "${S}"
}
diff --git a/app-vim/pyclewn/Manifest b/app-vim/pyclewn/Manifest
index 0925548ec74d..ff3be219f23b 100644
--- a/app-vim/pyclewn/Manifest
+++ b/app-vim/pyclewn/Manifest
@@ -1,3 +1,3 @@
DIST pyclewn-2.1.tar.gz 129697 BLAKE2B 0dfef92cb36ea9fa89c7f0d85ed45e21c634732fc2d3d888dd792de22529bea86719f8ac8ed870dd5ab00efbfdb08011013a36880781abf9e0c64a62b2aa301a SHA512 346b98a9e37957a5bf97b8901247f56fa8e38bddac38727867773cf4e78e555d6a85848c4c400d1faf1159ba61122cfd4931c95a67e3b2abdfaae7996beb4f1b
-EBUILD pyclewn-2.1-r1.ebuild 934 BLAKE2B d7021c1f48fc67a74433389eccac41441b1b12c4fe246dc79685e2a42250b4fd44299f9c92b83ec7b82ab600d92d6492de2432469b387f349f86730eea38432d SHA512 4a77578d914d36a2976546b4c06f744206099b3c9d5cdf2a085ecb90f143214d3780299bb7c6eecb599c6759f78788e90cd3b38c61b0baff4ff7d6661be571ca
+EBUILD pyclewn-2.1-r2.ebuild 1043 BLAKE2B 8486be082ed725b74a9201ec5cff0e8f426841819f661b345a47a887997d752fba66288e16cffaeef59fcb1f79637ea59841158587d261b7447f0bd019cbb82e SHA512 d65597aa71406e979c0f2b134c225e9fd9092eebf14a12566dac4ba47b5389061bc55c99ffefb48aa38c70ef94f9f921fd59049b1e8d2dddffce2894c34c5f41
MISC metadata.xml 499 BLAKE2B 4955bd7a080dc2ae909143477040d191cb48ab4badfd47b6b7c11fd4686139bbbe77475f005e10c3b2bba50d0615b94600a55cda57a7d02ecaaffe1e504219dd SHA512 30b127677f0d5a9afce208e5cbb00c9b98f6d7e771ef273155f9acad764da789e71249289104e8006420cf5ff62075bb7572527150f9b339e0e51cb219c76a81
diff --git a/app-vim/pyclewn/pyclewn-2.1-r1.ebuild b/app-vim/pyclewn/pyclewn-2.1-r2.ebuild
index 67459d86ff7e..e57e74a67364 100644
--- a/app-vim/pyclewn/pyclewn-2.1-r1.ebuild
+++ b/app-vim/pyclewn/pyclewn-2.1-r2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-inherit eutils vim-plugin distutils-r1
+inherit vim-plugin distutils-r1
SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
@@ -14,9 +14,11 @@ HOMEPAGE="http://pyclewn.sourceforge.net/"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
CDEPEND="|| (
- >=app-editors/vim-7.3
- >=app-editors/gvim-7.3[netbeans]
+ app-editors/vim
+ app-editors/gvim[netbeans]
)"
DEPEND="
@@ -26,15 +28,19 @@ DEPEND="
RDEPEND="
${DEPEND}"
-SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-#Completely broken (runs vim), disable for now
-#python_test() {
-# esetup.py test
-#}
+src_prepare() {
+ default
+
+ # async in a now a reserved keyword.
+ sed -e 's#async#_async#g;' \
+ -i lib/clewn/gdb.py || die "can't patch gdb.py"
+}
python_install_all() {
distutils-r1_python_install_all
+ python_optimize
vimball -x -C "${ED}"/usr/share/vim/vimfiles lib/clewn/runtime/${P}.vmb || die "Extracting vimball failed"
}
diff --git a/app-vim/vim-latex/Manifest b/app-vim/vim-latex/Manifest
index e3904181e9be..6a7da8105632 100644
--- a/app-vim/vim-latex/Manifest
+++ b/app-vim/vim-latex/Manifest
@@ -1,3 +1,4 @@
DIST vim-latex-1.10.0.tar.gz 260820 BLAKE2B 2314ad5ded3bea51def3172e8f2b7a7483839b58804f9d8c1cc1c8f1139c1da731f91525691d47dba57d07a7db85c371e87c5ce0d3d22a004a9402df7e7cad3a SHA512 1d22b675c124e402a280dcc3a675b49a92fb9f4d42efdda0ea97be26379cd6c023589a35e165f4231524d853380e22411901bfbcc98f171c938ba800821a1213
EBUILD vim-latex-1.10.0-r1.ebuild 1569 BLAKE2B 528be5ca5ef37bad2794a1f8990bc768b6d47fd8427609fd574311d6474306c5a087d4ddfc1669f36dcbfc26434f704887f9ac7ad197585fea4023ffef906676 SHA512 33daa51732a577e0f75cdf70d591fa8008eaae823473813ea7d293a614987389333a941baf05364b18bb1d4f3440b8308e0a8c934a72e1696a07e18e940c4650
+EBUILD vim-latex-1.10.0-r2.ebuild 1577 BLAKE2B d8619c6debee550dc49df52b0db4555408aa77e07a958c6d0eeb9b13f8ac44bc07285e1f9e67a46c7d744262ab02ea59a7e00f70dcc5b5e2ad6e5e8176efd1eb SHA512 a1ac6495641601608159b9237faa3f47d478c272cbe4a275bc0d2f7807f6cece5bfa7756efb19bd84dd694086a0a897218e5d467c7c0dce75f82c884d5391812
MISC metadata.xml 328 BLAKE2B bcf4c9979e43da6c141669c218e852e7a0c062d900c35790709e393f6cabc56f646f7a84e8057d9dbafa0a73e5786135a7cfe3ef825af867500bcd502f03a61f SHA512 e14b88742b6d8143cb578ddac61dbc0ac5e84c90659e8d9b5c40882ebdf35dc001b1ffae26eb90617434b2c8a898055c838738bf7cf18a45cd2a2ce66a30bdce
diff --git a/app-vim/vim-latex/vim-latex-1.10.0-r2.ebuild b/app-vim/vim-latex/vim-latex-1.10.0-r2.ebuild
new file mode 100644
index 000000000000..ed03b0f51f16
--- /dev/null
+++ b/app-vim/vim-latex/vim-latex-1.10.0-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="A comprehensive set of tools to view, edit and compile LaTeX documents"
+HOMEPAGE="http://vim-latex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ || (
+ app-editors/vim[python,${PYTHON_SINGLE_USEDEP}]
+ app-editors/gvim[python,${PYTHON_SINGLE_USEDEP}]
+ )
+ virtual/latex-base
+ !app-vim/vimtex"
+
+VIM_PLUGIN_HELPFILES="latex-suite.txt latex-suite-quickstart.txt latexhelp.txt imaps.txt"
+
+src_compile() { :; }
+
+src_install() {
+ # remove unused metadata
+ rm vim-latex.metainfo.xml || die
+
+ # don't mess up vim's doc dir with random files
+ mv doc mydoc || die
+ mkdir doc || die
+ mv mydoc/*.txt doc/ || die
+ rm -rf mydoc || die
+
+ # don't install buggy tags scripts, use ctags instead
+ rm latextags ltags || die
+
+ vim-plugin_src_install
+
+ # use executable permissions (bug #352403)
+ fperms a+x /usr/share/vim/vimfiles/ftplugin/latex-suite/outline.py
+
+ python_fix_shebang "${ED}"
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ echo
+ elog "To use the vim-latex plugin add:"
+ elog " filetype plugin on"
+ elog ' set grepprg=grep\ -nH\ $*'
+ elog " let g:tex_flavor='latex'"
+ elog "to your ~/.vimrc-file"
+ echo
+ fi
+}
diff --git a/app-vim/vimoutliner/Manifest b/app-vim/vimoutliner/Manifest
index 3ff2e4eecad6..8d94547740a3 100644
--- a/app-vim/vimoutliner/Manifest
+++ b/app-vim/vimoutliner/Manifest
@@ -3,5 +3,5 @@ DIST vimoutliner-0.3.6.tar.gz 210251 BLAKE2B d50b3d1c752fba80e26d7430801baf30a79
DIST vimoutliner-0.4.0_p20180301.tar.gz 367361 BLAKE2B a97df5c154e6ed9b3209bd90bd57b4166877f02b9513351fda0e841de84334a1e592e1ed56b46cc59bc6bb64f3c763cdca81df3f8696f3c348a8ef4744124c02 SHA512 f9f369e7e7f09dac04b58a27a86dc2121b3aacd0002537db348517e779fd1b7c9e88ae905b4b42aace10f79cb8f91acada1ad58e26f2257e46d1af98347eab62
EBUILD vimoutliner-0.3.6-r1.ebuild 692 BLAKE2B eaba6b518a890480abaac5eb234a0ff96a37d93f03f0f323aeed19b754f6a77267b97619aa0e30e8f10d320af2d8e0ed3235d25ab442e1933af659485039d2c8 SHA512 7b66c1a82d6537e631f9ef4268f375e4c4b883a973be0492689580de46b39f70220588dff9b2eb31edd1f8e262f4faf11ab2e5c100a449cb5074ee4f5e5333cc
EBUILD vimoutliner-0.3.6-r3.ebuild 1330 BLAKE2B 021a5c03383c7b23d98b2076f8139ca9e311e8710c234cc6c257817707660425f382e2b9011f8513f56674901d4617da19719ba1f89b396e01c7adb366e79dd2 SHA512 8e6762e23b3c0c423784401d77309fa5bf9b68361f9c1493a1f632520a83450b21adc457c9b0e5d6116b805156ce389c053fed37686c05e7826d42c2eb25b990
-EBUILD vimoutliner-0.4.0_p20180301-r2.ebuild 1148 BLAKE2B cfa5d5fcd95ee8924480ee8787918eaf3693dce75d4b9cb2fbef9e22a80eb5c4b5de5e5970daadc010106f129e53e5d690668f67ddb8a4b57f3deb84e053e3e9 SHA512 8b4859df3548df3eb93bb05fbe6e60822511e0bf6935358966fb4b2dbe34aac54b0381e9155d888ec90f694a8de1adce00185eb3857cad609baf47c6b2312418
+EBUILD vimoutliner-0.4.0_p20180301-r2.ebuild 1263 BLAKE2B 11d197e2641bdf5f335e641b797fddaec23b6be79819062711c6b7b44e0e56e422187af2c43793c6c3aca6092baad3f02c48a2b9ae537053d1beb96570bea51d SHA512 307a8c310122890a3a2729c2299b7354e4f85b12c25aa7b13564233b0a0b33b4d240100525fa469fd937885d7138f25d389b79bf1d80cba429661402d251d62a
MISC metadata.xml 337 BLAKE2B c4ae899109190b6ad14fcc71ff0dbea76f7ab6b731992174b4623847291d63bb8cbdc7e73cd92343beafdba086e0b54c4cda686593ef8b836f8add578b0459d0 SHA512 782f682a6837436ee5db28f818b2168035fbae243aa466077053e17842fec96672d702b818ad28a9f1d0b8fa1a1e2fb79b056d2e31bc09d5bf522d5f18ea1c7b
diff --git a/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301-r2.ebuild b/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301-r2.ebuild
index e35b5c0b1473..0e9694fa01f4 100644
--- a/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301-r2.ebuild
+++ b/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
inherit python-single-r1 vim-plugin vcs-snapshot
@@ -22,16 +22,19 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
VIM_PLUGIN_HELPFILES="vimoutliner"
VIM_PLUGIN_MESSAGES="filetype"
-RDEPEND="${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/autopep8[${PYTHON_MULTI_USEDEP}]
- ')"
-DEPEND="${RDEPEND}"
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/autopep8[${PYTHON_MULTI_USEDEP}]')
+"
+
+DEPEND="
+ ${RDEPEND}"
src_prepare() {
default
- sed -i -e '1s:^:#!/usr/bin/python\n:' vimoutliner/scripts/otl2latex/otl2latex.py || die
+ sed -e '1s:^:#!/usr/bin/python\n:' \
+ -i "${S}"/vimoutliner/scripts/otl2latex/otl2latex.py || die
find "${S}" -type f -exec chmod a+r {} \; || die
}
@@ -39,7 +42,9 @@ src_compile() {
local pyscript _pyscript
for pyscript in $(find "${S}" -type f -name \*.py); do
_pyscript=$(basename "${pyscript}")
- [ ${_pyscript} == "otl.py" ] && continue
- python_fix_shebang -q "${pyscript}"
+ [[ ${_pyscript} == "otl.py" ]] && continue
+ 2to3 -w -n --no-diffs "${pyscript}" >& /dev/null || die
+ python_fix_shebang -f -q "${pyscript}"
done
+ rm -v README.detailed || die
}