summaryrefslogtreecommitdiff
path: root/app-vim/repeat/repeat-1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/repeat/repeat-1.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/repeat/repeat-1.1.ebuild')
-rw-r--r--app-vim/repeat/repeat-1.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-vim/repeat/repeat-1.1.ebuild b/app-vim/repeat/repeat-1.1.ebuild
new file mode 100644
index 000000000000..c2506991860e
--- /dev/null
+++ b/app-vim/repeat/repeat-1.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vim-plugin
+
+MY_PN="vim-repeat"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="vim plugin: use the repeat command \".\" with plugin maps"
+HOMEPAGE="https://github.com/tpope/vim-repeat/ https://www.vim.org/scripts/script.php?script_id=2136"
+SRC_URI="https://github.com/tpope/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="amd64 x86"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ rm *.markdown || die
+}