summaryrefslogtreecommitdiff
path: root/app-vim/repeat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/repeat
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/repeat')
-rw-r--r--app-vim/repeat/Manifest3
-rw-r--r--app-vim/repeat/metadata.xml11
-rw-r--r--app-vim/repeat/repeat-1.1.ebuild21
3 files changed, 35 insertions, 0 deletions
diff --git a/app-vim/repeat/Manifest b/app-vim/repeat/Manifest
new file mode 100644
index 000000000000..4246ab9ecc14
--- /dev/null
+++ b/app-vim/repeat/Manifest
@@ -0,0 +1,3 @@
+DIST repeat-1.1.tar.gz 2621 BLAKE2B 22573f49d69ca5b798c9e6e480c605a6de515cde40913b73ce7db2f0a045e14b850d5ed00fc960b1214f851c138763f89e0d43ca78e7f0961cfaa3721c072d8a SHA512 9df73c7049f38a93da5e6bd36dc0fe833ec23394540de1b6929159910ec9f18af2a76211af612bc8f3c92d9c7f2faacd72a65d7d593584689ac6a7068df60bf9
+EBUILD repeat-1.1.ebuild 529 BLAKE2B de9f5792d816291cd4c29c54289a25d0888ae921afb622a85ffb763112e70f3b44018b2dbbc7cc1a1383a768d0c2a6904806bb3b422fe8e5a04252bd8bc4c9a9 SHA512 4890212fd43d9a5b8b744849e88b1939655d233d313be2848787fa40742a79146914c0d12acf2ffb88c571fb0d9795e6045cc64c47bd0037997cd0f311c7b68d
+MISC metadata.xml 340 BLAKE2B 57a4452d4baca17d9de632e2df1edfac3987af64fe3e920810fd01ded99b9a745267e658c7596d7a2f67cf6987fca3652e96a093ebaf625ec659da4a9c06a32a SHA512 126d76f034905a45118eaf05237228af870c065ed967ead33818101d13dad96cfa6ccdccbb4e394e69fe5d698bce0ffbbd4c03315a11866c9b56f5189dbfb6fd
diff --git a/app-vim/repeat/metadata.xml b/app-vim/repeat/metadata.xml
new file mode 100644
index 000000000000..c61e73016706
--- /dev/null
+++ b/app-vim/repeat/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tpope/vim-repeat</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/repeat/repeat-1.1.ebuild b/app-vim/repeat/repeat-1.1.ebuild
new file mode 100644
index 000000000000..c2506991860e
--- /dev/null
+++ b/app-vim/repeat/repeat-1.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vim-plugin
+
+MY_PN="vim-repeat"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="vim plugin: use the repeat command \".\" with plugin maps"
+HOMEPAGE="https://github.com/tpope/vim-repeat/ https://www.vim.org/scripts/script.php?script_id=2136"
+SRC_URI="https://github.com/tpope/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="amd64 x86"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ rm *.markdown || die
+}