summaryrefslogtreecommitdiff
path: root/app-vim/notes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /app-vim/notes
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'app-vim/notes')
-rw-r--r--app-vim/notes/Manifest2
-rw-r--r--app-vim/notes/notes-0.33.4-r1.ebuild (renamed from app-vim/notes/notes-0.33.4.ebuild)23
2 files changed, 15 insertions, 10 deletions
diff --git a/app-vim/notes/Manifest b/app-vim/notes/Manifest
index 04ee974aa4b1..9967f523bd97 100644
--- a/app-vim/notes/Manifest
+++ b/app-vim/notes/Manifest
@@ -1,3 +1,3 @@
DIST notes-0.33.4.tar.gz 239372 BLAKE2B f326c5d6adf25cce9261ac555541261750926c55f73d3a3f57885f7f03f9fae97e03f20882cb74f5fcd78b1ec06c2e0a5b1eb977aadf6a9771c679205a4a48e9 SHA512 7f2147e786582e69760c6d76d7144bc1fd0f8934ce6574184e16f463f5ca9c21e9e0fc87f88b56922b8195b26be7b0f99435cef773ccbc360077cf568b98b98a
-EBUILD notes-0.33.4.ebuild 688 BLAKE2B e222ddbabb1bc5791c7aad52f476d9cc19cf70c8cc25decce0d59e6ecf544d5593ae04ad3a732945012635f85dd00186639d8be399e1a062ca8eda0a6db24c67 SHA512 e643ca31ca9124cc94db3727999fe66189233c2ce3985d66b036fa9493e839da7e053b3deba489be3aecf42371f8825126f79463d414fb418d1cd1c0f54640bb
+EBUILD notes-0.33.4-r1.ebuild 709 BLAKE2B a042e2ba158971a026b5dbdb11721510c2963a2ca44f7fc3407e6b70f6845427f9768057809d1916f7b1a1b55b7da4711808645f08de35a7aeb8fb50fac8adf0 SHA512 1f1bb3192f9504a9255c4210f0bd55cf8f951d4ae3206552a18043889ed0bc4e5f6414d3c5e755bf42b7853aa0ea1be25e3e8c24813ccaee669a52d8a29b95d3
MISC metadata.xml 339 BLAKE2B 7d1ee9c5de677bd78ad2a5e0bca15deb9dc48bbfa56c7da216d47c0924fdab4e28c9db8878177471d2d4a7504770cf0395fd03a786d807971d07b61c31d8d7bb SHA512 ebc2c6981c7bb2ad9c8281e69d29203e5700bd5b930ee17feb16e5f1f581eb164971bcfc5584eb639404d70e2f13a3b8c51f4514759798ecc47ee8ec4776bbd1
diff --git a/app-vim/notes/notes-0.33.4.ebuild b/app-vim/notes/notes-0.33.4-r1.ebuild
index 9006ecc51f8c..d436975d1828 100644
--- a/app-vim/notes/notes-0.33.4.ebuild
+++ b/app-vim/notes/notes-0.33.4-r1.ebuild
@@ -1,30 +1,35 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="sqlite"
-inherit python-single-r1 vim-plugin
+inherit vim-plugin python-single-r1
DESCRIPTION="vim plugin: easy note taking in vim"
HOMEPAGE="http://peterodding.com/code/vim/notes/"
SRC_URI="https://github.com/xolox/vim-notes/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
+
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}
- >=app-vim/vim-misc-1.17.6"
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-vim/vim-misc"
VIM_PLUGIN_HELPFILES="${PN}.txt"
-S=${WORKDIR}/vim-${P}
+S="${WORKDIR}/vim-${P}"
src_prepare() {
+ default
+
# remove unnecessary files
rm addon-info.json INSTALL.md README.md || die
- python_fix_shebang .
+ python_fix_shebang "${S}"
}